Okay, I have made some progress getting calls in and out of asterisk with
the mc3810. I think the problem lies in how the switch is sending me the
did digits. I am receiving "*6125551212**4418*" from the switch (the
612... being the caller id, 4418 the did#), the cisco matches *612555 with
the pots dial peer I have setup for outgoing calls and tries to make an
outgoing call to *612555. Does anyone know how I can build a dial peer with
a destination pattern that will strip off all of the extra stuff and just
process the 4 digit did?
Thanks
Jason
----- Original Message -----
From: "Jason Brockman" <jason@routerheads.com>
To: <asterisk-users@lists.digium.com>
Sent: Monday, November 29, 2004 5:47 PM
Subject: [Asterisk-Users] Cisco gateway help needed
> HI,
>
> I have been pulling my hair out trying to get a Cisco MC3810 to interface
my> Asterisk box with a T1.
> I am able to make outgoing calls but incoing calls never reach my Asterisk
> box. The cisco give a fast busy when I try to call one of the DID's.
When> playing around with the dial-peers I can get the cisco to pick up the
call,> but then it forwards the call back to the ANI that is dialing. I know the
> T1 is good because I hooked it up to a Nortel KSU and the DID's work
fine.
>
> I am receiving 4 digits and the T1 only has 4 ds0's.
>
> I have attached a sho run, any help would be appreciated.
>
> TIA,
> Jason
>
> service timestamps debug uptime
> service timestamps log uptime
> service password-encryption
> !
> hostname gw1
> !
> boot-start-marker
> boot system tftp mc3810-a2isv5-mz.123-10a.bin 192.168.5.104
> boot-end-marker
>
> network-clock base-rate 56k
> no aaa new-model
> ip subnet-zero
> !
> voice class codec 10
> codec preference 1 g711ulaw
> codec preference 2 g711alaw
> codec preference 4 g729r8
> codec preference 6 g729ar8
> !
> !
> no voice confirmation-tone
> !
> controller T1 0
> mode cas
> framing esf
> linecode b8zs
> ds0-group 1 timeslots 1-4 type e&m-wink-start
> fdl both
> !
> controller T1 1
> mode cas
> framing esf
> linecode b8zs
> ds0-group 1 timeslots 1-4 type e&m-wink-start
> !
> !
> !
> interface Tunnel1
> no ip address
> !
> interface Ethernet0
> ip address xx.xx.xx.xx 255.255.255.248
> !
> interface Serial0
> no ip address
> shutdown
> !
> interface Serial1
> no ip address
> shutdown
> !
> interface FR-ATM20
> no ip address
> shutdown
> !
> ip default-gateway xx.xx.xx.xx
> ip classless
> ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx
> no ip http server
> !
> !
> !
> snmp-server community xxxxxx RO
> !
> voice-port 0:1
> !
> voice-port 1:1
> !
> !
> !
> dial-peer voice 1 voip
> destination-pattern T
> progress_ind setup enable 3
> progress_ind progress enable 8
> voice-class codec 10
> session protocol sipv2
> session target ipv4:xx.xx.xx.xx
> session transport udp
> dtmf-relay rtp-nte
> no vad
> !
> dial-peer voice 110 pots
> incoming called-number ....
> direct-inward-dial
> !
> dial-peer voice 100 pots
> destination-pattern .......
> port 0:1
> !
> sip-ua
> retry invite 3
> retry cancel 2
> sip-server ipv4:xx.xx.xx.xx:5060
> !
> !
> line con 0
> transport preferred all
> transport output all
> line aux 0
> transport preferred all
> transport output all
> line 2 3
> transport preferred all
> transport output all
> line vty 0 4
> login local
> transport preferred all
> transport input all
> transport output all
> !
> ntp server xx.xx.xx.xx
> end
>
> gw1#
>
> _______________________________________________
> Asterisk-Users mailing list
> Asterisk-Users@lists.digium.com
> http://lists.digium.com/mailman/listinfo/asterisk-users
> To UNSUBSCRIBE or update options visit:
> http://lists.digium.com/mailman/listinfo/asterisk-users
>