Hi, I am struggling with ZFS/ACL on indiana preview. (ps: I am new to ZFS, new to indiana, and generally incompetent on Solaris admin commands:-) First of, I am a bit surprised the ''old'' setfacl command does not work on ZFS: setfacl -m user:ludo:rw- /etc/apache2/2.2/httpd.conf File system doesn''t support aclent_t style ACL''s. See acl(5) for more information on ACL styles support by Solaris. So I try the chmod (based on google search http://www.cims.nyu.edu/cgi-comment/man.cgi?section=1&topic=chmod or http://blogs.sun.com/lisaweek ) I do: chmod A+user:ludo:read_data:rwx php.ini chmod: invalid mode: `A+user:ludo:read_data:rwx'' Try `chmod --help'' for more information. or chmod A+user:ludo:read_data:allow php.ini chmod: invalid mode: `A+user:ludo:read_data:allow'' Try `chmod --help'' for more information. or: ls -v php.ini ls -v php.ini php.ini (note the lack of ACL info displayed there) Then man chmod Miscellaneous missing(x) missing - Missing Manual Page DESCRIPTION Unfortunately, this OpenSolaris Developer Preview does not include the manual page you are looking for. We''re sorry and hope to improve upon this situation in future releases. Online versions of many manual pages are available at http://docs.sun.com/app/docs/coll/40.17. SunOS 5.11 Last change: 07/10/25 1 I try to understand how people would react to this incompatible setfacl command on an indiana system with zfs : How would you write a script to change acl for a user for both zfs and non zfs system (i.e SXDE default installation or Indiana default installation): https://www.phillconrad.org/cisc474/Wiki.jsp?page=AccessControlLists) What is the good way for doing this? So how can I write a portable script (with or without zfs) that would take a user name as a parameter and would add rwx rights to the file /foo? Why setfacl could not be adapted to work on ZFS, as if I am guessing correctly, there should be a simple mapping from the limited setfacl options to the mega-extended chmod options for ZFS? Thanks for some pointers or some help, Ludo
What does ''which chmod'' show? I think that Indiana chose to have /usr/gnu/bin at the head of the path, so you''re probably picking up the GNU chmod, which doesn''t handle NFSv4 ACLs. Manually running /usr/bin/chmod should solve your problem. - Eric On Wed, Dec 19, 2007 at 09:13:25AM -0800, ludo wrote:> Hi, > > I am struggling with ZFS/ACL on indiana preview. (ps: I am new to ZFS, > new to indiana, and generally incompetent on Solaris admin commands:-) > > First of, I am a bit surprised the ''old'' setfacl command does not work > on ZFS: > > setfacl -m user:ludo:rw- /etc/apache2/2.2/httpd.conf > File system doesn''t support aclent_t style ACL''s. > See acl(5) for more information on ACL styles support by Solaris. > > > So I try the chmod (based on google search > http://www.cims.nyu.edu/cgi-comment/man.cgi?section=1&topic=chmod > or http://blogs.sun.com/lisaweek ) > > I do: > chmod A+user:ludo:read_data:rwx php.ini > chmod: invalid mode: `A+user:ludo:read_data:rwx'' > Try `chmod --help'' for more information. > > or > chmod A+user:ludo:read_data:allow php.ini > chmod: invalid mode: `A+user:ludo:read_data:allow'' > Try `chmod --help'' for more information. > > or: > ls -v php.ini > > ls -v php.ini > php.ini > > (note the lack of ACL info displayed there) > > Then > > man chmod > > Miscellaneous missing(x) > missing - Missing Manual Page > DESCRIPTION > Unfortunately, this OpenSolaris Developer Preview does not > include the manual page you are looking for. We''re sorry > and hope to improve upon this situation in future releases. > Online versions of many manual pages are available at > http://docs.sun.com/app/docs/coll/40.17. > > SunOS 5.11 Last change: 07/10/25 1 > > > I try to understand how people would react to this incompatible setfacl > command on an indiana system with zfs : > > How would you write a script to change acl for a user for both zfs and > non zfs system (i.e SXDE default installation or Indiana default > installation): > https://www.phillconrad.org/cisc474/Wiki.jsp?page=AccessControlLists) > What is the good way for doing this? > > So how can I write a portable script (with or without zfs) that would > take a user name as a parameter and would add rwx rights to the file /foo? > > Why setfacl could not be adapted to work on ZFS, as if I am guessing > correctly, there should be a simple mapping from the limited setfacl > options to the mega-extended chmod options for ZFS? > > Thanks for some pointers or some help, > Ludo > > _______________________________________________ > zfs-discuss mailing list > zfs-discuss at opensolaris.org > http://mail.opensolaris.org/mailman/listinfo/zfs-discuss-- Eric Schrock, FishWorks http://blogs.sun.com/eschrock
Eric Schrock wrote:> What does ''which chmod'' show? I think that Indiana chose to have > /usr/gnu/bin at the head of the path, so you''re probably picking up the > GNU chmod, which doesn''t handle NFSv4 ACLs. Manually running > /usr/bin/chmod should solve your problem. >correct for chmod... I can go further. Thanks. Any pointers to the way to detect zfs fs? Would mount -p |grep "/ ufs" be a valid test for testing /var content? Ludo> - Eric > > On Wed, Dec 19, 2007 at 09:13:25AM -0800, ludo wrote: > >> Hi, >> >> I am struggling with ZFS/ACL on indiana preview. (ps: I am new to ZFS, >> new to indiana, and generally incompetent on Solaris admin commands:-) >> >> First of, I am a bit surprised the ''old'' setfacl command does not work >> on ZFS: >> >> setfacl -m user:ludo:rw- /etc/apache2/2.2/httpd.conf >> File system doesn''t support aclent_t style ACL''s. >> See acl(5) for more information on ACL styles support by Solaris. >> >> >> So I try the chmod (based on google search >> http://www.cims.nyu.edu/cgi-comment/man.cgi?section=1&topic=chmod >> or http://blogs.sun.com/lisaweek ) >> >> I do: >> chmod A+user:ludo:read_data:rwx php.ini >> chmod: invalid mode: `A+user:ludo:read_data:rwx'' >> Try `chmod --help'' for more information. >> >> or >> chmod A+user:ludo:read_data:allow php.ini >> chmod: invalid mode: `A+user:ludo:read_data:allow'' >> Try `chmod --help'' for more information. >> >> or: >> ls -v php.ini >> >> ls -v php.ini >> php.ini >> >> (note the lack of ACL info displayed there) >> >> Then >> >> man chmod >> >> Miscellaneous missing(x) >> missing - Missing Manual Page >> DESCRIPTION >> Unfortunately, this OpenSolaris Developer Preview does not >> include the manual page you are looking for. We''re sorry >> and hope to improve upon this situation in future releases. >> Online versions of many manual pages are available at >> http://docs.sun.com/app/docs/coll/40.17. >> >> SunOS 5.11 Last change: 07/10/25 1 >> >> >> I try to understand how people would react to this incompatible setfacl >> command on an indiana system with zfs : >> >> How would you write a script to change acl for a user for both zfs and >> non zfs system (i.e SXDE default installation or Indiana default >> installation): >> https://www.phillconrad.org/cisc474/Wiki.jsp?page=AccessControlLists) >> What is the good way for doing this? >> >> So how can I write a portable script (with or without zfs) that would >> take a user name as a parameter and would add rwx rights to the file /foo? >> >> Why setfacl could not be adapted to work on ZFS, as if I am guessing >> correctly, there should be a simple mapping from the limited setfacl >> options to the mega-extended chmod options for ZFS? >> >> Thanks for some pointers or some help, >> Ludo >> >> _______________________________________________ >> zfs-discuss mailing list >> zfs-discuss at opensolaris.org >> http://mail.opensolaris.org/mailman/listinfo/zfs-discuss >> > > -- > Eric Schrock, FishWorks http://blogs.sun.com/eschrock >
> What does ''which chmod'' show? I think that Indiana > chose to have > /usr/gnu/bin at the head of the path, so you''re > probably picking up the > GNU chmod, which doesn''t handle NFSv4 ACLs. Manually > running > /usr/bin/chmod should solve your problem.Would it be better if this issue is brought to indiana-discuss? Not to start a fresh round of PATH war, the point is either to make /usr/gnu/bin utilities compatible with /usr/bin ones, or no scripts in Indiana should safely *assume* everyone will have /usr/gnu/bin before /usr/bin (or every scripts do export PATH=$its_own_like) Ivan.> > - Eric > > On Wed, Dec 19, 2007 at 09:13:25AM -0800, ludo wrote: > > Hi, > > > > I am struggling with ZFS/ACL on indiana preview. > (ps: I am new to ZFS, > > new to indiana, and generally incompetent on > Solaris admin commands:-) > > > > First of, I am a bit surprised the ''old'' setfacl > command does not work > > on ZFS: > > > > setfacl -m user:ludo:rw- > /etc/apache2/2.2/httpd.conf > > File system doesn''t support aclent_t style ACL''s. > > See acl(5) for more information on ACL styles > support by Solaris. > > > > > > So I try the chmod (based on google search > > > http://www.cims.nyu.edu/cgi-comment/man.cgi?section=1& > topic=chmod > > or http://blogs.sun.com/lisaweek ) > > > > I do: > > chmod A+user:ludo:read_data:rwx php.ini > > chmod: invalid mode: `A+user:ludo:read_data:rwx'' > > Try `chmod --help'' for more information. > > > > or > > chmod A+user:ludo:read_data:allow php.ini > > chmod: invalid mode: `A+user:ludo:read_data:allow'' > > Try `chmod --help'' for more information. > > > > or: > > ls -v php.ini > > > > ls -v php.ini > > php.ini > > > > (note the lack of ACL info displayed there) > > > > Then > > > > man chmod > > > > Miscellaneous > missing(x) > CRIPTION > > Unfortunately, this OpenSolaris Developer > Preview does not > > include the manual page you are looking for. > We''re sorry > and hope to improve upon this situation in > future releases. > Online versions of many manual pages are > available at > http://docs.sun.com/app/docs/coll/40.17. > SunOS 5.11 Last change: 07/10/25 > 1 > erstand how people would react to this incompatible > setfacl > > command on an indiana system with zfs : > > > > How would you write a script to change acl for a > user for both zfs and > > non zfs system (i.e SXDE default installation or > Indiana default > > installation): > > > https://www.phillconrad.org/cisc474/Wiki.jsp?page=Acce > ssControlLists) > > What is the good way for doing this? > > > > So how can I write a portable script (with or > without zfs) that would > > take a user name as a parameter and would add rwx > rights to the file /foo? > > > > Why setfacl could not be adapted to work on ZFS, as > if I am guessing > > correctly, there should be a simple mapping from > the limited setfacl > > options to the mega-extended chmod options for ZFS? > > > > Thanks for some pointers or some help, > > Ludo > > > > _______________________________________________ > > zfs-discuss mailing list > > zfs-discuss at opensolaris.org > > > http://mail.opensolaris.org/mailman/listinfo/zfs-discu > ss > > -- > Eric Schrock, FishWorks > http://blogs.sun.com/eschrock > ________________________ > zfs-discuss mailing list > zfs-discuss at opensolaris.org > http://mail.opensolaris.org/mailman/listinfo/zfs-discu > ssThis message posted from opensolaris.org
On Thu, Dec 20, 2007 at 04:19:52AM -0800, Ivan Wang wrote:> > What does ''which chmod'' show? I think that Indiana > > chose to have > > /usr/gnu/bin at the head of the path, so you''re > > probably picking up the > > GNU chmod, which doesn''t handle NFSv4 ACLs. Manually > > running > > /usr/bin/chmod should solve your problem. > > Would it be better if this issue is brought to indiana-discuss? Not > to start a fresh round of PATH war, the point is either to make > /usr/gnu/bin utilities compatible with /usr/bin ones, or no scripts in > Indiana should safely *assume* everyone will have /usr/gnu/bin before > /usr/bin (or every scripts do export PATH=$its_own_like)Yes, please take any philosophical discussions about the choice of PATH (or the compatibility of GNU utilities) to indiana-discuss. I was just pointing out the solution to this particular problem ;-) - Eric -- Eric Schrock, FishWorks http://blogs.sun.com/eschrock
Ivan Wang
2007-Dec-21 02:25 UTC
[zfs-discuss] /usr/gnu/bin compatibility [Was: Re: ZFS and acl questions in Indiana]
Moving to indiana-discuss.. Please do not start battling each other, bringing this issue to indiana-discuss is only to show potential gotcha when assuming a specific PATH setting in utilities/scripts Cheers, Ivan This message posted from opensolaris.org