Hi All, when looking through all the existing targets, I see that each of them defines <Target>ISelLowering.{cpp,h} files. However, they define a class called "<Target>TargetLowering" (though the comments in [at least some of] those files stay the define "<Target>ISelLowering". I suspect that this class was renamed at some time (which makes sense, since I don't think that the TargetLowering classes have anything to do with instruction selection [any more?]). However, the inconsistent filenames are a bit confusing. Perhaps somebody should rename the lot of them? The same goes for <Target>ISelDAGToDAG.cpp, which defines a class called <Target>DAGToDAGISel. Gr. Matthijs -------------- next part -------------- A non-text attachment was scrubbed... Name: signature.asc Type: application/pgp-signature Size: 189 bytes Desc: Digital signature URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20081201/241b3ef7/attachment.sig>
On Dec 1, 2008, at 8:53 AM, Matthijs Kooijman wrote:> Hi All, > > when looking through all the existing targets, I see that each of > them defines > <Target>ISelLowering.{cpp,h} files. However, they define a class > called > "<Target>TargetLowering" (though the comments in [at least some of] > those > files stay the define "<Target>ISelLowering". > > I suspect that this class was renamed at some time (which makes > sense, since I > don't think that the TargetLowering classes have anything to do with > instruction selection [any more?]). However, the inconsistent > filenames are a > bit confusing. Perhaps somebody should rename the lot of them?Sure, I'd support renaming them to <target>TargetLowering.cpp etc.> The same goes for <Target>ISelDAGToDAG.cpp, which defines a class > called > <Target>DAGToDAGISel.The DAGToDAG suffix is actually a pretty old historical artifact at this point. It would be better to rename the classes and files to <target>DAGISel. -Chris
Hi all,> Sure, I'd support renaming them to <target>TargetLowering.cpp etc.Good.> > The same goes for <Target>ISelDAGToDAG.cpp, which defines a class > > called > > <Target>DAGToDAGISel. > > The DAGToDAG suffix is actually a pretty old historical artifact at > this point. It would be better to rename the classes and files to > <target>DAGISel.That sounds even better indeed. Anyone want to take this up? I won't be able to do this, considering that I have only two workdays left to spend on finishing up my projects, which will be work enough. I can commit the changes, but not test them thorougly enough to know if it works for sure. Gr. Matthijs -------------- next part -------------- A non-text attachment was scrubbed... Name: signature.asc Type: application/pgp-signature Size: 189 bytes Desc: Digital signature URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20081201/c2cccfe3/attachment.sig>