Displaying 20 results from an estimated 30 matches for "ifdefferi".
Did you mean:
ifdeffery
2020 Feb 10
3
[PATCH] virtio_balloon: Fix unused label warning
From: Borislav Petkov <bp at suse.de>
Fix
drivers/virtio/virtio_balloon.c: In function ?virtballoon_probe?:
drivers/virtio/virtio_balloon.c:963:1: warning: label ?out_del_vqs? defined but not used [-Wunused-label]
963 | out_del_vqs:
| ^~
The CONFIG_BALLOON_COMPACTION ifdeffery should enclose it too.
Signed-off-by: Borislav Petkov <bp at suse.de>
Cc: David
2020 Feb 10
3
[PATCH] virtio_balloon: Fix unused label warning
From: Borislav Petkov <bp at suse.de>
Fix
drivers/virtio/virtio_balloon.c: In function ?virtballoon_probe?:
drivers/virtio/virtio_balloon.c:963:1: warning: label ?out_del_vqs? defined but not used [-Wunused-label]
963 | out_del_vqs:
| ^~
The CONFIG_BALLOON_COMPACTION ifdeffery should enclose it too.
Signed-off-by: Borislav Petkov <bp at suse.de>
Cc: David
2020 Aug 31
2
[PATCH v6 42/76] x86/sev-es: Setup early #VC handler
On Mon, Aug 24, 2020 at 10:54:37AM +0200, Joerg Roedel wrote:
> +#ifdef CONFIG_AMD_MEM_ENCRYPT
> +static void set_early_idt_handler(gate_desc *idt, int n, void *handler)
> +{
> + struct idt_data data;
> + gate_desc desc;
> +
> + init_idt_data(&data, n, handler);
> + idt_init_desc(&desc, &data);
> + native_write_idt_entry(idt, n, &desc);
> +}
>
2020 Aug 31
2
[PATCH v6 42/76] x86/sev-es: Setup early #VC handler
On Mon, Aug 24, 2020 at 10:54:37AM +0200, Joerg Roedel wrote:
> +#ifdef CONFIG_AMD_MEM_ENCRYPT
> +static void set_early_idt_handler(gate_desc *idt, int n, void *handler)
> +{
> + struct idt_data data;
> + gate_desc desc;
> +
> + init_idt_data(&data, n, handler);
> + idt_init_desc(&desc, &data);
> + native_write_idt_entry(idt, n, &desc);
> +}
>
2015 Dec 10
3
[PATCH] Receive multiple packets at a time
10.12.2015 09:20, Michael Tokarev wrote:
> 10.12.2015 03:35, Samuel Thibault wrote:
> []
>
> I suggest reducing ifdeffery in handle_incoming_vpn_data(), especially
> the error checking code.
>
> The function isn't that large now, it might be much better to have
> two different implementations. Like this (untested, patch attached):
>
> void
2018 Sep 10
2
[PATCH] x86/paravirt: Cleanup native_patch()
On Mon, Sep 10, 2018 at 08:54:12AM +0200, Juergen Gross wrote:
> > + case PARAVIRT_PATCH(lock.queued_spin_unlock):
> > + if (pv_is_native_spin_unlock())
> > + return paravirt_patch_insns(ibuf, len,
> > + start_lock_queued_spin_unlock,
> > + end_lock_queued_spin_unlock);
> > + else
> > + return paravirt_patch_default(type, ibuf,
2018 Sep 10
2
[PATCH] x86/paravirt: Cleanup native_patch()
On Mon, Sep 10, 2018 at 08:54:12AM +0200, Juergen Gross wrote:
> > + case PARAVIRT_PATCH(lock.queued_spin_unlock):
> > + if (pv_is_native_spin_unlock())
> > + return paravirt_patch_insns(ibuf, len,
> > + start_lock_queued_spin_unlock,
> > + end_lock_queued_spin_unlock);
> > + else
> > + return paravirt_patch_default(type, ibuf,
2015 Dec 10
2
[PATCH] Receive multiple packets at a time
Hello,
Guus Sliepen, on Wed 02 Dec 2015 13:53:37 +0100, wrote:
> That's great! It would be good though to split
> handle_incoming_vpn_data() into a function that does the actual
> recvfrom/mmsg() and one that processes each individual packet, to reduce
> the level of indentation and make the functions a bit more readable.
> Then I'll merge it :)
Here it is.
Samuel
2007 Apr 18
3
[patch] paravirt: VDSO page is essential
On Mon, 2007-03-05 at 13:06 +0100, Ingo Molnar wrote:
> Subject: [patch] paravirt: VDSO page is essential
> From: Ingo Molnar <mingo@elte.hu>
>
> commit 3bbf54725467d604698721384d858b5983b87e8f disables the VDSO for
> CONFIG_PARAVIRT kernels. This #ifdeffery was a bad change: the VDSO is
> an essential component of Linux, and this change forces all of them to
> use
2007 Apr 18
3
[patch] paravirt: VDSO page is essential
On Mon, 2007-03-05 at 13:06 +0100, Ingo Molnar wrote:
> Subject: [patch] paravirt: VDSO page is essential
> From: Ingo Molnar <mingo@elte.hu>
>
> commit 3bbf54725467d604698721384d858b5983b87e8f disables the VDSO for
> CONFIG_PARAVIRT kernels. This #ifdeffery was a bad change: the VDSO is
> an essential component of Linux, and this change forces all of them to
> use
2018 Sep 10
0
[PATCH] x86/paravirt: Cleanup native_patch()
On 10/09/18 09:01, Borislav Petkov wrote:
> On Mon, Sep 10, 2018 at 08:54:12AM +0200, Juergen Gross wrote:
>>> + case PARAVIRT_PATCH(lock.queued_spin_unlock):
>>> + if (pv_is_native_spin_unlock())
>>> + return paravirt_patch_insns(ibuf, len,
>>> + start_lock_queued_spin_unlock,
>>> + end_lock_queued_spin_unlock);
>>> +
2020 Feb 16
0
[PATCH] virtio_balloon: Fix unused label warning
On Mon, Feb 10, 2020 at 10:33:28AM +0100, Borislav Petkov wrote:
> From: Borislav Petkov <bp at suse.de>
>
> Fix
>
> drivers/virtio/virtio_balloon.c: In function ?virtballoon_probe?:
> drivers/virtio/virtio_balloon.c:963:1: warning: label ?out_del_vqs? defined but not used [-Wunused-label]
> 963 | out_del_vqs:
> | ^~
>
> The
2020 May 19
1
[PATCH v3 35/75] x86/head/64: Build k/head64.c with -fno-stack-protector
On Tue, Apr 28, 2020 at 05:16:45PM +0200, Joerg Roedel wrote:
> From: Joerg Roedel <jroedel at suse.de>
>
> The code inserted by the stack protector does not work in the early
> boot environment because it uses the GS segment, at least with memory
> encryption enabled.
Can you elaborate on why is that a problem?
The stack cookie is not generated that early yet so it should
2020 Sep 01
0
[PATCH v6 42/76] x86/sev-es: Setup early #VC handler
On Mon, Aug 31, 2020 at 11:45:41AM +0200, Borislav Petkov wrote:
> On Mon, Aug 24, 2020 at 10:54:37AM +0200, Joerg Roedel wrote:
> > +#ifdef CONFIG_AMD_MEM_ENCRYPT
> > + /* VMM Communication Exception */
> > + handler = fixup_pointer(vc_no_ghcb, physbase);
> > + set_early_idt_handler(idt, X86_TRAP_VC, handler);
>
> This function is used only once AFAICT - you
2015 Dec 10
0
[PATCH] Receive multiple packets at a time
10.12.2015 03:35, Samuel Thibault wrote:
[]
I suggest reducing ifdeffery in handle_incoming_vpn_data(), especially
the error checking code.
The function isn't that large now, it might be much better to have
two different implementations. Like this (untested, patch attached):
void handle_incoming_vpn_data(int sock) {
#ifdef HAVE_RECVMMSG
#define MAX_MSG 256
vpn_packet_t
2011 Jun 28
0
[PATCH 2/2] cpio: directly include fnmatch
Useless ifdeffery seen on previous cleanup.
Signed-off-by: maximilian attems <max at stro.at>
---
usr/utils/cpio.c | 2 --
1 files changed, 0 insertions(+), 2 deletions(-)
diff --git a/usr/utils/cpio.c b/usr/utils/cpio.c
index 15134b9..cb61679 100644
--- a/usr/utils/cpio.c
+++ b/usr/utils/cpio.c
@@ -27,9 +27,7 @@
#include <time.h>
#include <unistd.h>
#include
2017 May 24
1
[PATCH 05/10] paravirt: add new PARAVIRT_FULL config item
On 05/19/2017 11:47 AM, Juergen Gross wrote:
> Add a new config item PARAVIRT_FULL. It will be used to guard the
> pv_*_ops functions used by fully paravirtualized guests (Xen pv-guests
> and lguest) only.
>
> Kernels not meant to support those guest types will be able to use many
> operations without paravirt abstraction while still supporting all the
> other paravirt
2017 May 24
1
[PATCH 05/10] paravirt: add new PARAVIRT_FULL config item
On 05/19/2017 11:47 AM, Juergen Gross wrote:
> Add a new config item PARAVIRT_FULL. It will be used to guard the
> pv_*_ops functions used by fully paravirtualized guests (Xen pv-guests
> and lguest) only.
>
> Kernels not meant to support those guest types will be able to use many
> operations without paravirt abstraction while still supporting all the
> other paravirt
2020 Aug 31
1
[PATCH v6 48/76] x86/entry/64: Add entry code for #VC handler
On Mon, Aug 24, 2020 at 10:54:43AM +0200, Joerg Roedel wrote:
> @@ -446,6 +448,82 @@ _ASM_NOKPROBE(\asmsym)
> SYM_CODE_END(\asmsym)
> .endm
>
ifdeffery pls...
> +/**
> + * idtentry_vc - Macro to generate entry stub for #VC
> + * @vector: Vector number
> + * @asmsym: ASM symbol for the entry point
> + * @cfunc: C function to be called
> + *
> + * The macro
2018 Jun 26
0
[PATCH v2 0/5] Add virtio-iommu driver
On Thu, Jun 21, 2018 at 08:06:50PM +0100, Jean-Philippe Brucker wrote:
> Implement the base virtio-iommu driver, following version 0.7 of the
> specification [1].
>
> Changes since last version [2]:
> * Address comments, thanks again for the review.
> * As suggested, add a DT binding description in patch 1.
> * Depend on VIRTIO_MMIO=y to fix a build failure?
> * Switch to