search for: ifdeffery

Displaying 20 results from an estimated 30 matches for "ifdeffery".

2020 Feb 10
3
[PATCH] virtio_balloon: Fix unused label warning
From: Borislav Petkov <bp at suse.de> Fix drivers/virtio/virtio_balloon.c: In function ?virtballoon_probe?: drivers/virtio/virtio_balloon.c:963:1: warning: label ?out_del_vqs? defined but not used [-Wunused-label] 963 | out_del_vqs: | ^~ The CONFIG_BALLOON_COMPACTION ifdeffery should enclose it too. Signed-off-by: Borislav Petkov <bp at suse.de> Cc: David Hildenbrand <david at redhat.com> --- drivers/virtio/virtio_balloon.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/virtio/virtio_balloon.c b/drivers/virtio/virtio_balloon.c i...
2020 Feb 10
3
[PATCH] virtio_balloon: Fix unused label warning
From: Borislav Petkov <bp at suse.de> Fix drivers/virtio/virtio_balloon.c: In function ?virtballoon_probe?: drivers/virtio/virtio_balloon.c:963:1: warning: label ?out_del_vqs? defined but not used [-Wunused-label] 963 | out_del_vqs: | ^~ The CONFIG_BALLOON_COMPACTION ifdeffery should enclose it too. Signed-off-by: Borislav Petkov <bp at suse.de> Cc: David Hildenbrand <david at redhat.com> --- drivers/virtio/virtio_balloon.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/virtio/virtio_balloon.c b/drivers/virtio/virtio_balloon.c i...
2020 Aug 31
2
[PATCH v6 42/76] x86/sev-es: Setup early #VC handler
...NCRYPT > + /* VMM Communication Exception */ > + handler = fixup_pointer(vc_no_ghcb, physbase); > + set_early_idt_handler(idt, X86_TRAP_VC, handler); This function is used only once AFAICT - you might just as well add its three-lined body here and save yourself the function definition and ifdeffery above... > +#endif > + > + /* Initialize IDT descriptor and load IDT */ > + early_idt_descr.address = (unsigned long)idt; > + native_load_idt(&early_idt_descr); > +} > -- > 2.28.0 > -- Regards/Gruss, Boris. https://people.kernel.org/tglx/notes-about-netiquet...
2020 Aug 31
2
[PATCH v6 42/76] x86/sev-es: Setup early #VC handler
...NCRYPT > + /* VMM Communication Exception */ > + handler = fixup_pointer(vc_no_ghcb, physbase); > + set_early_idt_handler(idt, X86_TRAP_VC, handler); This function is used only once AFAICT - you might just as well add its three-lined body here and save yourself the function definition and ifdeffery above... > +#endif > + > + /* Initialize IDT descriptor and load IDT */ > + early_idt_descr.address = (unsigned long)idt; > + native_load_idt(&early_idt_descr); > +} > -- > 2.28.0 > -- Regards/Gruss, Boris. https://people.kernel.org/tglx/notes-about-netiquet...
2015 Dec 10
3
[PATCH] Receive multiple packets at a time
10.12.2015 09:20, Michael Tokarev wrote: > 10.12.2015 03:35, Samuel Thibault wrote: > [] > > I suggest reducing ifdeffery in handle_incoming_vpn_data(), especially > the error checking code. > > The function isn't that large now, it might be much better to have > two different implementations. Like this (untested, patch attached): > > void handle_incoming_vpn_data(int sock) { > > #ifdef...
2018 Sep 10
2
[PATCH] x86/paravirt: Cleanup native_patch()
..._spin_unlock); > > + else > > + return paravirt_patch_default(type, ibuf, addr, len); > > Why not replace the else clause by a "break;" and ... Because I think that exiting right then and there is much easier to follow than adding all those breaks and wading through ifdeffery to realize that this is the default path and we'll end up calling paravirt_patch_default() in the end. -- Regards/Gruss, Boris. Good mailing practices for 400: avoid top-posting and trim the reply.
2018 Sep 10
2
[PATCH] x86/paravirt: Cleanup native_patch()
..._spin_unlock); > > + else > > + return paravirt_patch_default(type, ibuf, addr, len); > > Why not replace the else clause by a "break;" and ... Because I think that exiting right then and there is much easier to follow than adding all those breaks and wading through ifdeffery to realize that this is the default path and we'll end up calling paravirt_patch_default() in the end. -- Regards/Gruss, Boris. Good mailing practices for 400: avoid top-posting and trim the reply.
2015 Dec 10
2
[PATCH] Receive multiple packets at a time
Hello, Guus Sliepen, on Wed 02 Dec 2015 13:53:37 +0100, wrote: > That's great! It would be good though to split > handle_incoming_vpn_data() into a function that does the actual > recvfrom/mmsg() and one that processes each individual packet, to reduce > the level of indentation and make the functions a bit more readable. > Then I'll merge it :) Here it is. Samuel
2007 Apr 18
3
[patch] paravirt: VDSO page is essential
On Mon, 2007-03-05 at 13:06 +0100, Ingo Molnar wrote: > Subject: [patch] paravirt: VDSO page is essential > From: Ingo Molnar <mingo@elte.hu> > > commit 3bbf54725467d604698721384d858b5983b87e8f disables the VDSO for > CONFIG_PARAVIRT kernels. This #ifdeffery was a bad change: the VDSO is > an essential component of Linux, and this change forces all of them to > use int $0x80 - including sane ones like KVM. (If a hypervisor does not > handle the VDSO properly then it can work things around via the vdso=0 > boot option. Or CONFIG_PARAVIRT...
2007 Apr 18
3
[patch] paravirt: VDSO page is essential
On Mon, 2007-03-05 at 13:06 +0100, Ingo Molnar wrote: > Subject: [patch] paravirt: VDSO page is essential > From: Ingo Molnar <mingo@elte.hu> > > commit 3bbf54725467d604698721384d858b5983b87e8f disables the VDSO for > CONFIG_PARAVIRT kernels. This #ifdeffery was a bad change: the VDSO is > an essential component of Linux, and this change forces all of them to > use int $0x80 - including sane ones like KVM. (If a hypervisor does not > handle the VDSO properly then it can work things around via the vdso=0 > boot option. Or CONFIG_PARAVIRT...
2018 Sep 10
0
[PATCH] x86/paravirt: Cleanup native_patch()
...+ else >>> + return paravirt_patch_default(type, ibuf, addr, len); >> >> Why not replace the else clause by a "break;" and ... > > Because I think that exiting right then and there is much easier to > follow than adding all those breaks and wading through ifdeffery > to realize that this is the default path and we'll end up calling > paravirt_patch_default() in the end. > Really? All of the remaining coding would fit easily on one screen. No hidden breaks anywhere and no deep nesting involved. And the ifdefs hardly makes it more difficult to un...
2020 Feb 16
0
[PATCH] virtio_balloon: Fix unused label warning
...e> > > Fix > > drivers/virtio/virtio_balloon.c: In function ?virtballoon_probe?: > drivers/virtio/virtio_balloon.c:963:1: warning: label ?out_del_vqs? defined but not used [-Wunused-label] > 963 | out_del_vqs: > | ^~ > > The CONFIG_BALLOON_COMPACTION ifdeffery should enclose it too. > > Signed-off-by: Borislav Petkov <bp at suse.de> > Cc: David Hildenbrand <david at redhat.com> > --- > drivers/virtio/virtio_balloon.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/virtio/virtio_ballo...
2020 May 19
1
[PATCH v3 35/75] x86/head/64: Build k/head64.c with -fno-stack-protector
...e stack cookie is not generated that early yet so it should be comparing %gs:40 to 0. Also, it generates the checking code here only with CONFIG_STACKPROTECTOR_STRONG=y > Make sure the early code is compiled without this feature enabled. If so, then this should be with CONFIG_AMD_MEM_ENCRYPT ifdeffery around it. -- Regards/Gruss, Boris. https://people.kernel.org/tglx/notes-about-netiquette
2020 Sep 01
0
[PATCH v6 42/76] x86/sev-es: Setup early #VC handler
...tion Exception */ > > + handler = fixup_pointer(vc_no_ghcb, physbase); > > + set_early_idt_handler(idt, X86_TRAP_VC, handler); > > This function is used only once AFAICT - you might just as well add its > three-lined body here and save yourself the function definition and > ifdeffery above... True, but having a separate function might be handy when support for #VE and #HV is developed. Those might also need to setup their early handlers here, no? Regards, Joerg
2015 Dec 10
0
[PATCH] Receive multiple packets at a time
10.12.2015 03:35, Samuel Thibault wrote: [] I suggest reducing ifdeffery in handle_incoming_vpn_data(), especially the error checking code. The function isn't that large now, it might be much better to have two different implementations. Like this (untested, patch attached): void handle_incoming_vpn_data(int sock) { #ifdef HAVE_RECVMMSG #define MAX_MSG 256...
2011 Jun 28
0
[PATCH 2/2] cpio: directly include fnmatch
Useless ifdeffery seen on previous cleanup. Signed-off-by: maximilian attems <max at stro.at> --- usr/utils/cpio.c | 2 -- 1 files changed, 0 insertions(+), 2 deletions(-) diff --git a/usr/utils/cpio.c b/usr/utils/cpio.c index 15134b9..cb61679 100644 --- a/usr/utils/cpio.c +++ b/usr/utils/cpio.c @@ -27,9...
2017 May 24
1
[PATCH 05/10] paravirt: add new PARAVIRT_FULL config item
On 05/19/2017 11:47 AM, Juergen Gross wrote: > Add a new config item PARAVIRT_FULL. It will be used to guard the > pv_*_ops functions used by fully paravirtualized guests (Xen pv-guests > and lguest) only. > > Kernels not meant to support those guest types will be able to use many > operations without paravirt abstraction while still supporting all the > other paravirt
2017 May 24
1
[PATCH 05/10] paravirt: add new PARAVIRT_FULL config item
On 05/19/2017 11:47 AM, Juergen Gross wrote: > Add a new config item PARAVIRT_FULL. It will be used to guard the > pv_*_ops functions used by fully paravirtualized guests (Xen pv-guests > and lguest) only. > > Kernels not meant to support those guest types will be able to use many > operations without paravirt abstraction while still supporting all the > other paravirt
2020 Aug 31
1
[PATCH v6 48/76] x86/entry/64: Add entry code for #VC handler
On Mon, Aug 24, 2020 at 10:54:43AM +0200, Joerg Roedel wrote: > @@ -446,6 +448,82 @@ _ASM_NOKPROBE(\asmsym) > SYM_CODE_END(\asmsym) > .endm > ifdeffery pls... > +/** > + * idtentry_vc - Macro to generate entry stub for #VC > + * @vector: Vector number > + * @asmsym: ASM symbol for the entry point > + * @cfunc: C function to be called > + * > + * The macro emits code to set up the kernel context for #VC. The #VC handler &gt...
2018 Jun 26
0
[PATCH v2 0/5] Add virtio-iommu driver
...iments, such as using kmem_cache for requests instead of kmalloc, > didn't show any improvement. > > Driver is available on branch virtio-iommu/v0.7 [3], and the x86+ACPI > prototype is on branch virtio-iommu/devel. That x86 code hasn't changed, > it still requires the DMA ifdeffery and I lack the expertise to tidy it > up. The kvmtool example device has been cleaned up and is available on > branch virtio-iommu/v0.7 [4]. > > Feedback welcome! > > Thanks, > Jean So as I pointed out new virtio 0 device isn't really welcome ;) No one bothered implement...