I''m writing my first full-fledged rails app and I happened to notice a minor inconsistency in the way script\generate works. When I create a separate model and controller, such as: script\generate controller appointment script\generate model appointment A few different files/dirs are created: app\controllers\appointment_controller.rb app\helpers\appointment_helper.rb models\appointment.rb views\appointment However, if instead I use script\generate to create the scaffolding so that I can alter it and save some coding time by not having to create all the files from scratch, like so: script\generate scaffold appointment It names some of the files/dirs differently: app\controllers\appointments_controller.rb app\helpers\appointments_helper.rb models\appointment.rb views\appointments Notice that in both cases I specified "appointment" in the singular. It seems to me like both methods should use the same naming conventions. For the time being, which usage is more common for naming controllers and models? Do you like to put the object being operated on in singular or plural? Thanks, Carl