Displaying 20 results from an estimated 21 matches for "out_buff".
Did you mean:
out_buf
2023 Feb 24
1
[PATCH 1/1] Add support for ZSTD compression
...t;state->compression_zstd_in_stream)
+ return SSH_ERR_ALLOC_FAIL;
+
+ ssh->state->compression_in_started = COMP_ZSTD;
+ return 0;
+}
+
+static int
+compress_buffer_zstd(struct ssh *ssh, struct sshbuf *in, struct sshbuf *out)
+{
+ u_char buf[4096];
+ ZSTD_inBuffer in_buff;
+ ZSTD_outBuffer out_buff;
+ int r, comp;
+
+ if (ssh->state->compression_out_started != COMP_ZSTD)
+ return SSH_ERR_INTERNAL_ERROR;
+
+ if (sshbuf_len(in) == 0)
+ return 0;
+
+ in_buff.src = sshbuf_mutable_ptr(in);
+ if (!in_buff.src)
+ return SSH_ERR_INTERNAL_ERROR;
+ in_buff.size = sshbuf_len(in);
+ in_buff.pos...
2023 Feb 24
1
[PATCH 0/1] ZSTD compression support for OpenSSH
I added ZSTD support to OpenSSH roughly three years ago and I've been
playing with it ever since.
The nice part is that ZSTD achieves reasonable compression (like zlib)
but consumes little CPU so it is unlikely that compression becomes the
bottle neck of a transfer. The compression overhead (CPU) is negligible
even when uncompressed data is tunneled over the SSH connection (SOCKS
proxy, port
2020 Mar 24
4
ZSTD compression support for OpenSSH
I hacked zstd support into OpenSSH a while ago and just started to clean
it up in the recent days. The cleanup includes configuration support
among other things that I did not have.
During testing I noticed the following differences compared to zlib:
- highly interactive shell output (as in refreshed at a _very_ high
rate) may result in higher bandwidth compared to zlib. Since zstd is
quicker
2020 Sep 05
8
[PATCH 0/5] ZSTD compression support for OpenSSH
I added ZSTD support to OpenSSH roughly over a year and I've been
playing with it ever since.
The nice part is that ZSTD achieves reasonable compression (like zlib)
but consumes little CPU so it is unlikely that compression becomes the
bottle neck of a transfer. The compression overhead (CPU) is negligible
even when uncompressed data is tunneled over the SSH connection (SOCKS
proxy, port
2007 May 16
3
draft-ietf-avt-rtp-speex-01.txt
...its_remaining"...)
I'm not really sure I understand your code, but it looks much more
complicated than it should be. Normally, the decode code should look like:
speex_bits_init(&bits);
speex_bits_read_from(&bits, packet, length);
while (1)
{
err = speex_decode_int(state, bits, out_buffer);
if (err != 0)
break;
play_audio(out_buffer);
}
if (err == -2)
ms_warning("there was an error decoding");
I see from your code that you use speex_bits_remaining(&bits) but I
can't really understand why. Could you explain?
Jean-Marc
2004 Aug 06
1
About reducing noise..
...E, &tmp);
// set quality
tmp = 10;
speex_encoder_ctl ( state, SPEEX_SET_QUALITY, &tmp);
// initialize bits
speex_bits_init(&bits);
while( 1 )
{
// read FRAME_SIZE bytes from buffer
// convert to short
for ( int i = 0; i < FRAME_SIZE; i++)
in[i] = out_buffer[i];
speex_bits_reset(&bits);
// encode
speex_encode ( state, in, &bits);
// copy bits to an array of chars
nbBytes = speex_bits_write ( &bits, cbits, 200);
// copy these cbits into a buffer
CopyBuffer(pBuffer + dwLength, cbits, nbByte...
2007 May 17
0
draft-ietf-avt-rtp-speex-01.txt
...not really sure I understand your code, but it looks much more
> complicated than it should be. Normally, the decode code should look like:
>
> speex_bits_init(&bits);
> speex_bits_read_from(&bits, packet, length);
> while (1)
> {
> err = speex_decode_int(state, bits, out_buffer);
> if (err != 0)
> break;
> play_audio(out_buffer);
> }
> if (err == -2)
> ms_warning("there was an error decoding");
>
>
> I see from your code that you use speex_bits_remaining(&bits) but I
> can't really understand why. Could you expl...
2007 May 16
2
draft-ietf-avt-rtp-speex-01.txt
>> The main idea is that Speex supports many bit-rates, but for one reason
>> or another, some modes may be left out in implementations (e.g. for RAM
>> or network reasons). What we're saying here is that you should make an
>> effoft to at least support (and offer) the 8 kbps mode to maximise
>> compatibility.
>
> I understood this. But as you may know: the
2007 Aug 24
2
[git patch] klibc bzero, mount fixes + random stuff
...always be a multiple of 4 helps us (and our callers)
insure this. */
-void disk_empty_output_buffer(int out_des)
+static void disk_empty_output_buffer(int out_des)
{
int bytes_written;
@@ -206,7 +193,7 @@ void disk_empty_output_buffer(int out_des)
/* Copy NUM_BYTES of buffer IN_BUF to `out_buff', which may be partly full.
When `out_buff' fills up, flush it to file descriptor OUT_DES. */
-void disk_buffered_write(char *in_buf, int out_des, long num_bytes)
+static void disk_buffered_write(char *in_buf, int out_des, long num_bytes)
{
register long bytes_left = num_bytes; /*...
2012 Mar 27
0
App. Delisprint hangs on second run
...tWaitForSingleObject+0x3b(handle=0x8c, alertable=0, timeout=(nil)) [/build/buildd/wine1.3-1.4/dlls/ntdll/sync.c:1169] in ntdll (0x00a4e818)
6 0x7bc3f367 server_ioctl_file+0x226(handle=0x54, event=0x0(nil), apc=(nil), apc_context=0x0(nil), io=0xa4e9e8, code=0x110008, in_buffer=0x0(nil), in_size=0, out_buffer=0x0(nil), out_size=0) [/build/buildd/wine1.3-1.4/dlls/ntdll/file.c:1276] in ntdll (0x00a4e918)
7 0x7bc42217 NtFsControlFile+0xa6(handle=0x54, event=0x0(nil), apc=(nil), apc_context=0x0(nil), io=0xa4e9e8, code=0x110008, in_buffer=0x0(nil), in_size=0, out_buffer=0x0(nil), out_size=0) [/build/buil...
2016 Aug 22
5
[PATCH] CodingStyle: add some more error handling guidelines
...Documentation/CodingStyle
index a096836..af2b5e9 100644
--- a/Documentation/CodingStyle
+++ b/Documentation/CodingStyle
@@ -397,8 +397,7 @@ cleanup needed then just return directly.
Choose label names which say what the goto does or why the goto exists. An
example of a good name could be "out_buffer:" if the goto frees "buffer". Avoid
-using GW-BASIC names like "err1:" and "err2:". Also don't name them after the
-goto location like "err_kmalloc_failed:"
+using GW-BASIC names like "err1:" and "err2:".
The rationale for...
2016 Aug 22
5
[PATCH] CodingStyle: add some more error handling guidelines
...Documentation/CodingStyle
index a096836..af2b5e9 100644
--- a/Documentation/CodingStyle
+++ b/Documentation/CodingStyle
@@ -397,8 +397,7 @@ cleanup needed then just return directly.
Choose label names which say what the goto does or why the goto exists. An
example of a good name could be "out_buffer:" if the goto frees "buffer". Avoid
-using GW-BASIC names like "err1:" and "err2:". Also don't name them after the
-goto location like "err_kmalloc_failed:"
+using GW-BASIC names like "err1:" and "err2:".
The rationale for...
2014 Oct 17
0
Wine release 1.7.29
...nv().
wined3d: Don't check for color-keying for WINED3D_CT_P8.
ws2_32: Return the needed buffer size for SIO_ADDRESS_LIST_QUERY.
ws2_32: Return WSAEINVAL if "out_size" is smaller than the minimum size for SIO_ADDRESS_LIST_QUERY.
ws2_32: Return an error if "out_buff" is NULL for SIO_ADDRESS_LIST_QUERY.
ws2_32: Simplify some address calculations for SIO_ADDRESS_LIST_QUERY.
wined3d: Return the destination format from d3dfmt_get_conv().
wined3d: Get rid of d3dfmt_convert_surface().
wined3d: Get rid of surface_prepare_texture_internal(...
2020 Jun 16
0
[PATCH v5 2/2] mm, treewide: Rename kzfree() to kfree_sensitive()
...dbc2d7c5c 100644
--- a/drivers/crypto/cavium/cpt/cptvf_reqmanager.c
+++ b/drivers/crypto/cavium/cpt/cptvf_reqmanager.c
@@ -305,12 +305,12 @@ static void do_request_cleanup(struct cpt_vf *cptvf,
}
}
- kzfree(info->scatter_components);
- kzfree(info->gather_components);
- kzfree(info->out_buffer);
- kzfree(info->in_buffer);
- kzfree((void *)info->completion_addr);
- kzfree(info);
+ kfree_sensitive(info->scatter_components);
+ kfree_sensitive(info->gather_components);
+ kfree_sensitive(info->out_buffer);
+ kfree_sensitive(info->in_buffer);
+ kfree_sensitive((void *)info-...
2020 Apr 13
0
[PATCH 1/2] mm, treewide: Rename kzfree() to kfree_sensitive()
...dbc2d7c5c 100644
--- a/drivers/crypto/cavium/cpt/cptvf_reqmanager.c
+++ b/drivers/crypto/cavium/cpt/cptvf_reqmanager.c
@@ -305,12 +305,12 @@ static void do_request_cleanup(struct cpt_vf *cptvf,
}
}
- kzfree(info->scatter_components);
- kzfree(info->gather_components);
- kzfree(info->out_buffer);
- kzfree(info->in_buffer);
- kzfree((void *)info->completion_addr);
- kzfree(info);
+ kfree_sensitive(info->scatter_components);
+ kfree_sensitive(info->gather_components);
+ kfree_sensitive(info->out_buffer);
+ kfree_sensitive(info->in_buffer);
+ kfree_sensitive((void *)info-...
2020 Jun 16
0
[PATCH v4 2/3] mm, treewide: Rename kzfree() to kfree_sensitive()
...dbc2d7c5c 100644
--- a/drivers/crypto/cavium/cpt/cptvf_reqmanager.c
+++ b/drivers/crypto/cavium/cpt/cptvf_reqmanager.c
@@ -305,12 +305,12 @@ static void do_request_cleanup(struct cpt_vf *cptvf,
}
}
- kzfree(info->scatter_components);
- kzfree(info->gather_components);
- kzfree(info->out_buffer);
- kzfree(info->in_buffer);
- kzfree((void *)info->completion_addr);
- kzfree(info);
+ kfree_sensitive(info->scatter_components);
+ kfree_sensitive(info->gather_components);
+ kfree_sensitive(info->out_buffer);
+ kfree_sensitive(info->in_buffer);
+ kfree_sensitive((void *)info-...
2020 Jun 16
3
[PATCH v5 0/2] mm, treewide: Rename kzfree() to kfree_sensitive()
v5:
- Break the btrfs patch out as a separate patch to be processed
independently.
- Update the commit log of patch 1 to make it less scary.
- Add a kzfree backward compatibility macro in patch 2.
v4:
- Break out the memzero_explicit() change as suggested by Dan Carpenter
so that it can be backported to stable.
- Drop the "crypto: Remove unnecessary
2020 Jun 16
14
[PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()
v4:
- Break out the memzero_explicit() change as suggested by Dan Carpenter
so that it can be backported to stable.
- Drop the "crypto: Remove unnecessary memzero_explicit()" patch for
now as there can be a bit more discussion on what is best. It will be
introduced as a separate patch later on after this one is merged.
This patchset makes a global rename of the kzfree()
2020 Jun 16
14
[PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()
v4:
- Break out the memzero_explicit() change as suggested by Dan Carpenter
so that it can be backported to stable.
- Drop the "crypto: Remove unnecessary memzero_explicit()" patch for
now as there can be a bit more discussion on what is best. It will be
introduced as a separate patch later on after this one is merged.
This patchset makes a global rename of the kzfree()
2020 Apr 13
10
[PATCH 0/2] mm, treewide: Rename kzfree() to kfree_sensitive()
This patchset makes a global rename of the kzfree() to kfree_sensitive()
to highlight the fact buffer clearing is only needed if the data objects
contain sensitive information like encrpytion key. The fact that kzfree()
uses memset() to do the clearing isn't totally safe either as compiler
may compile out the clearing in their optimizer. Instead, the new
kfree_sensitive() uses