search for: optionparser

Displaying 20 results from an estimated 38 matches for "optionparser".

2006 Jan 24
18
Can''t install rails, instructions in the book are wrong....
...ose, and I then type the command that came right out of the book. C:\ruby>gem install rails --include-dependencies and it doesn''t even work: C:\ruby>"C:\ruby\bin\ruby.exe" "C:\ruby\bin\gem" install rails --include-dependencies ERROR: While executing gem ... (OptionParser::InvalidOption) invalid option: --include-dependencies Hard to believe. Did I do something wrong? Greg -- Posted via http://www.ruby-forum.com/.
2007 Sep 16
4
"Not Implemented" doesn''t show
....rb should produce according to his screen cast: 1 example, 0 failures, 1 not implemented but I only recieve: 1 example, 0 failures Also spec spec/simple_spec.rb --format will fail /usr/local/lib/ruby/1.8/optparse.rb:451:in `parse'': missing argument: --format (OptionParser::MissingArgument) RSpec 1.0.8 ZenTest 3.6.1 -------------- next part -------------- An HTML attachment was scrubbed... URL: http://rubyforge.org/pipermail/rspec-users/attachments/20070916/7a5765c4/attachment.html
2007 Oct 30
7
RSpec Texmate Bundle errors
I''ve the same problem as Alastair when running rspec command : http://lists.macromates.com/pipermail/textmate/2007-October/022585.html ../spec/mate/runner.rb:34:in `run'': undefined method `parse'' for Spec::Runner::OptionParser:Class I fixed this for me by changing the offending line to : ::Spec::Runner::CommandLine.run(argv, STDERR, stdout) (see http://lists.macromates.com/pipermail/textmate/2007-October/022985.html ) But I''m not sure at all for this fix. Did someone else have the...
2007 Mar 01
4
RC1, Rails, and problems with multiple options in spec.opts
...ent output with multiple options in the spec.opts file. I can, for instance, pass --color or --colour, or, separately, use --drb. But when combining them I get: /opt/local/lib/ruby/1.8/optparse.rb:1381:in `complete'': invalid option: --options --color --drb (OptionParser::InvalidOption) from /opt/local/lib/ruby/1.8/optparse.rb:1379:in `catch'' from /opt/local/lib/ruby/1.8/optparse.rb:1379:in `complete'' from /opt/local/lib/ruby/1.8/optparse.rb:1212:in...
2007 Aug 15
8
Extra Options to Heckle
I''ve tried running Heckle with rspec on some of my classes, but keep getting (what I believe to be) an infinite recursion. Is there some way to supply extra options to heckle via. rspec? Scott
2008 Oct 18
4
Problems when programmatically defining examples
...lly building examples, and launching the runner with a custom formatter. Here are the code snippets from my app: Launching the runner: example_groups = test_expectation.example_groups_for(system_state) @output = StringIO.new options = Spec::Runner::OptionParser.parse(["--format", "RAutotest::Runner::Formatter"], @output, @output) example_groups.each {|example_group| options.add_example_group(example_group) } Spec::Runner::CommandLine.run(options) Building the example groups: exampl...
2006 Mar 20
1
I need some help with OptionsParser
Hey all, I must be doing something wrong here. Im calling the following file this way: ruby script.rb -s 1234 or ruby script.rb -s1111 #Code snip require ''optparse'' opts = OptionParser.new opts.on("-s", "--size VAL", Integer) do |val| puts "-s #{val}" puts val end But..no matter what I do, I don''t get any values out. I must be doing something wrong?? Help! THanks all, Brian -------------- next part -------------- An HTML attachment was s...
2009 Jul 07
2
[PATCH] Set up ovirt-agent so it starts as a daemon
...7;ovirt-server/ovirt-agent.log' - ensure_credentials + def initialize() - # FIXME: Use RAILS_DEFAULT_LOGGER - @logger = Logger.new(STDERR) - @logger.level = Logger::DEBUG + ensure_credentials server, port = nil sleepy = 5 + + do_daemon = true + + opts = OptionParser.new do |opts| + opts.on("-h", "--help", "Print help message") do + puts opts + exit + end + opts.on("-n", "--nodaemon", "Run interactively (useful for debugging)") do |n| + do_daemon = false + end +...
2006 Mar 02
5
Installation Problem
I need to install rails on my system for a class project. I have ruby 1.8.2-14 installed and am entering at the command prompt >gem install rails --remote According to Curt Hibbs installation, I should get a series of questions to answer yes to, and then info on the installation. All I am getting is... Successfully installed rails_analyzer_tools, version 1.1.0 Installing RDoc documentation
2012 Feb 09
1
Autorun Picks Up Options
...noticed that when I run the command to kick off the ruby scripts it picks up the options that I give to the command. ''myRubyBin -j optionValue'' This then fails with this error, /usr/lib/ruby/1.8/optparse.rb:1448:in `complete'' : invalid option: -j ( OptionParser::InvalidOption ) from /usr/lib/ruby/1.8/optparse.rb:1446:in `catch'' from /usr/lib/ruby/1.8/optparse.rb:1446:in `complete'' from /usr/lib/ruby/1.8/optparse.rb:1285:in `parse_in_order'' from /usr/lib/ruby...
2016 Sep 17
7
Benchmark LNT weird thread behaviour
Hi James/Chris, You guys have done this before, so I'm guessing you can help me understand what's going on. If my buildbot config is: jobs=2, nt_flags=['--cflag', '-mcpu=cortex-a15', '--use-perf', '--threads=1', '--build-threads=4'] It uses -j4 for build, -j2 for running the tests:
2006 Apr 02
3
RPC interface for xenmon
Hi, I read about RPC interface for xenmon in this presentation: www.xensource.com/files/xs0106_xenmon_brief.pdf Has such interface been implemented yet by anyone? Thanks, -- Jayesh ------------------------------------------------------------------------ Everything you can imagine is real _______________________________________________ Xen-devel mailing list
2008 Nov 20
1
running tests on gem
...wanted to run the tests on the gem and tried: $ jruby -S gem list RedCloth *** LOCAL GEMS *** RedCloth (4.1.1) $ jruby --version jruby 1.1.5 (ruby 1.8.6 patchlevel 114) (2008-11-14 rev 6586) [i386-java] [jruby.git (master)]$ jruby -S gem check -test RedCloth ERROR: While executing gem ... (OptionParser::InvalidOption) invalid option: -est [jruby.git (master)]$ jruby -S gem check --test RedCloth /Users/stephen/dev/ruby/src/jruby.git/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:38:in `require'': no such file to load -- helper (LoadE...
2006 May 11
3
Reinstall ruby''s MySQL Library on OS X Server
Hello, I am running OS X Server version 10.4.6 and I already have some MySQL databases working on the server. I install the RubyGem recently, however, it does not work correctly with the default MySQL. I am wondering if anybody can shed some light on: 1): how to reinstall ruby''s mysql library on the OS X server, 2): Is it possible to keep the old database files intact while reinstall
2009 Sep 14
2
[PATCH node-image] add livecd-iso-to-iscsi script to support iscsi root booting setup
...ee the +# GNU Library General Public License for more details. +# +# You should have received a copy of the GNU General Public License +# along with this program; if not, write to the Free Software +# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. + +from optparse import OptionParser +from tempfile import mkdtemp +import dbus +import dbus.glib +import sys +import os +import subprocess +import shutil + +parser = OptionParser() +parser.add_option("--iso", dest="iso", help="LiveCD iso filename") +parser.add_option("--target", dest="targ...
2008 Jan 06
5
alternate gem repo?
Hey folks, I''ve looked through the docs, and the mailing list, but for the life of me I can''t figure out how to specify an alternate gem repository for a package. From the docs, it looks like I should be able to do source => whatever, but this seems to just send gem looking for a specific gem at a url, rather then the more general alternate source for the gem. It looks
2006 Jan 23
5
can''t install model_security_generator
I''m trying to install Bruce Perens'' ModelSecurity gem, but it keeps asking me if I want to install rails too (I have already installed rails). It exits if I say no and crashes if I say yes: C:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install model_security_generator Attempting local installation of ''model_security_generator'' Local gem
2009 May 19
3
[PATCH server] added ovirt vnc proxy server, to proxy vnc request to managed vms
...} (#{$$}) #{msg}\n" + end +end + +$logfile = '/var/log/ovirt-server/vnc-proxy.log' + +########### + + +class VncProxy + + # initialize vnc proxy + def initialize() + super() + do_daemon = true + port = DEFAULT_VNC_PROXY_PORT + + opts = OptionParser.new do |opts| + opts.on("-h", "--help", "Print help message") do + puts opts + exit + end + opts.on("-n", "--nodaemon", "Run interactively (useful for debugging)") do |n| +...
2006 Mar 08
0
script/console custom prompt
...k, but I''m sure there is a more elegant way to do it. Anyway: irb = RUBY_PLATFORM =~ /mswin32/ ? ''irb.bat'' : ''irb'' require ''optparse'' options = { :sandbox => false, :irb => irb, :prompt => ''simple'' } OptionParser.new do |opt| opt.banner = "Usage: console [environment] [options]" opt.on(''-s'', ''--sandbox'', ''Rollback database modifications on exit.'') { |options[:sandbox]| } opt.on("--irb=[#{irb}]", ''Invoke a different...
2007 Nov 19
1
Capistrano in InstaRails bombs?
Following the book, I try: cap --apply-to C:\CapPlanner\trunk\Source capplanner And get in reply: C:/InstantRails/ruby/lib/ruby/1.8/optparse.rb:1443:in `complete'': invalid option: --apply-to (OptionParser::InvalidOption) from C:/InstantRails/ruby/lib/ruby/1.8/optparse.rb:1441:in `catch'' from C:/InstantRails/ruby/lib/ruby/1.8/optparse.rb:1441:in `complete'' from C:/InstantRails/ruby/lib/ruby/1...