search for: imperator

Displaying 20 results from an estimated 284 matches for "imperator".

Did you mean: vimperator
2008 Nov 07
13
features and form filling - going declarative?
I''m working on writing features for a wizard. The wizard collects information from a number of different forms, and you can navigate through it in a number of ways. Anyhow one of these forms is a customer form collecting name, and email. In the context of the wizard I feel that the following scenarios Scenario: Given I step to customer And I fill in my customer details
2016 Jul 07
0
[PATCH v3 4/8] mllib: Add some imperative list manipulation functions.
This adds imperative list manipulation functions inspired by Perl. The functions are passed list refs which get updated in place. This allows us to replace some awkward pure functional code like: let xs = ys in let xs = if foo then xs @ zs else xs in with: let xs = ref ys in if foo then append xs zs; --- mllib/common_utils.ml | 20 ++++++++++++++++++++ mllib/common_utils.mli | 36
2016 Jul 07
2
Re: [PATCH v3 4/8] mllib: Add some imperative list manipulation functions.
On Thursday 07 July 2016 17:30:03 Richard W.M. Jones wrote: > This adds imperative list manipulation functions inspired by Perl. > The functions are passed list refs which get updated in place. > > This allows us to replace some awkward pure functional code like: > > let xs = ys in > let xs = if foo then xs @ zs else xs in > > with: > > let xs = ref ys in
2016 Jul 08
2
Re: [PATCH v3 4/8] mllib: Add some imperative list manipulation functions.
On Thu, Jul 07, 2016 at 06:08:43PM +0100, Richard W.M. Jones wrote: > On Thu, Jul 07, 2016 at 07:00:46PM +0200, Pino Toscano wrote: > > On Thursday 07 July 2016 17:30:03 Richard W.M. Jones wrote: > > > This adds imperative list manipulation functions inspired by Perl. > > > The functions are passed list refs which get updated in place. > > > > > > This
2008 May 11
5
Are you writing "imperative" or "declarative" scenarios in your stories?
Hey all, I just found Bryan Helmkamp''s (of webrat fame) slides on a presentation he did at GoRuCo 2008: http://www.brynary.com/2008/4/26/story-driven-development-slides-posted On slides 21-24 he talks about writing good stories and shows gives two examples.. the way not to do it and the way to do it. You can also see the video of the presentation at confreaks
2016 Jul 07
0
Re: [PATCH v3 4/8] mllib: Add some imperative list manipulation functions.
On Thu, Jul 07, 2016 at 07:00:46PM +0200, Pino Toscano wrote: > On Thursday 07 July 2016 17:30:03 Richard W.M. Jones wrote: > > This adds imperative list manipulation functions inspired by Perl. > > The functions are passed list refs which get updated in place. > > > > This allows us to replace some awkward pure functional code like: > > > > let xs = ys
2016 Jul 08
0
Re: [PATCH v3 4/8] mllib: Add some imperative list manipulation functions.
On Fri, Jul 08, 2016 at 09:10:51AM +0100, Richard W.M. Jones wrote: > On Thu, Jul 07, 2016 at 06:08:43PM +0100, Richard W.M. Jones wrote: > > On Thu, Jul 07, 2016 at 07:00:46PM +0200, Pino Toscano wrote: > > > On Thursday 07 July 2016 17:30:03 Richard W.M. Jones wrote: > > > > This adds imperative list manipulation functions inspired by Perl. > > > > The
2010 Dec 16
1
my function does not work for large data set
Dear R community, I have one function, it works for small data set, but does not work on large data set, can anyone help me with this? > #creat new variable by dividing each aa dimer by total_length. > imper<-function(x, file) { + round(x/file$length, 5) + } > dim(test) [1] 999 2402 > test[varname[2:2401]]<-
2018 May 24
3
Style: getFoo() vs foo()
The coding guidelines say: > Function names should be verb phrases (as they represent actions), and command-like function should be imperative. The name should be camel case, and start with a lower case letter (e.g. openFile() or isFoo()). This means that functions that just compute or access a value (no side-effects) should be named e.g. `getParent()`, rather than `parent()` as they are in
2009 Feb 17
5
[Cucumber] Level of features / Feature dependent steps
Forgive the long post, just looking for input/advice/alternate opinions.. Like many I think that going through the exercise of framing user requests in Cucumber terms(Features, Scenarios..) really helps facilitate necessary conversations and avoid time wasted implementing the wrong thing(e.g. as a requirement/specification tool). However, I''m a bit confused when it comes to
2016 Jul 07
0
[PATCH v3 5/8] builder, v2v: Use imperative list functions to simplify curl arg code.
No functional change in this commit. --- builder/downloader.ml | 40 +++++++++++++++++++--------------------- v2v/copy_to_local.ml | 26 +++++++++++--------------- v2v/vCenter.ml | 34 ++++++++++++++++------------------ 3 files changed, 46 insertions(+), 54 deletions(-) diff --git a/builder/downloader.ml b/builder/downloader.ml index 3c9ba18..2a3f76f 100644 --- a/builder/downloader.ml
2019 Oct 05
2
CentOS 8 network-scripts
On Fri, 4 Oct 2019 at 18:11, Japheth Cleaver <cleaver at terabithia.org> wrote: > > On 10/4/2019 8:17 AM, Lamar Owen wrote: > > On 10/4/19 10:40 AM, Valeri Galtsev wrote: > >> My impression is younger generation doesn't value rules that > >> programmers were following 2-3 decades ago. One of which is: > >> > >> Do not make any changes [in
2018 May 24
0
Style: getFoo() vs foo()
> On 24 May 2018, at 20:19, Sam McCall via llvm-dev <llvm-dev at lists.llvm.org> wrote: > > The coding guidelines say: > > Function names should be verb phrases (as they represent actions), and command-like function should be imperative. The name should be camel case, and start with a lower case letter (e.g. openFile() or isFoo()). > > This means that functions that
2018 May 24
1
Style: getFoo() vs foo()
On 24.05.2018 13:11, Dean Michael Berris via llvm-dev wrote: > >> On 24 May 2018, at 20:19, Sam McCall via llvm-dev <llvm-dev at lists.llvm.org> wrote: >> >> The coding guidelines say: >>> Function names should be verb phrases (as they represent actions), and command-like function should be imperative. The name should be camel case, and start with a lower case
2008 Jul 07
5
[LLVMdev] fp_round libcall
Hi, I'm trying to emit FP_ROUND f64 -> f32 considering a mips target that only supports single float point operations. The problem is that f32 is considered legal on this target but f64 doesn't and the only way I can codegen this instruction is using setConvertAction(MVT::f64, MVT::f32, Expand), which issues a EmitStackConvert. What if I want a libcall instead? What should I do? The
2018 Feb 07
4
retpoline mitigation and 6.0
On Tue, Feb 6, 2018 at 2:56 PM David Woodhouse <dwmw2 at infradead.org> wrote: > On Tue, 2018-02-06 at 22:08 +0000, Chandler Carruth wrote: > > So, I was waiting to hear a definitive response on whether using aliases > is hard, and didn't see one here, which is why I haven't responded further. > > However, a colleauge pointed me at an LKML thread where it seems
2011 Apr 20
2
[LLVMdev] translation to the LLVM IR
Hi all, I am trying to compile a high-level imperative OOP-like language to the LLVM IR. Do we have any "generic" way of translating a non-SSA form to the LLVM IR's SSA? There are lots of LLVM front-ends now. Do they do such translation individually? or there is some common non-SSA IR that we can translate to, and can be converted to the LLVM IR automatically? I did not find such
2004 Sep 10
2
[Flac-users] new stripping options
So the right way to do it -- it seemed to work when I tried it, at least -- is metaflac --remove-all --dont-use-padding filename.flac ? I guess that these features make it more imperative than ever to watch the timestamps and not to validate a FLAC with an MD5 that is older than the FLAC is.
2006 May 20
0
EventLog#tail is broken
...'Security'').tail{ |log| p log } #<struct Struct::EventLogStruct record_number=15399, time_generated=Fri May 19 19:54:25 MDT 2006, time_written=Fri May 1 9 19:54:25 MDT 2006, event_id=680, event_type="audit failure", category=9, source="Security", computer="IMPERATOR", user ="SYSTEM", description="Logon attempt by: MICROSOFT_AUTHENTICATION_PACKAGE_V1_0\r\n\r\nLogon account: Daniel\r\n\r\nSou rce Workstation: IMPERATOR\r\n\r\nError Code: 0xC000006A\r\n\r\n"> #<struct Struct::EventLogStruct record_number=15064, time_generated=Sun...
2008 Jul 21
1
[LLVMdev] small bss and data support for elf asm
Basic support for Small bss and data. The rest is implemented with target specific logic and will be commited as soon as it's ok to commit this patch. -- Bruno Cardoso Lopes http://www.brunocardoso.cc "When faced with untenable alternatives, you should consider your imperative." -------------- next part -------------- A non-text attachment was scrubbed... Name: smallsections.patch