search for: camelcases

Displaying 20 results from an estimated 136 matches for "camelcases".

Did you mean: camelcase
2016 Apr 28
2
code style for test programs: CamelCase?
Hi everyone, I have a code style question: should full test programs (.c,.cpp files) use the documented CamelCase from http://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly or instead use lower_with_underscores as I've been told the .ll lit test files should use? I see both in existing files, and in particular for projects/compiler-rt I cannot
2013 Apr 15
6
how to transform string to "Camel Case"?
Dear all, Given the following vector: > (z <- c('R project', 'hello world', 'something Else')) [1] "R project" "hello world" "something Else" I know how to obtain all capitals or all lower case letters: > tolower(z) [1] "r project" "hello world" "something else" > toupper(z) [1] "R
2020 Feb 17
4
amount of camelCase refactoring causing some downstream overhead
Hi there, At the end of last week we saw a number of commits go in that were camelCasing batches of MCStreamer::Emit* and AsmPrinter::Emit* functions. For example: - https://reviews.llvm.org/rG549b436beb4129854e729a3e1398f03429149691 - https://reviews.llvm.org/rGa55daa146166353236aa528546397226bee9363b - https://reviews.llvm.org/rG0bc77a0f0d1606520c7ad0ea72c434661786a956 Unfortunately all these
2020 Feb 18
2
amount of camelCase refactoring causing some downstream overhead
During that variable renaming debate, there was a discussion about discussion about doing things all at once, piecemeal or not at all. An issue that wasn't really resolved I think. I had the impression that the efforts fizzled out a bit, and I thought this renaming was maybe related to that, but I'm neutral on if we should do variable renaming. All I'm asking as a kindness if we could
2014 Oct 13
16
[LLVMdev] RFC: variable names
I’d like to discuss revising the LLVM coding conventions to change the naming of variables to start with a lowercase letter. This should not be a discussion on the pain of such a transition, or how to get from here to there, but rather, if there is a better place to be. My arguments for the change are: 1. No other popular C++ coding style uses capitalized variable names. For instance here
2020 Feb 18
2
amount of camelCase refactoring causing some downstream overhead
I don't think anyone is arguing to change longstanding policy. From a downstream perspective many small renaming changes do increase overhead for us. One thing that happens to downstream projects is that they support more than one LLVM version, we (JuliaLang) currently try to support latest stable + master. So for me the question is more, are renaming changes worth downstream projects not
2010 Nov 01
1
[patch] Allowing to_xml to rename keys in lower camel case format
Hi all, I''ve created and submitted a patch to resolve an issue I had while attempting to meet the OpenSocial API specifications, which dictates that the xml output have tags formatted as lower camelcase (as opposed to upper camelcase, which is currently the only option). With this patch, simply passing :camelize => true still begets the current behavior, but you can now enable lower
2006 Jan 01
5
scaffold not working on Windows XP
Hello, I did a fresh install of ruby182 and gem rails --include-dependencies Now when I do: rails receipts cd receipts ruby script\generate scaffold receipt receipt rails does not create the views or controller. What can I do? Thanks Frank
2019 Feb 22
3
RFC: changing variable naming rules in LLVM codebase
> -----Original Message----- > From: David Greene [mailto:dag at cray.com] > Sent: Friday, February 22, 2019 2:40 PM > To: Robinson, Paul > Cc: asb at lowrisc.org; clattner at nondot.org; llvm-dev at lists.llvm.org; > nd at arm.com > Subject: Re: [llvm-dev] RFC: changing variable naming rules in LLVM > codebase > > via llvm-dev <llvm-dev at lists.llvm.org>
2020 Jun 19
3
Inclusive language in LLVM: can we rename `master` branch?
On 2020-06-19, Justin Hibbits via llvm-dev wrote: >On Fri, 19 Jun 2020 17:38:02 +0100 >Renato Golin <rengolin at gmail.com> wrote: > >> On Fri, 19 Jun 2020 at 16:43, Robinson, Paul via llvm-dev >> <llvm-dev at lists.llvm.org> wrote: >> > If anyone's keeping track of the voting: >> > +1 for "dev" (contrasts with "release")
2020 Feb 20
3
amount of camelCase refactoring causing some downstream overhead
Hi Mehdi! I think the value to upstream (of doing mass reformatting in fewer commits) has to do with the intrusion of nonfunctional commits into `git blame` kinds of research. Every line that someone touches for a formatting reason necessarily obscures the history of functional changes in that block of code. The fewer of those that people have to work around, the better. I admit this is a
2010 Jun 11
5
Issues creating tables in mysql tests
Hello, I''m a beginner, so any hints are appreciated; I''m still trying to find my way around Rails code. For a bug I''ve found I need to create a table called "values" so I added this: create_table :values do |t| t.integer :value end among the other table creations in activerecord/test/cases/migration_test.rb. Is that ok? But then, when I run the tests
2006 Jan 06
2
How do I reference eagerly loaded Models in the View?
[I hope the repost isnt'' "minded". Following the advice of another thread I''ve changed the subject to a question. If I haven''t included important info, please ask. My database is being unduly killed. Jodi] Cheers on-the-Rails-ers, Before I start, I''ve read the ActiveRecord docs on eager loading, but for the life of me, I can''t seem to get
2006 Jul 11
0
text_field_with_auto_complete problem
hello all, I am trying to get a customized text_field_with_auto_complete working where the generated dropdown will display not only the list of teams (first line), but also their city and country(second line). In my view, I have: <p> <label for="team_name">Team: </label> <%= text_field_with_auto_complete :team, :name, {}, :skip_style => true %>
2020 Feb 19
5
amount of camelCase refactoring causing some downstream overhead
Hi Philip, I think you might be reading more into the suggestion/discussion than is actually there. * I do not want upstream developers "trying to be polite" if that delays otherwise worthwhile work. Nobody suggested that. It’s perfectly possible to “be polite” and still not delay worthwhile work. * The current policy is "downstream is on their own". Nobody
2020 Feb 19
7
amount of camelCase refactoring causing some downstream overhead
Hi Philip, While it's true we don't I think Valentin is reasonable in saying "hey, when people do this let's try to combine them if it makes sense". It's just being polite to everyone, especially if it doesn't risk the patches or upstream stability. I don't think there's a policy change being proposed, just a "hey, let's see what we can do in the
2019 Jul 09
4
RFC: changing variable naming rules in LLVM codebase
This looks really great to me Rui, and I’m also pleased to see the positive comments on the review thread. Thank you for driving this forward! -Chris > On Jul 4, 2019, at 9:50 PM, Rui Ueyama <ruiu at google.com> wrote: > > Hi all, > > I wrote a tool <https://reviews.llvm.org/D64123> to batch-rename variable names so that they are in camelCase, and I applied the
2006 Jul 14
3
Accessing the Model class from Controller
Hi, I wonder if there''s an easy way to access the associated Model class from its Controller. Something that would allow me to write snippets like the following: class PeopleController < ApplicationController def some_method person_model_class = self.some_method_to_retrieve_the_person_model_class() end end Cheers, Marco -- Posted via
2007 Jul 18
3
application naming convention
I''m creating a new rails app. The application is named BigIdea. Should I create this project using: 1. rails bigidea or 2. rails big_idea I know both will work, but just want to get off to the right start using the proper rails naming convention. Thanks! Brian -- Posted via http://www.ruby-forum.com/. --~--~---------~--~----~------------~-------~--~----~ You received this
2019 Jul 09
2
RFC: changing variable naming rules in LLVM codebase
Hi Rui, I’m totally positive on switching to camelCase convention. In fact I have been always uncomfortable with the current naming approach. My only suggestion/concern is that we should provide a transition path not only for the trunk code in the repository, but for eventual out-of-trunk code with implementations of custom architectures. I have currently a custom backend implemented on top of