I propose that loadings() be made generic in R-devel with definition loadings <- function(x, ...) UseMethod("loadings") loadings.default <- function(x, ...) x$loadings The default is the current definition of loadings with the ... argument added. The current definition is not specific about the returned value, though $loadings may usually be a matrix. I'm not sure what would be broken if a more strict definition of the return value is enforced. For my purposes a matrix is fine, but I am not sure that there is a benefit from imposing that the returned value must be a matrix, so I suggest sticking with the current non-specific structure for the return value. (For piecewise linear or other non-linear analysis there may be good reasons to allow more general structures for the loadings.) Paul Gilbert