Michał Mirosław
2018-Oct-09 19:14 UTC
[Nouveau] [PATCH] drm/nouveau: avoid client name truncation
If TASK_COMM_LEN is made bigger DRM client name will be truncated. Avoid that. Signed-off-by: Michał Mirosław <mirq-linux at rere.qmqm.pl> --- drivers/gpu/drm/nouveau/nouveau_drm.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/nouveau/nouveau_drm.c b/drivers/gpu/drm/nouveau/nouveau_drm.c index 74d2283f2c28..b0a3708992fe 100644 --- a/drivers/gpu/drm/nouveau/nouveau_drm.c +++ b/drivers/gpu/drm/nouveau/nouveau_drm.c @@ -894,7 +894,7 @@ nouveau_drm_open(struct drm_device *dev, struct drm_file *fpriv) { struct nouveau_drm *drm = nouveau_drm(dev); struct nouveau_cli *cli; - char name[32], tmpname[TASK_COMM_LEN]; + char name[TASK_COMM_LEN + 16], tmpname[TASK_COMM_LEN]; int ret; /* need to bring up power immediately if opening device */ -- 2.19.1
Reasonably Related Threads
- [PATCH] drm: nouveau: replace magic constant for TASK_COMM_LEN
- [PATCH] virtio_net: convert to hw_features
- [PATCH] virtio_net: convert to hw_features
- [PATCH 02/13] fbdev: add remove_conflicting_pci_framebuffers()
- [PATCH 02/13] fbdev: add remove_conflicting_pci_framebuffers()