Michał Mirosław
2017-Aug-31 17:39 UTC
[Nouveau] [PATCH] drm: nouveau: replace magic constant for TASK_COMM_LEN
Client's name is task_comm + pid: use constant for clarity and prepare for changed TASK_COMM_LEN. Signed-off-by: Michał Mirosław <mirq-linux at rere.qmqm.pl> --- drivers/gpu/drm/nouveau/nouveau_drm.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/nouveau/nouveau_drm.c b/drivers/gpu/drm/nouveau/nouveau_drm.c index 15a13d09d431..28396d0b0864 100644 --- a/drivers/gpu/drm/nouveau/nouveau_drm.c +++ b/drivers/gpu/drm/nouveau/nouveau_drm.c @@ -830,7 +830,7 @@ nouveau_drm_open(struct drm_device *dev, struct drm_file *fpriv) { struct nouveau_drm *drm = nouveau_drm(dev); struct nouveau_cli *cli; - char name[32], tmpname[TASK_COMM_LEN]; + char name[TASK_COMM_LEN + 16], tmpname[TASK_COMM_LEN]; int ret; /* need to bring up power immediately if opening device */ -- 2.11.0
Possibly Parallel Threads
- [PATCH] drm/nouveau: avoid client name truncation
- [PATCH] virtio_net: convert to hw_features
- [PATCH] virtio_net: convert to hw_features
- [PATCH 02/13] fbdev: add remove_conflicting_pci_framebuffers()
- [PATCH 02/13] fbdev: add remove_conflicting_pci_framebuffers()