I have implemented a new property for ZFS, "refratio", which is the compression ratio for referenced space (the "compressratio" is the ratio for used space). We are using this here at Delphix to figure out how much space a filesystem would use if it was not compressed (ignoring snapshots). I''d like to integrate this into Illumos. The changes have been reviewed by Delphix folks but it would be nice to get another set of eyes on these 37 lines changed. webrev: http://dev1.illumos.org/~eschrock/cr/zfs-refratio/ bug report: https://www.illumos.org/issues/1092 Thanks! --matt -------------- next part -------------- An HTML attachment was scrubbed... URL: <http://mail.opensolaris.org/pipermail/zfs-discuss/attachments/20110606/d44b5dca/attachment.html>
On Mon, Jun 06, 2011 at 02:19:50PM -0700, Matthew Ahrens wrote:> I have implemented a new property for ZFS, "refratio", which is the > compression ratio for referenced space (the "compressratio" is the ratio for > used space). We are using this here at Delphix to figure out how much space > a filesystem would use if it was not compressed (ignoring snapshots). I''d > like to integrate this into Illumos. The changes have been reviewed by > Delphix folks but it would be nice to get another set of eyes on these 37 > lines changed. > > webrev: > http://dev1.illumos.org/~eschrock/cr/zfs-refratio/ > > bug report: > https://www.illumos.org/issues/1092Just one question - wouldn''t "compressrefratio" (or something similar) be a better name for the property (I know that it''s long, but more intuitive, in my opinion)? Yuri -------------- next part -------------- A non-text attachment was scrubbed... Name: not available Type: application/pgp-signature Size: 834 bytes Desc: not available URL: <http://mail.opensolaris.org/pipermail/zfs-discuss/attachments/20110607/5155fbe8/attachment.bin>
Richard Elling
2011-Jun-06 22:02 UTC
[zfs-discuss] [illumos-Developer] zfs refratio property
On Jun 6, 2011, at 2:54 PM, Yuri Pankov wrote:> On Mon, Jun 06, 2011 at 02:19:50PM -0700, Matthew Ahrens wrote: >> I have implemented a new property for ZFS, "refratio", which is the >> compression ratio for referenced space (the "compressratio" is the ratio for >> used space). We are using this here at Delphix to figure out how much space >> a filesystem would use if it was not compressed (ignoring snapshots). I''d >> like to integrate this into Illumos. The changes have been reviewed by >> Delphix folks but it would be nice to get another set of eyes on these 37 >> lines changed. >> >> webrev: >> http://dev1.illumos.org/~eschrock/cr/zfs-refratio/ >> >> bug report: >> https://www.illumos.org/issues/1092 > > Just one question - wouldn''t "compressrefratio" (or something similar) > be a better name for the property (I know that it''s long, but more > intuitive, in my opinion)?I''d favor "refcompressratio" otherwise LGTM -- richard
Haudy Kazemi
2011-Jun-06 23:08 UTC
[zfs-discuss] [illumos-Developer] zfs refratio property
On 6/6/2011 5:02 PM, Richard Elling wrote:> On Jun 6, 2011, at 2:54 PM, Yuri Pankov wrote: > >> On Mon, Jun 06, 2011 at 02:19:50PM -0700, Matthew Ahrens wrote: >>> I have implemented a new property for ZFS, "refratio", which is the >>> compression ratio for referenced space (the "compressratio" is the ratio for >>> used space). >> Just one question - wouldn''t "compressrefratio" (or something similar) >> be a better name for the property (I know that it''s long, but more >> intuitive, in my opinion)? > I''d favor "refcompressratio" > otherwise LGTM > -- richardLooks useful. I favor longer, more description names. "refcompressratio" is my preference amongst the three proposed names. -hk
Eric Schrock
2011-Jun-06 23:18 UTC
[zfs-discuss] [illumos-Developer] zfs refratio property
It''s worth noting that ZFS supports abbreviated names ("compression" -> "compress", "compressratio" -> "ratio", etc). The short name is used in ''zfs list'' column titles and can also be used as the property name. So maybe the full name should be "refcompressratio" as the long name and "refratio" as the short name would make sense, as that matches "compressratio". Matt? - Eric On Mon, Jun 6, 2011 at 7:08 PM, Haudy Kazemi <kaze0010 at umn.edu> wrote:> On 6/6/2011 5:02 PM, Richard Elling wrote: > >> On Jun 6, 2011, at 2:54 PM, Yuri Pankov wrote: >> >> On Mon, Jun 06, 2011 at 02:19:50PM -0700, Matthew Ahrens wrote: >>> >>>> I have implemented a new property for ZFS, "refratio", which is the >>>> compression ratio for referenced space (the "compressratio" is the ratio >>>> for >>>> used space). >>>> >>> Just one question - wouldn''t "compressrefratio" (or something similar) >>> >>> be a better name for the property (I know that it''s long, but more >>> intuitive, in my opinion)? >>> >> I''d favor "refcompressratio" >> otherwise LGTM >> -- richard >> > > Looks useful. I favor longer, more description names. "refcompressratio" > is my preference amongst the three proposed names. > > -hk > > > _______________________________________________ > Developer mailing list > Developer at lists.illumos.org > http://lists.illumos.org/m/listinfo/developer >-- Eric Schrock Delphix 275 Middlefield Road, Suite 50 Menlo Park, CA 94025 http://www.delphix.com -------------- next part -------------- An HTML attachment was scrubbed... URL: <http://mail.opensolaris.org/pipermail/zfs-discuss/attachments/20110606/a5c1af84/attachment.html>
Matthew Ahrens
2011-Jun-06 23:30 UTC
[zfs-discuss] [illumos-Developer] zfs refratio property
Yeah that sounds great, we can have "refcompressratio" as the long name and "refratio" as the short name, analogous to "compressratio" -> "ratio". --matt On Mon, Jun 6, 2011 at 4:18 PM, Eric Schrock <eric.schrock at delphix.com>wrote:> It''s worth noting that ZFS supports abbreviated names ("compression" -> > "compress", "compressratio" -> "ratio", etc). The short name is used in > ''zfs list'' column titles and can also be used as the property name. So > maybe the full name should be "refcompressratio" as the long name and > "refratio" as the short name would make sense, as that matches > "compressratio". Matt? > > - Eric > > > On Mon, Jun 6, 2011 at 7:08 PM, Haudy Kazemi <kaze0010 at umn.edu> wrote: > >> On 6/6/2011 5:02 PM, Richard Elling wrote: >> >>> On Jun 6, 2011, at 2:54 PM, Yuri Pankov wrote: >>> >>> On Mon, Jun 06, 2011 at 02:19:50PM -0700, Matthew Ahrens wrote: >>>> >>>>> I have implemented a new property for ZFS, "refratio", which is the >>>>> compression ratio for referenced space (the "compressratio" is the >>>>> ratio for >>>>> used space). >>>>> >>>> Just one question - wouldn''t "compressrefratio" (or something similar) >>>> >>>> be a better name for the property (I know that it''s long, but more >>>> intuitive, in my opinion)? >>>> >>> I''d favor "refcompressratio" >>> otherwise LGTM >>> -- richard >>> >> >> Looks useful. I favor longer, more description names. "refcompressratio" >> is my preference amongst the three proposed names. >> >> -hk >> >> >> _______________________________________________ >> Developer mailing list >> Developer at lists.illumos.org >> http://lists.illumos.org/m/listinfo/developer >> > > > > -- > Eric Schrock > Delphix > > 275 Middlefield Road, Suite 50 > Menlo Park, CA 94025 > http://www.delphix.com > > > _______________________________________________ > Developer mailing list > Developer at lists.illumos.org > http://lists.illumos.org/m/listinfo/developer > >-------------- next part -------------- An HTML attachment was scrubbed... URL: <http://mail.opensolaris.org/pipermail/zfs-discuss/attachments/20110606/1ad1acfe/attachment.html>
Richard Elling
2011-Jun-07 01:01 UTC
[zfs-discuss] [illumos-Developer] zfs refratio property
+1 On Jun 6, 2011, at 4:30 PM, Matthew Ahrens wrote:> Yeah that sounds great, we can have "refcompressratio" as the long name and "refratio" as the short name, analogous to "compressratio" -> "ratio". > > --matt > > On Mon, Jun 6, 2011 at 4:18 PM, Eric Schrock <eric.schrock at delphix.com> wrote: > It''s worth noting that ZFS supports abbreviated names ("compression" -> "compress", "compressratio" -> "ratio", etc). The short name is used in ''zfs list'' column titles and can also be used as the property name. So maybe the full name should be "refcompressratio" as the long name and "refratio" as the short name would make sense, as that matches "compressratio". Matt? > > - Eric > > > On Mon, Jun 6, 2011 at 7:08 PM, Haudy Kazemi <kaze0010 at umn.edu> wrote: > On 6/6/2011 5:02 PM, Richard Elling wrote: > On Jun 6, 2011, at 2:54 PM, Yuri Pankov wrote: > > On Mon, Jun 06, 2011 at 02:19:50PM -0700, Matthew Ahrens wrote: > I have implemented a new property for ZFS, "refratio", which is the > compression ratio for referenced space (the "compressratio" is the ratio for > used space). > Just one question - wouldn''t "compressrefratio" (or something similar) > > be a better name for the property (I know that it''s long, but more > intuitive, in my opinion)? > I''d favor "refcompressratio" > otherwise LGTM > -- richard > > Looks useful. I favor longer, more description names. "refcompressratio" is my preference amongst the three proposed names. > > -hk > > > _______________________________________________ > Developer mailing list > Developer at lists.illumos.org > http://lists.illumos.org/m/listinfo/developer > > > > -- > Eric Schrock > Delphix > > 275 Middlefield Road, Suite 50 > Menlo Park, CA 94025 > http://www.delphix.com > > > _______________________________________________ > Developer mailing list > Developer at lists.illumos.org > http://lists.illumos.org/m/listinfo/developer > > > _______________________________________________ > zfs-discuss mailing list > zfs-discuss at opensolaris.org > http://mail.opensolaris.org/mailman/listinfo/zfs-discuss-------------- next part -------------- An HTML attachment was scrubbed... URL: <http://mail.opensolaris.org/pipermail/zfs-discuss/attachments/20110606/d72e309e/attachment.html>
Eric Schrock
2011-Jun-07 01:10 UTC
[zfs-discuss] [illumos-Developer] zfs refratio property
Webrev has been updated: http://dev1.illumos.org/~eschrock/cr/zfs-refratio/ - Eric -- Eric Schrock Delphix 275 Middlefield Road, Suite 50 Menlo Park, CA 94025 http://www.delphix.com -------------- next part -------------- An HTML attachment was scrubbed... URL: <http://mail.opensolaris.org/pipermail/zfs-discuss/attachments/20110606/d9f30f04/attachment.html>
Mark Musante
2011-Jun-07 01:39 UTC
[zfs-discuss] [illumos-Developer] zfs refratio property
minor quibble: compressratio uses a lowercase x for the description text whereas the new prop uses an uppercase X On 6 Jun 2011, at 21:10, Eric Schrock wrote:> Webrev has been updated: > > http://dev1.illumos.org/~eschrock/cr/zfs-refratio/ > > - Eric > > -- > Eric Schrock > Delphix > > 275 Middlefield Road, Suite 50 > Menlo Park, CA 94025 > http://www.delphix.com > > _______________________________________________ > zfs-discuss mailing list > zfs-discuss at opensolaris.org > http://mail.opensolaris.org/mailman/listinfo/zfs-discuss-------------- next part -------------- An HTML attachment was scrubbed... URL: <http://mail.opensolaris.org/pipermail/zfs-discuss/attachments/20110606/999283ed/attachment-0001.html>
Eric Schrock
2011-Jun-07 01:56 UTC
[zfs-discuss] [illumos-Developer] zfs refratio property
Good catch. For consistency, I updated the property description to match "compressratio" exactly. - Eric On Mon, Jun 6, 2011 at 9:39 PM, Mark Musante <mark.musante at oracle.com>wrote:> > minor quibble: compressratio uses a lowercase x for the description text > whereas the new prop uses an uppercase X > >-- Eric Schrock Delphix 275 Middlefield Road, Suite 50 Menlo Park, CA 94025 http://www.delphix.com -------------- next part -------------- An HTML attachment was scrubbed... URL: <http://mail.opensolaris.org/pipermail/zfs-discuss/attachments/20110606/a7bf1e87/attachment.html>
Richard Elling
2011-Jun-07 05:34 UTC
[zfs-discuss] [illumos-Developer] zfs refratio property
Beautiful, ship it -- richard On Jun 6, 2011, at 6:56 PM, Eric Schrock wrote:> Good catch. For consistency, I updated the property description to match "compressratio" exactly. > > - Eric > > On Mon, Jun 6, 2011 at 9:39 PM, Mark Musante <mark.musante at oracle.com> wrote: > > minor quibble: compressratio uses a lowercase x for the description text whereas the new prop uses an uppercase X > > > > -- > Eric Schrock > Delphix > > 275 Middlefield Road, Suite 50 > Menlo Park, CA 94025 > http://www.delphix.com > > _______________________________________________ > Developer mailing list > Developer at lists.illumos.org > http://lists.illumos.org/m/listinfo/developer-------------- next part -------------- An HTML attachment was scrubbed... URL: <http://mail.opensolaris.org/pipermail/zfs-discuss/attachments/20110606/f1e06b7c/attachment.html>