For debug builds we define __WXDEBUG__ and WXDEBUG=1. In the swig code we add a check for wxDEBUG to directors. My guess is we mean for one of those defines to be the other. Which one should we change? wxDEBUG-> WXDEBUG or WXDEBUG-> wxDebug? Roy
Roy Sutton wrote:> For debug builds we define __WXDEBUG__ and WXDEBUG=1. In the swig code > we add a check for wxDEBUG to directors. My guess is we mean for one of > those defines to be the other. Which one should we change? wxDEBUG-> > WXDEBUG or WXDEBUG-> wxDebug?Looks like __WXDEBUG__ is the official one: kevins@aria:~/work/wxruby2$ wx-config --cflags -I/usr/local/lib/wx/include/gtk2-unicode-debug-2.6 -I/usr/local/include/wx-2.6 -D__WXDEBUG__ -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 Is there any reason to have WXDEBUG or wxDEBUG or wxDebug? Kevin
I''ll submit a patch later for fixdeleting.rb. The other option is to change its wxDEBUG to DIRECTOR_DEBUG or some such. Kevin Smith wrote:> Roy Sutton wrote: > >> For debug builds we define __WXDEBUG__ and WXDEBUG=1. In the swig >> code we add a check for wxDEBUG to directors. My guess is we mean >> for one of those defines to be the other. Which one should we >> change? wxDEBUG-> WXDEBUG or WXDEBUG-> wxDebug? > > > Looks like __WXDEBUG__ is the official one: > > kevins@aria:~/work/wxruby2$ wx-config --cflags > -I/usr/local/lib/wx/include/gtk2-unicode-debug-2.6 > -I/usr/local/include/wx-2.6 -D__WXDEBUG__ -D__WXGTK__ > -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 > > Is there any reason to have WXDEBUG or wxDEBUG or wxDebug? > > Kevin > > _______________________________________________ > wxruby-users mailing list > wxruby-users@rubyforge.org > http://rubyforge.org/mailman/listinfo/wxruby-users > > >
Roy Sutton wrote:> I''ll submit a patch later for fixdeleting.rb. The other option is to > change its wxDEBUG to DIRECTOR_DEBUG or some such.Ah, I see the context now. It would probably be better to use something other than __WXDEBUG__, in case someone wants normal wx debugging but not this, or vice versa. DIRECTOR_DEBUG would be fine, or maybe VERBOSE_DIRECTORS. I don''t have strong feelings either way. Thanks, Kevin