? 2022/3/8 ??8:35, Xuan Zhuo ??:> Add helper for virtio queue reset.
>
> * virtio_reset_vq(): reset a queue individually
> * virtio_enable_resetq(): enable a reset queue
>
> Signed-off-by: Xuan Zhuo <xuanzhuo at linux.alibaba.com>
> ---
> include/linux/virtio_config.h | 40 +++++++++++++++++++++++++++++++++++
> 1 file changed, 40 insertions(+)
>
> diff --git a/include/linux/virtio_config.h b/include/linux/virtio_config.h
> index d51906b1389f..0b81fbe17c85 100644
> --- a/include/linux/virtio_config.h
> +++ b/include/linux/virtio_config.h
> @@ -230,6 +230,46 @@ int virtio_find_vqs_ctx(struct virtio_device *vdev,
unsigned nvqs,
> desc);
> }
>
> +/**
> + * virtio_reset_vq - reset a queue individually
> + * @vq: the virtqueue
> + *
> + * returns 0 on success or error status
> + *
> + * The api process of reset under normal circumstances:
> + * 1. virtio_reset_vq() - notify the device to reset the
queue
> + * 2. virtqueue_detach_unused_buf() - recycle the buffer submitted
> + * 3. virtqueue_reset_vring() - reset the vring (may re-alloc)
> + * 4. virtio_enable_resetq() - mmap vring to device, and enable
the queue
> + *
> + * Caller should guarantee that the vring is not accessed by any functions
> + * of virtqueue.
> + */
> +static inline
> +int virtio_reset_vq(struct virtqueue *vq)
> +{
It looks to me the prefix "virtio" is used for the device specific
operations.
I wonder if it's better to rename this as virtqueue_reste() and move it
to virtio_ring.c?
Thanks
> + if (!vq->vdev->config->reset_vq)
> + return -ENOENT;
> +
> + return vq->vdev->config->reset_vq(vq);
> +}
> +
> +/**
> + * virtio_enable_resetq - enable a reset queue
> + * @vq: the virtqueue
> + *
> + * returns 0 on success or error status
> + *
> + */
> +static inline
> +int virtio_enable_resetq(struct virtqueue *vq)
> +{
> + if (!vq->vdev->config->enable_reset_vq)
> + return -ENOENT;
> +
> + return vq->vdev->config->enable_reset_vq(vq);
> +}
> +
> /**
> * virtio_device_ready - enable vq use in probe function
> * @vdev: the device