Michael S. Tsirkin
2016-Oct-09 23:30 UTC
[PATCH 4/4] virtio_blk: Rename a jump label in virtblk_get_id()
On Tue, Sep 13, 2016 at 02:15:20PM +0200, SF Markus Elfring wrote:> From: Markus Elfring <elfring at users.sourceforge.net> > Date: Tue, 13 Sep 2016 13:50:56 +0200 > > Adjust a jump label according to the current Linux coding style convention. > > Signed-off-by: Markus Elfring <elfring at users.sourceforge.net>Please don't send me such patches, I'm not really interested in renaming labels unless it clearly adds to a significant improvement in readability.> --- > drivers/block/virtio_blk.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/block/virtio_blk.c b/drivers/block/virtio_blk.c > index 696f452..fef2bd0 100644 > --- a/drivers/block/virtio_blk.c > +++ b/drivers/block/virtio_blk.c > @@ -247,10 +247,10 @@ static int virtblk_get_id(struct gendisk *disk, char *id_str) > > err = blk_rq_map_kern(q, req, id_str, VIRTIO_BLK_ID_BYTES, GFP_KERNEL); > if (err) > - goto out; > + goto put_request; > > err = blk_execute_rq(vblk->disk->queue, vblk->disk, req, false); > -out: > + put_request: > blk_put_request(req); > return err; > } > -- > 2.10.0
SF Markus Elfring
2016-Oct-10 08:18 UTC
virtio_blk: Rename a jump label in virtblk_get_id()
> Please don't send me such patches, I'm not really interested in renaming labelsThanks for your feedback.> unless it clearly adds to a significant improvement in readability.Have you got any more concrete conditions for the selection of appropriate identifiers in this use case according to your software development view? Regards, Markus
Seemingly Similar Threads
- [PATCH 4/4] virtio_blk: Rename a jump label in virtblk_get_id()
- [PATCH 4/4] virtio_blk: Rename a jump label in virtblk_get_id()
- [PATCH 4/4] virtio_blk: Rename a jump label in virtblk_get_id()
- [PATCH 3/4] virtio_blk: implement a request-based ID command, VIRTIO_BLK_T_GET_ID
- [PATCH 3/4] virtio_blk: implement a request-based ID command, VIRTIO_BLK_T_GET_ID