similar to: [PATCH] drm/nouveau/dispnv04: fix null pointer dereference in nv17_tv_get_hd_modes

Displaying 20 results from an estimated 900 matches similar to: "[PATCH] drm/nouveau/dispnv04: fix null pointer dereference in nv17_tv_get_hd_modes"

2023 Oct 13
1
[PATCH] drm/nouveau/dispnv04: fix a possible null pointer dereference
In nv17_tv_get_hd_modes(), the return value of drm_mode_duplicate() is assigned to mode, which will lead to a NULL pointer dereference on failure of drm_mode_duplicate(). The same applies to drm_cvt_mode(). Add a check to avoid null pointer dereference. Signed-off-by: Ma Ke <make_ruc2021 at 163.com> --- drivers/gpu/drm/nouveau/dispnv04/tvnv17.c | 4 ++++ 1 file changed, 4 insertions(+)
2024 Jun 25
0
[PATCH] drm/nouveau/dispnv04: fix null pointer dereference in nv17_tv_get_hd_modes
> In nv17_tv_get_hd_modes(), the return value of drm_mode_duplicate() is > assigned to mode, which will lead to a possible NULL pointer dereference > on failure of drm_mode_duplicate(). The same applies to drm_cvt_mode(). > Add a check to avoid null pointer dereference. Can a wording approach (like the following) be a better change description? A null pointer is stored in the local
2024 Jun 25
0
[PATCH] drm/nouveau/dispnv04: fix null pointer dereference in nv17_tv_get_ld_modes
Reviewed-by: Lyude Paul <lyude at redhat.com> On Tue, 2024-06-25 at 16:18 +0800, Ma Ke wrote: > In nv17_tv_get_ld_modes(), the return value of drm_mode_duplicate() > is > assigned to mode, which will lead to a possible NULL pointer > dereference > on failure of drm_mode_duplicate(). Add a check to avoid npd. > > Cc: stable at vger.kernel.org > Signed-off-by: Ma Ke
2023 Oct 07
1
[PATCH] drm/nouveau/dispnv04: fix a possible null pointer dereference
In nv17_tv_get_ld_modes(), the return value of drm_mode_duplicate() is assigned to mode, which will lead to a NULL pointer dereference on failure of drm_mode_duplicate(). Add a check to avoid npd. Signed-off-by: Ma Ke <make_ruc2021 at 163.com> --- drivers/gpu/drm/nouveau/dispnv04/tvnv17.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/gpu/drm/nouveau/dispnv04/tvnv17.c
2024 Jun 26
1
[PATCH] drm/nouveau: fix null pointer dereference in nouveau_connector_get_modes
On Wed, 26 Jun 2024, Ma Ke <make24 at iscas.ac.cn> wrote: > In nouveau_connector_get_modes(), the return value of drm_mode_duplicate() > is assigned to mode, which will lead to a possible NULL pointer > dereference on failure of drm_mode_duplicate(). Add a check to avoid npd. > > Signed-off-by: Ma Ke <make24 at iscas.ac.cn> > --- >
2024 Jun 25
1
[PATCH] drm/nouveau/dispnv04: fix null pointer dereference in nv17_tv_get_ld_modes
> In nv17_tv_get_ld_modes(), the return value of drm_mode_duplicate() is > assigned to mode, which will lead to a possible NULL pointer dereference > on failure of drm_mode_duplicate(). Add a check to avoid npd. Can a wording approach (like the following) be a better change description? A null pointer is stored in the local variable ?mode? after a call of the function
2024 Jun 26
0
[PATCH] drm/nouveau: fix null pointer dereference in nouveau_connector_get_modes
> In nouveau_connector_get_modes(), the return value of drm_mode_duplicate() > is assigned to mode, which will lead to a possible NULL pointer > dereference on failure of drm_mode_duplicate(). Add a check to avoid npd. 1. Can a wording approach (like the following) be a better change description? A null pointer is stored in the local variable ?mode? after a call of the function
2019 Dec 30
1
[PATCH -next] drm/nouveau/nv04: Use match_string() helper to simplify the code
match_string() returns the array index of a matching string. Use it instead of the open-coded implementation. Signed-off-by: YueHaibing <yuehaibing at huawei.com> --- drivers/gpu/drm/nouveau/dispnv04/tvnv17.c | 13 +++++-------- 1 file changed, 5 insertions(+), 8 deletions(-) diff --git a/drivers/gpu/drm/nouveau/dispnv04/tvnv17.c b/drivers/gpu/drm/nouveau/dispnv04/tvnv17.c index
2018 May 31
1
[PATCH v2 11/21] drm/nouveau: use match_string() helper
match_string() returns the index of an array for a matching string, which can be used instead of open coded variant. Cc: Ben Skeggs <bskeggs at redhat.com> Cc: David Airlie <airlied at linux.ie> Cc: dri-devel at lists.freedesktop.org Cc: nouveau at lists.freedesktop.org Signed-off-by: Yisheng Xie <xieyisheng1 at huawei.com> --- v2: - handle err case before normal case - per
2016 Aug 02
0
[PATCH 0202/1285] Replace numeric parameter like 0444 with macro
I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng
2018 May 21
1
[PATCH 21/33] drm/nouveau: use match_string() helper
match_string() returns the index of an array for a matching string, which can be used intead of open coded variant. Cc: Ben Skeggs <bskeggs at redhat.com> Cc: David Airlie <airlied at linux.ie> Cc: dri-devel at lists.freedesktop.org Cc: nouveau at lists.freedesktop.org Signed-off-by: Yisheng Xie <xieyisheng1 at huawei.com> --- drivers/gpu/drm/nouveau/dispnv04/tvnv17.c | 13
2018 Sep 14
0
[PATCH] drm: nouveau: use match_string() helper to simplify the code
match_string() returns the index of an array for a matching string, which can be used intead of open coded implementation. Signed-off-by: zhong jiang <zhongjiang at huawei.com> --- drivers/gpu/drm/nouveau/dispnv04/tvnv17.c | 14 +++++--------- 1 file changed, 5 insertions(+), 9 deletions(-) diff --git a/drivers/gpu/drm/nouveau/dispnv04/tvnv17.c b/drivers/gpu/drm/nouveau/dispnv04/tvnv17.c
2019 Mar 27
0
[PATCH AUTOSEL 5.0 242/262] drm/nouveau: Stop using drm_crtc_force_disable
From: Daniel Vetter <daniel.vetter at ffwll.ch> [ Upstream commit 934c5b32a5e43d8de2ab4f1566f91d7c3bf8cb64 ] The correct way for legacy drivers to update properties that need to do a full modeset, is to do a full modeset. Note that we don't need to call the drm_mode_config_internal helper because we're not changing any of the refcounted paramters. v2: Fixup error handling
2019 Mar 27
0
[PATCH AUTOSEL 4.19 177/192] drm/nouveau: Stop using drm_crtc_force_disable
From: Daniel Vetter <daniel.vetter at ffwll.ch> [ Upstream commit 934c5b32a5e43d8de2ab4f1566f91d7c3bf8cb64 ] The correct way for legacy drivers to update properties that need to do a full modeset, is to do a full modeset. Note that we don't need to call the drm_mode_config_internal helper because we're not changing any of the refcounted paramters. v2: Fixup error handling
2019 Mar 27
0
[PATCH AUTOSEL 4.14 114/123] drm/nouveau: Stop using drm_crtc_force_disable
From: Daniel Vetter <daniel.vetter at ffwll.ch> [ Upstream commit 934c5b32a5e43d8de2ab4f1566f91d7c3bf8cb64 ] The correct way for legacy drivers to update properties that need to do a full modeset, is to do a full modeset. Note that we don't need to call the drm_mode_config_internal helper because we're not changing any of the refcounted paramters. v2: Fixup error handling
2019 Mar 27
0
[PATCH AUTOSEL 4.9 80/87] drm/nouveau: Stop using drm_crtc_force_disable
From: Daniel Vetter <daniel.vetter at ffwll.ch> [ Upstream commit 934c5b32a5e43d8de2ab4f1566f91d7c3bf8cb64 ] The correct way for legacy drivers to update properties that need to do a full modeset, is to do a full modeset. Note that we don't need to call the drm_mode_config_internal helper because we're not changing any of the refcounted paramters. v2: Fixup error handling
2018 Mar 27
1
[PATCH FOR DISCUSSION ONLY] v2v: Add -o kubevirt output mode.
XXX No documentation. Only handles one disk. Network cards? Do we need to escape YAML format? What firmware types does kubevirt support. --- v2v/Makefile.am | 2 + v2v/cmdline.ml | 21 ++++++++++ v2v/output_kubevirt.ml | 103 ++++++++++++++++++++++++++++++++++++++++++++++++ v2v/output_kubevirt.mli | 24 +++++++++++ 4 files changed, 150 insertions(+) diff --git
2016 Nov 08
0
[PATCH] drm/nouveau: fix LEDS_CLASS=m configuration
On Tue, Nov 8, 2016 at 8:56 AM, Arnd Bergmann <arnd at arndb.de> wrote: > The newly introduced LED handling for nouveau fails to link when the > driver is built-in but the LED subsystem is a loadable module: > > drivers/gpu/drm/nouveau/nouveau.o: In function `nouveau_do_suspend': > tvnv17.c:(.text.nouveau_do_suspend+0x10): undefined reference to `nouveau_led_suspend'
2016 Jul 19
0
[PATCH v2 2/2] v2v: use Getopt.Symbol for few options
Use Getopt.Symbol for options with a fixed list of choices, so there is no need to check them on our own. --- v2v/cmdline.ml | 15 ++++++--------- 1 file changed, 6 insertions(+), 9 deletions(-) diff --git a/v2v/cmdline.ml b/v2v/cmdline.ml index 2d0a10a..96e0509 100644 --- a/v2v/cmdline.ml +++ b/v2v/cmdline.ml @@ -83,8 +83,7 @@ let parse_cmdline () = | "libvirt" -> input_mode
2016 Apr 10
1
[PATCH] module parameters: permissions as defines, readable to everyone
For the purposes of the module parameters, specifies the permissions of the corresponding files in sysfs in predefined S_I* form rather than in octal notation. Withal it makes the source code more consistent. Moreover, because all parameters are readable to everyone, it is more user-friendly. $ grep S_IRUGO include/linux/stat.h #define S_IRUGO (S_IRUSR|S_IRGRP|S_IROTH) $ grep