similar to: [PATCH] drm/nouveau/bios/init: fix spelling mistake: "CONDITON" -> "CONDITION"

Displaying 20 results from an estimated 4000 matches similar to: "[PATCH] drm/nouveau/bios/init: fix spelling mistake: "CONDITON" -> "CONDITION""

2019 May 14
2
[PATCH] drm/nouveau/bios/init: fix spelling mistake "CONDITON" -> "CONDITION"
From: Colin Ian King <colin.king at canonical.com> There is a spelling mistake in a warning message. Fix it. Signed-off-by: Colin Ian King <colin.king at canonical.com> --- drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c
2018 Oct 12
0
[PATCH] drm/nouveau/bios/init: fix spelling mistake "INIT_GENERIC_CONDITON" -> "INIT_GENERIC_CONDITION"
From: Colin Ian King <colin.king at canonical.com> Trivial fix to spelling mistake in warn message text Signed-off-by: Colin Ian King <colin.king at canonical.com> --- drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c b/drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c
2016 Dec 29
0
[PATCH] drm/nouveau/bios: fix spelling mistake: "INIT_GENERIC_CONDITON" -> "INIT_GENERIC_CONDITION"
From: Colin Ian King <colin.king at canonical.com> trivial fix to spelling mistake in warn message Signed-off-by: Colin Ian King <colin.king at canonical.com> --- drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c b/drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c index
2023 Jun 09
1
[RESEND 07/15] drm/nouveau/nvkm/subdev/bios/init: Demote a bunch of kernel-doc abuses
Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c:584: warning: Function parameter or member 'init' not described in 'init_reserved' drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c:611: warning: expecting prototype for INIT_DONE(). Prototype was for init_done() instead [Snipped ~140 lines for brevity] Cc: Ben Skeggs <bskeggs at
2023 Aug 24
1
[PATCH 03/20] drm/nouveau/nvkm/subdev/bios/init: Demote a bunch of kernel-doc abuses
Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c:584: warning: Function parameter or member 'init' not described in 'init_reserved' drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c:611: warning: expecting prototype for INIT_DONE(). Prototype was for init_done() instead [Snipped ~140 lines for brevity] Signed-off-by: Lee Jones
2017 Oct 16
0
[PATCH] drm/nouveau/bios/init: use ARRAY_SIZE
Using the ARRAY_SIZE macro improves the readability of the code. Also, it is useless to re-invent it. Found with Coccinelle with the following semantic patch: @r depends on (org || report)@ type T; T[] E; position p; @@ ( (sizeof(E)@p /sizeof(*E)) | (sizeof(E)@p /sizeof(E[...])) | (sizeof(E)@p /sizeof(T)) ) Reviewed-by: Thierry Reding <treding at nvidia.com> Signed-off-by: Jérémy
2019 Nov 02
0
[PATCH] drm/nouveau/bios/init: make const arrays probe_order static, makes object smaller
From: Colin Ian King <colin.king at canonical.com> Don't populate const arrays on the stack but instead make them static. Makes the object code smaller by 6 bytes. Before: text data bss dec hex filename 103075 9692 0 112767 1b87f nvkm/subdev/bios/init.o After: text data bss dec hex filename 102909 9852 0 112761 1b879
2020 Oct 16
0
[PATCH] drm/nouveau/bios/init: make two const arrays static, makes object smaller
From: Colin Ian King <colin.king at canonical.com> Don't populate const arrays on the stack but instead make them static. Makes the object code smaller by 7 bytes. Before: text data bss dec hex filename 104041 8284 0 112325 1b6c5 drm/nouveau/nvkm/subdev/bios/init.o After: text data bss dec hex filename 103874 8444 0 112318
2017 Sep 03
0
[PATCH 4/10] drm/nouveau/bios/init: Use ARRAY_SIZE macro
Use ARRAY_SIZE macro, rather than explicitly coding some variant of it yourself. Found with: find -type f -name "*.c" -o -name "*.h" | xargs perl -p -i -e 's/\bsizeof\s*\(\s*(\w+)\s*\)\s*\ /\s*sizeof\s*\(\s*\1\s*\[\s*0\s*\]\s*\) /ARRAY_SIZE(\1)/g' and manual check/verification. Signed-off-by: Thomas Meyer <thomas at m3y3r.de> --- diff --git
2023 Jun 09
7
[RESEND 00/15] Rid W=1 warnings from GPU
This set is part of a larger effort attempting to clean-up W=1 kernel builds, which are currently overwhelmingly riddled with niggly little warnings. Lee Jones (15): drm/xlnx/zynqmp_disp: Use correct kerneldoc formatting in zynqmp_disp drm/xlnx/zynqmp_dp: Fix function name zynqmp_dp_link_train() -> zynqmp_dp_train() drm/vkms/vkms_composer: Fix a few different kerneldoc formatting
2023 Aug 24
7
[PATCH (set 1) 00/20] Rid W=1 warnings from GPU
This set is part of a larger effort attempting to clean-up W=1 kernel builds, which are currently overwhelmingly riddled with niggly little warnings. Cc: Alex Deucher <alexander.deucher at amd.com> Cc: amd-gfx at lists.freedesktop.org Cc: Ben Skeggs <bskeggs at redhat.com> Cc: "Christian K?nig" <christian.koenig at amd.com> Cc: Daniel Vetter <daniel at ffwll.ch>
2016 Jun 04
0
[PATCH 3/3] nvkm/init: Add support for opcode 0xaf
As seen in at least one NV134 VBIOS (... that I obviously don't own myself). Signed-off-by: Roy Spliet <nouveau at spliet.org> --- drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c | 27 +++++++++++++++++++++++++ 1 file changed, 27 insertions(+) diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c b/drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c index 38ed09f..a18f8b4 100644
2018 Jun 29
1
[Bug 107069] New: trace in kernel.log on boot
https://bugs.freedesktop.org/show_bug.cgi?id=107069 Bug ID: 107069 Summary: trace in kernel.log on boot Product: xorg Version: 7.7 (2012.06) Hardware: x86-64 (AMD64) OS: Linux (All) Status: NEW Severity: normal Priority: medium Component: Driver/nouveau Assignee: nouveau at
2017 Oct 01
0
[PATCH 06/18] drm: use ARRAY_SIZE
Using the ARRAY_SIZE macro improves the readability of the code. Also, it is not always useful to use a variable to store this constant calculated at compile time nor to re-invent the ARRAY_SIZE macro. Found with Coccinelle with the following semantic patch: @r depends on (org || report)@ type T; T[] E; position p; @@ ( (sizeof(E)@p /sizeof(*E)) | (sizeof(E)@p /sizeof(E[...])) | (sizeof(E)@p
2019 Jun 02
3
[PATCH 0/2] drm/nouveau/bios/init: Improve pre-PMU devinit opcode coverage
NVIDIA GPUs include a common scripting language (devinit) that can be interpreted by a number of "engines", e.g. within a kernel-mode software driver, the VGA BIOS or an on-board small microcontroller which provides certain security assertions (the 'PMU'). This system allows a GPU programming sequence to be shared by multiple entities that would not otherwise be able to execute
2017 Apr 10
0
[PATCH 10/11] nvkm/pmu/memx: init script -> memx translation
Signed-off-by: Roy Spliet <nouveau at spliet.org> --- drivers/gpu/drm/nouveau/include/nvkm/subdev/pmu.h | 2 + drivers/gpu/drm/nouveau/nvkm/subdev/fb/ramfuc.h | 8 +++ drivers/gpu/drm/nouveau/nvkm/subdev/pmu/memx.c | 66 +++++++++++++++++++++++ 3 files changed, 76 insertions(+) diff --git a/drivers/gpu/drm/nouveau/include/nvkm/subdev/pmu.h
2018 Nov 30
2
[PATCH RFC 03/15] drm/nouveau: replace **** with a hug
On Fri, Nov 30, 2018 at 5:30 PM Jarkko Sakkinen <jarkko.sakkinen at linux.intel.com> wrote: > > In order to comply with the CoC, replace **** with a hug. > > Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen at linux.intel.com> > --- > drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c | 2 +- > drivers/gpu/drm/nouveau/nvkm/subdev/pmu/fuc/macros.fuc | 2 +- >
2017 Dec 30
24
[Bug 104421] New: System freeze on wayland with nouveau on NV137 (GP107)
https://bugs.freedesktop.org/show_bug.cgi?id=104421 Bug ID: 104421 Summary: System freeze on wayland with nouveau on NV137 (GP107) Product: xorg Version: unspecified Hardware: Other OS: All Status: NEW Severity: normal Priority: medium Component: Driver/nouveau Assignee:
2019 Apr 18
1
[PATCH] drm/nouveau/fb/ramgk104: fix spelling mistake "sucessfully" -> "successfully"
From: Colin Ian King <colin.king at canonical.com> There is a spelling mistake in a nvkm_debug message. Fix it. Signed-off-by: Colin Ian King <colin.king at canonical.com> --- drivers/gpu/drm/nouveau/nvkm/subdev/fb/ramgk104.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/fb/ramgk104.c
2017 Apr 29
1
[PATCH] tools/virtio: fix spelling mistake: "wakeus" -> "wakeups"
From: Colin Ian King <colin.king at canonical.com> trivial fix to spelling mistake in an error message. Signed-off-by: Colin Ian King <colin.king at canonical.com> --- tools/virtio/virtio_test.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/tools/virtio/virtio_test.c b/tools/virtio/virtio_test.c index 76d6f583c249..0fecaec90d0d 100644 ---