similar to: [PATCH] drm/nouveau/bios/init: use ARRAY_SIZE

Displaying 20 results from an estimated 200 matches similar to: "[PATCH] drm/nouveau/bios/init: use ARRAY_SIZE"

2017 Oct 01
0
[PATCH 06/18] drm: use ARRAY_SIZE
Using the ARRAY_SIZE macro improves the readability of the code. Also, it is not always useful to use a variable to store this constant calculated at compile time nor to re-invent the ARRAY_SIZE macro. Found with Coccinelle with the following semantic patch: @r depends on (org || report)@ type T; T[] E; position p; @@ ( (sizeof(E)@p /sizeof(*E)) | (sizeof(E)@p /sizeof(E[...])) | (sizeof(E)@p
2017 Sep 03
0
[PATCH 4/10] drm/nouveau/bios/init: Use ARRAY_SIZE macro
Use ARRAY_SIZE macro, rather than explicitly coding some variant of it yourself. Found with: find -type f -name "*.c" -o -name "*.h" | xargs perl -p -i -e 's/\bsizeof\s*\(\s*(\w+)\s*\)\s*\ /\s*sizeof\s*\(\s*\1\s*\[\s*0\s*\]\s*\) /ARRAY_SIZE(\1)/g' and manual check/verification. Signed-off-by: Thomas Meyer <thomas at m3y3r.de> --- diff --git
2017 Oct 01
6
[PATCH 00/18] use ARRAY_SIZE macro
Hi everyone, Using ARRAY_SIZE improves the code readability. I used coccinelle (I made a change to the array_size.cocci file [1]) to find several places where ARRAY_SIZE could be used instead of other macros or sizeof division. I tried to divide the changes into a patch per subsystem (excepted for staging). If one of the patch should be split into several patches, let me know. In order to reduce
2016 Jun 04
0
[PATCH 3/3] nvkm/init: Add support for opcode 0xaf
As seen in at least one NV134 VBIOS (... that I obviously don't own myself). Signed-off-by: Roy Spliet <nouveau at spliet.org> --- drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c | 27 +++++++++++++++++++++++++ 1 file changed, 27 insertions(+) diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c b/drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c index 38ed09f..a18f8b4 100644
2017 Oct 01
2
[PATCH 00/18] use ARRAY_SIZE macro
On Sun, Oct 01, 2017 at 03:30:38PM -0400, Jérémy Lefaure wrote: > Hi everyone, > Using ARRAY_SIZE improves the code readability. I used coccinelle (I > made a change to the array_size.cocci file [1]) to find several places > where ARRAY_SIZE could be used instead of other macros or sizeof > division. > > I tried to divide the changes into a patch per subsystem (excepted for
2017 Oct 02
2
[PATCH 00/18] use ARRAY_SIZE macro
On Sun, Oct 01, 2017 at 08:52:20PM -0400, Jérémy Lefaure wrote: > On Mon, 2 Oct 2017 09:01:31 +1100 > "Tobin C. Harding" <me at tobin.cc> wrote: > > > > In order to reduce the size of the To: and Cc: lines, each patch of the > > > series is sent only to the maintainers and lists concerned by the patch. > > > This cover letter is sent to every
2017 Oct 02
0
[PATCH 00/18] use ARRAY_SIZE macro
On Mon, Oct 02, 2017 at 07:35:54AM +0200, Greg KH wrote: > On Sun, Oct 01, 2017 at 08:52:20PM -0400, Jérémy Lefaure wrote: > > On Mon, 2 Oct 2017 09:01:31 +1100 > > "Tobin C. Harding" <me at tobin.cc> wrote: > > > > > > In order to reduce the size of the To: and Cc: lines, each patch of the > > > > series is sent only to the maintainers
2017 Oct 05
0
[PATCH 00/18] use ARRAY_SIZE macro
On Mon, Oct 02, 2017 at 09:33:12PM -0400, Jérémy Lefaure wrote: > On Mon, 2 Oct 2017 15:22:24 -0400 > bfields at fieldses.org (J. Bruce Fields) wrote: > > > Mainly I'd just like to know which you're asking for. Do you want me to > > apply this, or to ACK it so someone else can? If it's sent as a series > > I tend to assume the latter. > > > >
2017 Oct 03
1
[PATCH 00/18] use ARRAY_SIZE macro
On Mon, 2 Oct 2017 15:22:24 -0400 bfields at fieldses.org (J. Bruce Fields) wrote: > Mainly I'd just like to know which you're asking for. Do you want me to > apply this, or to ACK it so someone else can? If it's sent as a series > I tend to assume the latter. > > But in this case I'm assuming it's the former, so I'll pick up the nfsd > one.... Could
2013 Dec 21
21
[Bug 72943] New: NV98 [GeForce 9300 gs m] hangs on boot- all linux kernel versions > 3.2
https://bugs.freedesktop.org/show_bug.cgi?id=72943 Priority: medium Bug ID: 72943 Assignee: nouveau at lists.freedesktop.org Summary: NV98 [GeForce 9300 gs m] hangs on boot- all linux kernel versions > 3.2 QA Contact: xorg-team at lists.x.org Severity: normal Classification: Unclassified OS:
2016 Jun 04
3
PM + Init work
Following a series of three patches, two of which have been sitting in my tree for a while, the third is the result of some inspection of an NV134 BIOS that seems to use the 0xaf upcode to upload training patterns. Please test! Roy Ps. Sorry they come from yet another e-mail address. My previous provider, eclipso, actively blocks users of git send-email. Inquiries fall on deaf ears, hence I
2018 Jun 29
1
[Bug 107069] New: trace in kernel.log on boot
https://bugs.freedesktop.org/show_bug.cgi?id=107069 Bug ID: 107069 Summary: trace in kernel.log on boot Product: xorg Version: 7.7 (2012.06) Hardware: x86-64 (AMD64) OS: Linux (All) Status: NEW Severity: normal Priority: medium Component: Driver/nouveau Assignee: nouveau at
2020 May 05
0
problems with NVS310
The warning you included happens when we're trying to execute a VBIOS script as part of DP training. Can you include your vbios? It should be available at /sys/kernel/debug/dri/0/vbios.rom Also, can you confirm how your monitors are connected to the card (and e.g. what resolution they are, anything else "funny" about them)? Finally, this warning might not have anything to do with
2023 Jun 09
1
[RESEND 07/15] drm/nouveau/nvkm/subdev/bios/init: Demote a bunch of kernel-doc abuses
Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c:584: warning: Function parameter or member 'init' not described in 'init_reserved' drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c:611: warning: expecting prototype for INIT_DONE(). Prototype was for init_done() instead [Snipped ~140 lines for brevity] Cc: Ben Skeggs <bskeggs at
2023 Aug 24
1
[PATCH 03/20] drm/nouveau/nvkm/subdev/bios/init: Demote a bunch of kernel-doc abuses
Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c:584: warning: Function parameter or member 'init' not described in 'init_reserved' drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c:611: warning: expecting prototype for INIT_DONE(). Prototype was for init_done() instead [Snipped ~140 lines for brevity] Signed-off-by: Lee Jones
2020 May 05
2
problems with NVS310
I have a Nvidia NVS310 installed in my Linux computer for a few years. It works well with the Nvidia driver, and not so well with the Linux nouveau driver. The Nvidia NVS310 has never worked well with Linux. In the beginning (many years ago) I decided to install Nvidia proprietary drivers, but every kernel upgrade would require an additional effort to have the driver working. That was enough
2014 Jun 30
0
[PATCH 1/1] ia64: use ARRAY_SIZE instead of sizeof/sizeof[0]
Use macro definition Cc: Jeremy Fitzhardinge <jeremy at goop.org> Cc: Chris Wright <chrisw at sous-sol.org> Cc: virtualization at lists.linux-foundation.org Cc: linux-ia64 at vger.kernel.org Signed-off-by: Fabian Frederick <fabf at skynet.be> --- This is untested. arch/ia64/kernel/paravirt.c | 8 +++----- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git
2014 Jun 30
0
[PATCH 1/1] ia64: use ARRAY_SIZE instead of sizeof/sizeof[0]
Use macro definition Cc: Jeremy Fitzhardinge <jeremy at goop.org> Cc: Chris Wright <chrisw at sous-sol.org> Cc: virtualization at lists.linux-foundation.org Cc: linux-ia64 at vger.kernel.org Signed-off-by: Fabian Frederick <fabf at skynet.be> --- This is untested. arch/ia64/kernel/paravirt.c | 8 +++----- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git
2017 Oct 02
0
[PATCH 00/18] use ARRAY_SIZE macro
On Mon, 2 Oct 2017 09:01:31 +1100 "Tobin C. Harding" <me at tobin.cc> wrote: > > In order to reduce the size of the To: and Cc: lines, each patch of the > > series is sent only to the maintainers and lists concerned by the patch. > > This cover letter is sent to every list concerned by this series. > > Why don't you just send individual patches for
2023 Jun 25
0
[PATCH 08/26] virtio-mem: use array_size
On Fri, 23 Jun 2023 23:14:39 +0200, Julia Lawall <Julia.Lawall at inria.fr> wrote: > Use array_size to protect against multiplication overflows. > > The changes were done using the following Coccinelle semantic patch: > > // <smpl> > @@ > expression E1, E2; > constant C1, C2; > identifier alloc = {vmalloc,vzalloc}; > @@ > > ( >