similar to: [PATCH] nouveau: Switch perms from macros to octal notations, module params readable to everyone

Displaying 20 results from an estimated 3000 matches similar to: "[PATCH] nouveau: Switch perms from macros to octal notations, module params readable to everyone"

2017 Apr 26
0
[PATCH v5 3/5] nouveau_hwmon: Remove old code, add .write/.read operations
This patch removes old code related to the old api and transforms the functions for the new api. It also adds the .write and .read operations. Signed-off-by: Oscar Salvador <osalvador.vilardaga at gmail.com> --- drivers/gpu/drm/nouveau/nouveau_hwmon.c | 722 +++++++++++--------------------- 1 file changed, 249 insertions(+), 473 deletions(-) diff --git
2017 Apr 13
0
[PATCH 2/4] nouveau_hwmon: migrate to hwmon_device_register_with_info
Here is where most of the work is being done. We are replacing the old API with the new one, that means changing the functions layout and remove unnecessary code. We also set up the other operations: .read .write .read_string --- linux/drivers/gpu/drm/nouveau/nouveau_hwmon.c.orig 2017-04-13 10:11:29.241000086 +0200 +++ linux/drivers/gpu/drm/nouveau/nouveau_hwmon.c 2017-04-13 10:12:38.016055129
2017 Apr 12
0
[PATCH 1/1] nouveau_hwmon: migrate to hwmon_device_register_with_info
Sorry for that. I'll split the patch and I'll come again ;) El dia 11/04/2017 22:12, "Karol Herbst" <karolherbst at gmail.com> va escriure: thanks for the work, but could you please split that patch? It looks like you are doing several things at once and it isn't really easy to review like this. And it isn't bisectable. If there are clean ups here, please do it
2016 Apr 10
1
[PATCH] module parameters: permissions as defines, readable to everyone
For the purposes of the module parameters, specifies the permissions of the corresponding files in sysfs in predefined S_I* form rather than in octal notation. Withal it makes the source code more consistent. Moreover, because all parameters are readable to everyone, it is more user-friendly. $ grep S_IRUGO include/linux/stat.h #define S_IRUGO (S_IRUSR|S_IRGRP|S_IROTH) $ grep
2017 Apr 11
2
[PATCH 1/1] nouveau_hwmon: migrate to hwmon_device_register_with_info
Hi, this patch replaces the old hwmon_device_register with the new hwmon_device_register_with_info. I've tested it on my laptop with a GeForceGT 425M and it doesn't break anything. --- linux/drivers/gpu/drm/nouveau/nouveau_hwmon.c.orig 2017-04-11 18:27:15.477623009 +0200 +++ linux/drivers/gpu/drm/nouveau/nouveau_hwmon.c 2017-04-11 18:45:41.918688215 +0200 @@ -1,5 +1,6 @@ /* - *
2018 May 25
0
[PATCH] gpu: Consistently use octal not symbolic permissions
Well I think we rejected that multiple times now. At least I find the symbolic permissions easier to read and I absolutely don't see any reason why we should only use one form. Christian. Am 24.05.2018 um 22:22 schrieb Joe Perches: > There is currently a mixture of octal and symbolic permissions uses > in files in drivers/gpu/drm and one file in drivers/gpu. > > There are ~270
2018 May 23
3
[PATCH] block drivers/block: Use octal not symbolic permissions
Convert the S_<FOO> symbolic permissions to their octal equivalents as using octal and not symbolic permissions is preferred by many as more readable. see: https://lkml.org/lkml/2016/8/2/1945 Done with automated conversion via: $ ./scripts/checkpatch.pl -f --types=SYMBOLIC_PERMS --fix-inplace <files...> Miscellanea: o Wrapped modified multi-line calls to a single line where
2018 May 23
3
[PATCH] block drivers/block: Use octal not symbolic permissions
Convert the S_<FOO> symbolic permissions to their octal equivalents as using octal and not symbolic permissions is preferred by many as more readable. see: https://lkml.org/lkml/2016/8/2/1945 Done with automated conversion via: $ ./scripts/checkpatch.pl -f --types=SYMBOLIC_PERMS --fix-inplace <files...> Miscellanea: o Wrapped modified multi-line calls to a single line where
2018 May 24
3
[PATCH] gpu: Consistently use octal not symbolic permissions
There is currently a mixture of octal and symbolic permissions uses in files in drivers/gpu/drm and one file in drivers/gpu. There are ~270 existing octal uses and ~115 S_<FOO> uses. Convert all the S_<FOO> symbolic permissions to their octal equivalents as using octal and not symbolic permissions is preferred by many as more readable. see: https://lkml.org/lkml/2016/8/2/1945 Done
2017 Apr 26
0
[PATCH v5 5/5] nouveau_hwmon: Change permissions to numeric
This patch replaces the symbolic permissions with the numeric ones, and adds me to the authors too. Signed-off-by: Oscar Salvador <osalvador.vilardaga at gmail.com> --- drivers/gpu/drm/nouveau/nouveau_hwmon.c | 14 +++++++------- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/drivers/gpu/drm/nouveau/nouveau_hwmon.c b/drivers/gpu/drm/nouveau/nouveau_hwmon.c index
2017 May 02
1
[PATCH v5 5/5] nouveau_hwmon: Change permissions to numeric
On 26/04/17 19:46, Oscar Salvador wrote: > This patch replaces the symbolic permissions with the numeric ones, > and adds me to the authors too. > > Signed-off-by: Oscar Salvador <osalvador.vilardaga at gmail.com> > --- > drivers/gpu/drm/nouveau/nouveau_hwmon.c | 14 +++++++------- > 1 file changed, 7 insertions(+), 7 deletions(-) > > diff --git
2017 Apr 13
0
[PATCH 4/4] nouveau_hwmon: migrate to hwmon_device_register_with_info
This patch replaces symbolic permissions with the numeric ones and adds me to the authors too. --- linux/drivers/gpu/drm/nouveau/nouveau_hwmon.c.orig 2017-04-13 10:18:37.471129756 +0200 +++ linux/drivers/gpu/drm/nouveau/nouveau_hwmon.c 2017-04-13 10:19:58.182025638 +0200 @@ -1,5 +1,6 @@ /* - * Copyright 2010 Red Hat Inc. + * Copyright 2010 Red Hat Inc. (Ben Skeggs) + * Copyright 2017 Oscar
2014 Aug 18
0
[PATCH] drm: Display Nouveau boot options at launch
It can help to remove any ambiguity about which options were passed to Nouveau, especially in case the user had some options set in /etc/modprobe.d/*.conf that he forgot about, as they won't appear in a dmesg. Signed-off-by: Pierre Moreau <pierre.morrow at free.fr> --- drm/nouveau_chan.c | 2 +- drm/nouveau_chan.h | 2 ++ drm/nouveau_connector.c | 6 +++---
2016 Oct 24
0
[PATCH 3/3] hwmon: expose power_max and power_crit
Signed-off-by: Karol Herbst <karolherbst at gmail.com> --- drm/nouveau/nouveau_hwmon.c | 44 ++++++++++++++++++++++++++++++++++++++++++++ 1 file changed, 44 insertions(+) diff --git a/drm/nouveau/nouveau_hwmon.c b/drm/nouveau/nouveau_hwmon.c index 71f764b..3d4672a 100644 --- a/drm/nouveau/nouveau_hwmon.c +++ b/drm/nouveau/nouveau_hwmon.c @@ -596,6 +596,32 @@
2016 Aug 17
0
[PATCH 09/15] virtio-blk: Pass attribute group to device_add_disk
Previously after device_add_disk returns, the KOBJ_ADD uevent is already emitted. Adding attributes after that is a poor usage of kobject, and in practice may result in race conditions with userspace, for example udev checks availability of certain attributes and initializes /dev entries conditionally. device_add_disk can handle adding attribute group better, so use it. Meanwhile, handle error
2016 Oct 25
1
[PATCH 3/3] hwmon: expose power_max and power_crit
On 25/10/16 00:11, Karol Herbst wrote: > Signed-off-by: Karol Herbst <karolherbst at gmail.com> > --- > drm/nouveau/nouveau_hwmon.c | 44 ++++++++++++++++++++++++++++++++++++++++++++ > 1 file changed, 44 insertions(+) > > diff --git a/drm/nouveau/nouveau_hwmon.c b/drm/nouveau/nouveau_hwmon.c > index 71f764b..3d4672a 100644 > --- a/drm/nouveau/nouveau_hwmon.c > +++
2016 Aug 02
0
[PATCH 0205/1285] Replace numeric parameter like 0444 with macro
I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng
2016 Feb 20
0
[PATCH v4 4/6] hwmon: add power consumption
Signed-off-by: Karol Herbst <nouveau at karolherbst.de> --- drm/nouveau/include/nvif/device.h | 1 + drm/nouveau/nouveau_hwmon.c | 39 +++++++++++++++++++++++++++++++++++++++ 2 files changed, 40 insertions(+) diff --git a/drm/nouveau/include/nvif/device.h b/drm/nouveau/include/nvif/device.h index e0ed2f4..bcb9817 100644 --- a/drm/nouveau/include/nvif/device.h +++
2016 Aug 02
0
[PATCH 0203/1285] Replace numeric parameter like 0444 with macro
I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng
2020 Oct 06
0
[RFC PATCH v2 2/3] nouveau: Add kernel-docs for module parameters
In preparation for the nouveau kernel documentation page, add some documentation for the supported module parameters. It would be ideal if the value given to MODULE_PARM_DESC could be referenced in Sphinx to auto-document these parameters for both readers of the kernel's Sphinx project and users of modinfo, but that appears to require a bit of work so for now this approach will do.