Displaying 13 results from an estimated 13 matches for "volume_size".
2015 Oct 22
1
[PATCH] Bugfix in number parsing in vfs_min_size.
..._with_error ("cannot parse minimum size");
return -1;
}
diff --git a/daemon/ntfs.c b/daemon/ntfs.c
index ea0844f..8e1aa5a 100644
--- a/daemon/ntfs.c
+++ b/daemon/ntfs.c
@@ -201,7 +201,7 @@ ntfs_minimum_size (const char *device)
}
else if (STRPREFIX (lines[i], volume_size_pattern)) {
if (XSTRTOD64 (lines[i] + strlen (volume_size_pattern),
- NULL, 20, &volume_size, NULL) != LONGINT_OK) {
+ NULL, 10, &volume_size, NULL) != LONGINT_OK) {
reply_with_error ("cannot parse volume size");...
2015 Oct 19
5
Re: [PATCH 1/2] New API: vfs_min_size
...t; return do_ntfsresize (device, size, 0);
> }
>
> +int64_t
> +ntfs_min_size (const char *device)
> +{
> + CLEANUP_FREE char *err = NULL, *out = NULL;
> + CLEANUP_FREE_STRING_LIST char **lines = NULL;
> + int r;
> + size_t i;
> + char *p;
> + int64_t ret, volume_size = 0;
The scope of "ret" could be reduced to only the if below where it is
used.
> + const char *size_pattern = "You might resize at ",
> + *full_pattern = "Volume is full",
> + *cluster_size_pattern = "Cluster size",
> +...
2015 Oct 16
2
[PATCH] New API: ntfsresize_info
...o_ntfsresize_size (const char *device, int64_t size)
return do_ntfsresize (device, size, 0);
}
+int64_t
+do_ntfsresize_info (const char *device)
+{
+ CLEANUP_FREE char *err = NULL, *out = NULL;
+ CLEANUP_FREE_STRING_LIST char **lines = NULL;
+ int r;
+ size_t i;
+ char *p;
+ int64_t ret, volume_size = 0;
+ const char *size_pattern = "You might resize at ",
+ *full_pattern = "Volume is full",
+ *cluster_size_pattern = "Cluster size",
+ *volume_size_pattern = "Current volume size:";
+ int is_full = 0;
+ int32_t cluste...
2015 Oct 16
0
[PATCH 1/2] New API: get_min_size
...do_ntfsresize_size (const char *device, int64_t size)
return do_ntfsresize (device, size, 0);
}
+int64_t
+ntfs_get_min_size (const char *device)
+{
+ CLEANUP_FREE char *err = NULL, *out = NULL;
+ CLEANUP_FREE_STRING_LIST char **lines = NULL;
+ int r;
+ size_t i;
+ char *p;
+ int64_t ret, volume_size = 0;
+ const char *size_pattern = "You might resize at ",
+ *full_pattern = "Volume is full",
+ *cluster_size_pattern = "Cluster size",
+ *volume_size_pattern = "Current volume size:";
+ int is_full = 0;
+ int32_t cluste...
2015 Oct 19
0
[PATCH 1/2] New API: vfs_min_size
...@@ do_ntfsresize_size (const char *device, int64_t size)
return do_ntfsresize (device, size, 0);
}
+int64_t
+ntfs_min_size (const char *device)
+{
+ CLEANUP_FREE char *err = NULL, *out = NULL;
+ CLEANUP_FREE_STRING_LIST char **lines = NULL;
+ int r;
+ size_t i;
+ char *p;
+ int64_t ret, volume_size = 0;
+ const char *size_pattern = "You might resize at ",
+ *full_pattern = "Volume is full",
+ *cluster_size_pattern = "Cluster size",
+ *volume_size_pattern = "Current volume size:";
+ int is_full = 0;
+ int32_t cluste...
2015 Oct 20
0
[PATCHv3 1/2] New API: vfs_min_size
...153,6 +154,92 @@ do_ntfsresize_size (const char *device, int64_t size)
return do_ntfsresize (device, size, 0);
}
+int64_t
+ntfs_minimum_size (const char *device)
+{
+ CLEANUP_FREE char *err = NULL, *out = NULL;
+ CLEANUP_FREE_STRING_LIST char **lines = NULL;
+ int r;
+ size_t i;
+ int64_t volume_size = 0;
+ const char *size_pattern = "You might resize at ",
+ *full_pattern = "Volume is full",
+ *cluster_size_pattern = "Cluster size",
+ *volume_size_pattern = "Current volume size:";
+ int is_full = 0;
+ int32_t cluste...
2015 Oct 20
0
[PATCHv4 1/2] New API: vfs_minimum_size
...153,6 +154,92 @@ do_ntfsresize_size (const char *device, int64_t size)
return do_ntfsresize (device, size, 0);
}
+int64_t
+ntfs_minimum_size (const char *device)
+{
+ CLEANUP_FREE char *err = NULL, *out = NULL;
+ CLEANUP_FREE_STRING_LIST char **lines = NULL;
+ int r;
+ size_t i;
+ int64_t volume_size = 0;
+ const char *size_pattern = "You might resize at ",
+ *full_pattern = "Volume is full",
+ *cluster_size_pattern = "Cluster size",
+ *volume_size_pattern = "Current volume size:";
+ int is_full = 0;
+ int32_t cluste...
2015 Oct 19
5
[PATCHv2 0/2] Introduce vfs_min_size API to get minimum filesystem size.
Tried to make it in accordance with your comments.
Difference to v1:
Added reply_with_error where necessary.
Changed name get_min_size -> vfs_min_size.
Maxim Perevedentsev (2):
New API: vfs_min_size
Include resize2fs_P into vfs_min_size.
daemon/Makefile.am | 1 +
daemon/daemon.h | 2 ++
daemon/ext2.c | 45 ++++++++++++++++++++++++++-----
daemon/fs-min-size.c | 49
2015 Oct 20
4
[PATCHv3 0/2] Introduce vfs_min_size API to get minimum filesystem size.
Tried to make it in accordance with your comments.
Difference to v1:
Added reply_with_error where necessary.
Changed name get_min_size -> vfs_min_size.
Difference to v2:
Changed name to vfs_minimum_size.
Changed parsing to xstrtol + STR* macros where possible.
Maxim Perevedentsev (2):
New API: vfs_min_size
Include resize2fs_P into vfs_min_size.
daemon/Makefile.am | 1 +
2015 Oct 16
4
[PATCH 0/2] Introduce get_min_size API to get minimum filesystem size.
Tried to make it in accordance with your comments.
Maybe you can suggest a better name for API?
Maxim Perevedentsev (2):
New API: get_min_size
Include resize2fs_P into get_min_size.
daemon/Makefile.am | 1 +
daemon/daemon.h | 2 ++
daemon/ext2.c | 37 ++++++++++++++++++++++++----
daemon/fs-min-size.c | 49 +++++++++++++++++++++++++++++++++++++
daemon/ntfs.c | 68
2015 Oct 20
8
[PATCHv4 0/2] Introduce vfs_minimum_size API to get minimum filesystem size.
Tried to make it in accordance with your comments.
Difference to v1:
Added reply_with_error where necessary.
Changed name get_min_size -> vfs_min_size.
Difference to v2:
Changed name to vfs_minimum_size.
Changed parsing to xstrtol + STR* macros where possible.
Difference to v3:
Decapitalize error messages.
Maxim Perevedentsev (2):
New API: vfs_minimum_size
Include resize2fs_P into
2015 Oct 20
0
Re: [PATCH 1/2] New API: vfs_min_size
...im Perevedentsev wrote:
>> +int64_t
>> +ntfs_min_size (const char *device)
>> +{
>> + CLEANUP_FREE char *err = NULL, *out = NULL;
>> + CLEANUP_FREE_STRING_LIST char **lines = NULL;
>> + int r;
>> + size_t i;
>> + char *p;
>> + int64_t ret, volume_size = 0;
> The scope of "ret" could be reduced to only the if below where it is
> used.
Looking through code, I decided that declaring variables in the
beginning of function is part of code style, so I followed it. Should I
also move volume/cluster size declarations to branch where th...
2015 Oct 20
0
Re: [PATCH 1/2] New API: vfs_min_size
...onday 19 October 2015 17:05:02 Maxim Perevedentsev wrote:
>
>> + const char *size_pattern = "You might resize at ",
>> + *full_pattern = "Volume is full",
>> + *cluster_size_pattern = "Cluster size",
>> + *volume_size_pattern = "Current volume size:";
>> + int is_full = 0;
>> + int32_t cluster_size = 0;
>> +
>> + /* FS may be marked for check, so force ntfsresize */
>> + r = command (&out, &err, str_ntfsresize, "--info", "-ff", device, NULL)...