Displaying 8 results from an estimated 8 matches for "vhost_enable_user_be".
2016 Feb 10
3
[PATCH 1/2] vhost: helpers to enable/disable vring endianness
..._disable_user_be(struct vhost_virtqueue *vq)
> {
> vq->user_be = !virtio_legacy_is_little_endian();
> }
>
Hmm this doesn't look like an improvement to me.
What does it mean to disable big endian? Make it little endian?
Existing reset seems to make sense.
> +static void vhost_enable_user_be(struct vhost_virtqueue *vq, bool user_be)
> +{
> + vq->user_be = user_be;
> +}
> +
And this is maybe "init_user_be"?
> static long vhost_set_vring_endian(struct vhost_virtqueue *vq, int __user *argp)
> {
> struct vhost_vring_state s;
> @@ -62,7 +67,7 @@ st...
2016 Feb 10
3
[PATCH 1/2] vhost: helpers to enable/disable vring endianness
..._disable_user_be(struct vhost_virtqueue *vq)
> {
> vq->user_be = !virtio_legacy_is_little_endian();
> }
>
Hmm this doesn't look like an improvement to me.
What does it mean to disable big endian? Make it little endian?
Existing reset seems to make sense.
> +static void vhost_enable_user_be(struct vhost_virtqueue *vq, bool user_be)
> +{
> + vq->user_be = user_be;
> +}
> +
And this is maybe "init_user_be"?
> static long vhost_set_vring_endian(struct vhost_virtqueue *vq, int __user *argp)
> {
> struct vhost_vring_state s;
> @@ -62,7 +67,7 @@ st...
2016 Feb 10
1
[PATCH 1/2] vhost: helpers to enable/disable vring endianness
...le" cross-endian mode on reset.
OK but that's enable cross-endian. Not enable be. We could have
something like vhost_disable_user_byte_swap though each time we try,
the result makes my head hurt: "swap" is a relative thing and hard to
keep track of.
> > > +static void vhost_enable_user_be(struct vhost_virtqueue *vq, bool user_be)
> > > +{
> > > + vq->user_be = user_be;
> > > +}
> > > +
> >
> > And this is maybe "init_user_be"?
> >
>
> Anyway I don't mind changing the names to reset/init_user_be if you...
2016 Feb 10
1
[PATCH 1/2] vhost: helpers to enable/disable vring endianness
...le" cross-endian mode on reset.
OK but that's enable cross-endian. Not enable be. We could have
something like vhost_disable_user_byte_swap though each time we try,
the result makes my head hurt: "swap" is a relative thing and hard to
keep track of.
> > > +static void vhost_enable_user_be(struct vhost_virtqueue *vq, bool user_be)
> > > +{
> > > + vq->user_be = user_be;
> > > +}
> > > +
> >
> > And this is maybe "init_user_be"?
> >
>
> Anyway I don't mind changing the names to reset/init_user_be if you...
2016 Jan 13
0
[PATCH 1/2] vhost: helpers to enable/disable vring endianness
...rtio16 __user *)&vq->used->ring[vq->num])
#ifdef CONFIG_VHOST_CROSS_ENDIAN_LEGACY
-static void vhost_vq_reset_user_be(struct vhost_virtqueue *vq)
+static void vhost_disable_user_be(struct vhost_virtqueue *vq)
{
vq->user_be = !virtio_legacy_is_little_endian();
}
+static void vhost_enable_user_be(struct vhost_virtqueue *vq, bool user_be)
+{
+ vq->user_be = user_be;
+}
+
static long vhost_set_vring_endian(struct vhost_virtqueue *vq, int __user *argp)
{
struct vhost_vring_state s;
@@ -62,7 +67,7 @@ static long vhost_set_vring_endian(struct vhost_virtqueue *vq, int __user *argp)
s...
2016 Feb 10
0
[PATCH 1/2] vhost: helpers to enable/disable vring endianness
...the device is native endian.
The SET_VRING_ENDIAN ioctl is used to make the device big endian
on little endian hosts, hence "enabling" cross-endian mode...
> Existing reset seems to make sense.
>
... and we "disable" cross-endian mode on reset.
> > +static void vhost_enable_user_be(struct vhost_virtqueue *vq, bool user_be)
> > +{
> > + vq->user_be = user_be;
> > +}
> > +
>
> And this is maybe "init_user_be"?
>
Anyway I don't mind changing the names to reset/init_user_be if you think it
is clearer.
> > static long...
2016 Jan 13
7
[PATCH 0/2] vhost: cross-endian code cleanup
This series is a respin of the following patch:
http://patchwork.ozlabs.org/patch/565921/
Patch 1 is preliminary work: it gives better names to the helpers that are
involved in cross-endian support.
Patch 2 is actually a v2 of the original patch. All devices now call a
helper in the generic code, which DTRT according to vq->private_data, as
suggested by Michael.
---
Greg Kurz (2):
2016 Jan 13
7
[PATCH 0/2] vhost: cross-endian code cleanup
This series is a respin of the following patch:
http://patchwork.ozlabs.org/patch/565921/
Patch 1 is preliminary work: it gives better names to the helpers that are
involved in cross-endian support.
Patch 2 is actually a v2 of the original patch. All devices now call a
helper in the generic code, which DTRT according to vq->private_data, as
suggested by Michael.
---
Greg Kurz (2):