search for: velemtype

Displaying 5 results from an estimated 5 matches for "velemtype".

2011 Dec 02
5
[LLVMdev] [llvm-commits] [PATCH] BasicBlock Autovectorization Pass
...s>(); > + AU.addPreserved<ScalarEvolution>(); > + } > + > + // This returns the vector type that holds a pair of the provided type. > + // If the provided type is already a vector, then its length is doubled. > + static inline VectorType *getVecType(Type *VElemType) { What about naming this getVecTypeForPair()? I think ElemType is sufficient. No need for the 'V'. > + if (VElemType->isVectorTy()) { > + unsigned numElem = cast<VectorType>(VElemType)->getNumElements(); > + return VectorType::get(VElemType->ge...
2011 Dec 14
0
[LLVMdev] [llvm-commits] [PATCH] BasicBlock Autovectorization Pass
...ddPreserved<ScalarEvolution>(); > > + } > > + > > + // This returns the vector type that holds a pair of the provided type. > > + // If the provided type is already a vector, then its length is doubled. > > + static inline VectorType *getVecType(Type *VElemType) { > > What about naming this getVecTypeForPair()? > > I think ElemType is sufficient. No need for the 'V'. > > > + if (VElemType->isVectorTy()) { > > + unsigned numElem = cast<VectorType>(VElemType)->getNumElements(); > > +...
2011 Nov 23
0
[LLVMdev] [llvm-commits] [PATCH] BasicBlock Autovectorization Pass
On Mon, 2011-11-21 at 21:22 -0600, Hal Finkel wrote: > On Mon, 2011-11-21 at 11:55 -0600, Hal Finkel wrote: > > Tobias, > > > > I've attached an updated patch. It contains a few bug fixes and many > > (refactoring and coding-convention) changes inspired by your comments. > > > > I'm currently trying to fix the bug responsible for causing a compile
2011 Dec 02
0
[LLVMdev] [llvm-commits] [PATCH] BasicBlock Autovectorization Pass
...ddPreserved<ScalarEvolution>(); > > + } > > + > > + // This returns the vector type that holds a pair of the provided type. > > + // If the provided type is already a vector, then its length is doubled. > > + static inline VectorType *getVecType(Type *VElemType) { > > What about naming this getVecTypeForPair()? > > I think ElemType is sufficient. No need for the 'V'. > > > + if (VElemType->isVectorTy()) { > > + unsigned numElem = cast<VectorType>(VElemType)->getNumElements(); > > +...
2011 Nov 22
5
[LLVMdev] [llvm-commits] [PATCH] BasicBlock Autovectorization Pass
On Mon, 2011-11-21 at 11:55 -0600, Hal Finkel wrote: > Tobias, > > I've attached an updated patch. It contains a few bug fixes and many > (refactoring and coding-convention) changes inspired by your comments. > > I'm currently trying to fix the bug responsible for causing a compile > failure when compiling >