search for: valid_flag_alpha

Displaying 6 results from an estimated 6 matches for "valid_flag_alpha".

2018 Aug 22
1
[PATCH] lib: create: avoid one extra string allocation
...nge. --- lib/create.c | 25 +++++++++++-------------- 1 file changed, 11 insertions(+), 14 deletions(-) diff --git a/lib/create.c b/lib/create.c index 60e467fb6..fcc5855e0 100644 --- a/lib/create.c +++ b/lib/create.c @@ -250,11 +250,10 @@ is_power_of_2 (unsigned v) VALID_FLAG_ALPHA|VALID_FLAG_DIGIT, "") static int -disk_create_qcow2 (guestfs_h *g, const char *orig_filename, int64_t size, +disk_create_qcow2 (guestfs_h *g, const char *filename, int64_t size, const char *backingfile, const struct guestfs_disk_create_argv *opta...
2017 May 17
7
[PATCH 1/5] s390x: launch: libvirt: Use <console> device sclp for appliance debug messages (RHBZ#1376547).
Thanks: Cole Robinson, Dan Horak, Thomas Huth. --- lib/launch-libvirt.c | 17 +++++++++++++++++ 1 file changed, 17 insertions(+) diff --git a/lib/launch-libvirt.c b/lib/launch-libvirt.c index f66c8e0ef..4adb2cfb3 100644 --- a/lib/launch-libvirt.c +++ b/lib/launch-libvirt.c @@ -1359,6 +1359,7 @@ construct_libvirt_xml_devices (guestfs_h *g, return -1; } +#ifndef __s390x__ /*
2017 May 17
0
[PATCH 3/5] s390x: appliance: Use /dev/ttysclp0 for serial console.
...ed, 11 insertions(+), 3 deletions(-) diff --git a/lib/appliance-kcmdline.c b/lib/appliance-kcmdline.c index 4dde7a865..a394e6e67 100644 --- a/lib/appliance-kcmdline.c +++ b/lib/appliance-kcmdline.c @@ -40,11 +40,19 @@ guestfs_int_string_is_valid ((term), 1, 16, \ VALID_FLAG_ALPHA|VALID_FLAG_DIGIT, "-_") -#if defined(__powerpc64__) +#ifdef __powerpc64__ #define SERIAL_CONSOLE "console=hvc0 console=ttyS0" -#elif defined(__arm__) || defined(__aarch64__) +#endif + +#if defined(__arm__) || defined(__aarch64__) #define SERIAL_CONSOLE "console=ttyAMA0&...
2017 Jun 08
1
[PATCH] lib: create: Allow any [[:alnum:]]+ string as a backingfmt parameter.
...mp;& ((v & (v - 1)) == 0); } +/** + * Check for valid backing format. Allow any C<^[[:alnum]]+$> + * (in C locale), but limit the length to something reasonable. + */ +#define VALID_FORMAT(format) \ + guestfs_int_string_is_valid ((format), 1, 16, \ + VALID_FLAG_ALPHA|VALID_FLAG_DIGIT, "") + static int disk_create_qcow2 (guestfs_h *g, const char *orig_filename, int64_t size, const char *backingfile, @@ -267,12 +275,7 @@ disk_create_qcow2 (guestfs_h *g, const char *orig_filename, int64_t size, if (optargs->bitmask & GUE...
2017 Jan 20
5
[PATCH 0/5] Rename src/ to lib/ and move common code to common/
This patch series moves some files and directories around but is only code motion (or supposed to be). A new directory, common/, is created for all of the common code which is currently shared in random ways between parts of the project. And src/ becomes lib/ (the largest change, but mostly mechanical). In full this series makes the following changes: src/libprotocol -> common/protocol
2017 Jan 25
10
[PATCH v2 0/7] Rename src/ to lib/ and move common code to common/
Previous patch series was posted here: https://www.redhat.com/archives/libguestfs/2017-January/msg00059.html v2 simply extends this patch series to cover the extra directories common/edit, common/progress, common/windows and common/parallel. The only remaining item is to consider whether we should rename mllib to something else, mlcommon was my suggestion. Rich.