search for: test_feature_bit

Displaying 4 results from an estimated 4 matches for "test_feature_bit".

Did you mean: set_feature_bit
2014 Nov 27
1
[PATCH v5 01/45] virtio: use u32, not bitmap for struct virtio_device's features
...do (a|b|c) to get a set with 3 bits. > > if names collide with existing functions, we could simply rename them to: > > set_feature_bit() ... > clear_feature_bit() ... In fact that's why we have BIT macro. vdev->features & BIT_ULL(x) is only longer by 1 character than test_feature_bit(vdev, x), and it's much clearer than a non standard wrapper. vdev->features & (1ULL << x) is longer by 3 chars. I guess this is a suggestion to use BIT / BIT_ULL more. Good point. > > diff --git a/drivers/misc/mic/card/mic_virtio.c b/drivers/misc/mic/card/mic_virtio.c &g...
2014 Nov 27
1
[PATCH v5 01/45] virtio: use u32, not bitmap for struct virtio_device's features
...do (a|b|c) to get a set with 3 bits. > > if names collide with existing functions, we could simply rename them to: > > set_feature_bit() ... > clear_feature_bit() ... In fact that's why we have BIT macro. vdev->features & BIT_ULL(x) is only longer by 1 character than test_feature_bit(vdev, x), and it's much clearer than a non standard wrapper. vdev->features & (1ULL << x) is longer by 3 chars. I guess this is a suggestion to use BIT / BIT_ULL more. Good point. > > diff --git a/drivers/misc/mic/card/mic_virtio.c b/drivers/misc/mic/card/mic_virtio.c &g...
2014 Nov 27
2
[PATCH v5 01/45] virtio: use u32, not bitmap for struct virtio_device's features
From: Rusty Russell <rusty at rustcorp.com.au> It seemed like a good idea, but it's actually a pain when we get more than 32 feature bits. Just change it to a u32 for now. Cc: Brian Swetland <swetland at google.com> Cc: Christian Borntraeger <borntraeger at de.ibm.com> Signed-off-by: Rusty Russell <rusty at rustcorp.com.au> Signed-off-by: Cornelia Huck
2014 Nov 27
2
[PATCH v5 01/45] virtio: use u32, not bitmap for struct virtio_device's features
From: Rusty Russell <rusty at rustcorp.com.au> It seemed like a good idea, but it's actually a pain when we get more than 32 feature bits. Just change it to a u32 for now. Cc: Brian Swetland <swetland at google.com> Cc: Christian Borntraeger <borntraeger at de.ibm.com> Signed-off-by: Rusty Russell <rusty at rustcorp.com.au> Signed-off-by: Cornelia Huck