Displaying 5 results from an estimated 5 matches for "test_error_messages_cflags".
Did you mean:
test_error_messages_cppflags
2016 Mar 22
1
[PATCH] Reduce GUESTFS_PRIVATE usage
...sts/protocol/Makefile.am
@@ -43,7 +43,6 @@ check_PROGRAMS = test-error-messages
test_error_messages_SOURCES = \
test-error-messages.c
test_error_messages_CPPFLAGS = \
- -DGUESTFS_PRIVATE=1 \
-I$(top_srcdir)/gnulib/lib -I$(top_builddir)/gnulib/lib \
-I$(top_srcdir)/src -I$(top_builddir)/src
test_error_messages_CFLAGS = \
diff --git a/tests/qemu/Makefile.am b/tests/qemu/Makefile.am
index 091361f..fe45d88 100644
--- a/tests/qemu/Makefile.am
+++ b/tests/qemu/Makefile.am
@@ -43,7 +43,6 @@ qemu_boot_SOURCES = \
../../df/estimate-max-threads.h \
qemu-boot.c
qemu_boot_CPPFLAGS = \
- -DGUESTFS_PRIVATE=1 \
-I$(to...
2017 Jan 25
0
[PATCH v2 1/7] lib: Share common protocol and errnostring libraries with the library and daemon.
...l/guestfs_protocol.h \
test-error-messages.c
test_error_messages_CPPFLAGS = \
-I$(top_srcdir)/gnulib/lib -I$(top_builddir)/gnulib/lib \
- -I$(top_srcdir)/src -I$(top_builddir)/src
+ -I$(top_srcdir)/src -I$(top_builddir)/src \
+ -I$(top_srcdir)/common/protocol -I$(top_builddir)/common/protocol
test_error_messages_CFLAGS = \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
test_error_messages_LDADD = \
--
2.9.3
2017 Jan 25
0
[PATCH v2 2/7] lib: Move utilities to new directory common/utils.
.../lib \
- -I$(top_srcdir)/src -I$(top_builddir)/src \
- -I$(top_srcdir)/common/protocol -I$(top_builddir)/common/protocol
+ -I$(top_srcdir)/common/utils -I$(top_builddir)/common/utils \
+ -I$(top_srcdir)/common/protocol -I$(top_builddir)/common/protocol \
+ -I$(top_srcdir)/src -I$(top_builddir)/src
test_error_messages_CFLAGS = \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
test_error_messages_LDADD = \
- $(top_builddir)/src/libutils.la \
+ $(top_builddir)/common/utils/libutils.la \
$(top_builddir)/src/libguestfs.la \
$(LIBXML2_LIBS) \
$(LIBVIRT_LIBS) \
diff --git a/tests/regressions/Makefile.am b/tests/regressions/Makefile...
2017 Jan 20
5
[PATCH 0/5] Rename src/ to lib/ and move common code to common/
This patch series moves some files and directories around but is only
code motion (or supposed to be).
A new directory, common/, is created for all of the common code which
is currently shared in random ways between parts of the project.
And src/ becomes lib/ (the largest change, but mostly mechanical).
In full this series makes the following changes:
src/libprotocol -> common/protocol
2017 Jan 25
10
[PATCH v2 0/7] Rename src/ to lib/ and move common code to common/
Previous patch series was posted here:
https://www.redhat.com/archives/libguestfs/2017-January/msg00059.html
v2 simply extends this patch series to cover the extra directories
common/edit, common/progress, common/windows and common/parallel.
The only remaining item is to consider whether we should rename mllib
to something else, mlcommon was my suggestion.
Rich.