Displaying 10 results from an estimated 10 matches for "test_big_heap_sources".
2016 Mar 22
1
[PATCH] Reduce GUESTFS_PRIVATE usage
...DD = \
rhbz1055452_SOURCES = rhbz1055452.c
rhbz1055452_CPPFLAGS = \
- -I$(top_srcdir)/src -I$(top_builddir)/src \
- -DGUESTFS_PRIVATE=1
+ -I$(top_srcdir)/src -I$(top_builddir)/src
rhbz1055452_CFLAGS = \
-pthread \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
@@ -140,8 +139,7 @@ rhbz1055452_LDADD = \
test_big_heap_SOURCES = test-big-heap.c
test_big_heap_CPPFLAGS = \
- -I$(top_srcdir)/src -I$(top_builddir)/src \
- -DGUESTFS_PRIVATE=1
+ -I$(top_srcdir)/src -I$(top_builddir)/src
test_big_heap_CFLAGS = \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
test_big_heap_LDADD = \
--
2.5.5
2015 Oct 14
0
[PATCH 2/2] lib: Add comment and regression test for case where main process has large heap.
...IRT
@@ -89,7 +90,8 @@ check_PROGRAMS = \
rhbz501893 \
rhbz790721 \
rhbz914931 \
- rhbz1055452
+ rhbz1055452 \
+ test-big-heap
rhbz501893_SOURCES = rhbz501893.c
rhbz501893_CPPFLAGS = \
@@ -130,5 +132,14 @@ rhbz1055452_CFLAGS = \
rhbz1055452_LDADD = \
$(top_builddir)/src/libguestfs.la
+test_big_heap_SOURCES = test-big-heap.c
+test_big_heap_CPPFLAGS = \
+ -I$(top_srcdir)/src -I$(top_builddir)/src \
+ -DGUESTFS_PRIVATE=1
+test_big_heap_CFLAGS = \
+ $(WARN_CFLAGS) $(WERROR_CFLAGS)
+test_big_heap_LDADD = \
+ $(top_builddir)/src/libguestfs.la
+
check-slow:
$(MAKE) TESTS="rhbz909624.sh" check
d...
2015 Oct 14
2
[PATCH 1/2] lib: info: Move common code for setting child rlimits.
This is almost just refactoring, but I also set the memory
limit to really 1 GB, and not 1×10⁹.
---
src/info.c | 27 +++++++++++++++------------
1 file changed, 15 insertions(+), 12 deletions(-)
diff --git a/src/info.c b/src/info.c
index d7f45f0..616ef50 100644
--- a/src/info.c
+++ b/src/info.c
@@ -56,6 +56,7 @@ static yajl_val get_json_output (guestfs_h *g, const char *filename);
static char
2017 Jan 25
0
[PATCH v2 2/7] lib: Move utilities to new directory common/utils.
..._CPPFLAGS = \
+ -I$(top_srcdir)/common/utils -I$(top_builddir)/common/utils \
-I$(top_srcdir)/src -I$(top_builddir)/src
rhbz1055452_CFLAGS = \
-pthread \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
rhbz1055452_LDADD = \
+ $(top_builddir)/common/utils/libutils.la \
$(top_builddir)/src/libguestfs.la
test_big_heap_SOURCES = test-big-heap.c
test_big_heap_CPPFLAGS = \
+ -I$(top_srcdir)/common/utils -I$(top_builddir)/common/utils \
-I$(top_srcdir)/src -I$(top_builddir)/src
test_big_heap_CFLAGS = \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
test_big_heap_LDADD = \
+ $(top_builddir)/common/utils/libutils.la \
$(top_builddi...
2017 Jun 15
0
[PATCH v6 05/41] utils: Split out cleanups into common/cleanups.
...(top_srcdir)/lib -I$(top_builddir)/lib
rhbz1055452_CFLAGS = \
@@ -149,16 +156,19 @@ rhbz1055452_CFLAGS = \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
rhbz1055452_LDADD = \
$(top_builddir)/common/utils/libutils.la \
+ $(top_builddir)/common/cleanups/libcleanups.la \
$(top_builddir)/lib/libguestfs.la
test_big_heap_SOURCES = test-big-heap.c
test_big_heap_CPPFLAGS = \
+ -I$(top_srcdir)/common/cleanups -I$(top_builddir)/common/cleanups \
-I$(top_srcdir)/common/utils -I$(top_builddir)/common/utils \
-I$(top_srcdir)/lib -I$(top_builddir)/lib
test_big_heap_CFLAGS = \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
test_big_heap_...
2017 Jan 20
5
[PATCH 0/5] Rename src/ to lib/ and move common code to common/
This patch series moves some files and directories around but is only
code motion (or supposed to be).
A new directory, common/, is created for all of the common code which
is currently shared in random ways between parts of the project.
And src/ becomes lib/ (the largest change, but mostly mechanical).
In full this series makes the following changes:
src/libprotocol -> common/protocol
2017 Jan 25
10
[PATCH v2 0/7] Rename src/ to lib/ and move common code to common/
Previous patch series was posted here:
https://www.redhat.com/archives/libguestfs/2017-January/msg00059.html
v2 simply extends this patch series to cover the extra directories
common/edit, common/progress, common/windows and common/parallel.
The only remaining item is to consider whether we should rename mllib
to something else, mlcommon was my suggestion.
Rich.
2017 Jun 09
12
[PATCH 00/12] Refactor utility functions.
This turned out to be rather more involved than I thought.
We have lots of utility functions, spread all over the repository,
with not a lot of structure. This moves many of them under common/
and structures them so there are clear dependencies.
This doesn't complete the job by any means. Other items I had on my
to-do list for this change were:
- Split up mllib/common_utils into:
-
2017 Jun 12
32
[PATCH v5 00/32] Refactor utilities, implement some APIs in OCaml.
This is a combination of:
https://www.redhat.com/archives/libguestfs/2017-June/msg00046.html
[PATCH 00/12] Refactor utility functions.
plus:
https://www.redhat.com/archives/libguestfs/2017-June/msg00023.html
[PATCH v3 00/19] Allow APIs to be implemented in OCaml.
with the second patches rebased on top of the utility refactoring, and
some other adjustments and extensions.
This passes
2017 Jun 15
45
[PATCH v6 00/41] Refactor utilities, reimplement inspection in the daemon.
v5:
https://www.redhat.com/archives/libguestfs/2017-June/msg00065.html
Since v5, this now implements inspection almost completely for Linux
and Windows guests.
Rich.