Displaying 6 results from an estimated 6 matches for "teamd_port_add".
2018 Feb 20
2
[RFC PATCH v3 0/3] Enable virtio_net to act as a backup for a passthru device
On Tue, 20 Feb 2018 21:14:10 +0100, Jiri Pirko wrote:
> Yeah, I can see it now :( I guess that the ship has sailed and we are
> stuck with this ugly thing forever...
>
> Could you at least make some common code that is shared in between
> netvsc and virtio_net so this is handled in exacly the same way in both?
IMHO netvsc is a vendor specific driver which made a mistake on what
2018 Feb 20
2
[RFC PATCH v3 0/3] Enable virtio_net to act as a backup for a passthru device
On Tue, 20 Feb 2018 21:14:10 +0100, Jiri Pirko wrote:
> Yeah, I can see it now :( I guess that the ship has sailed and we are
> stuck with this ugly thing forever...
>
> Could you at least make some common code that is shared in between
> netvsc and virtio_net so this is handled in exacly the same way in both?
IMHO netvsc is a vendor specific driver which made a mistake on what
2018 Feb 21
0
[RFC PATCH v3 0/3] Enable virtio_net to act as a backup for a passthru device
...+ int err;
+ bool kidnap;
+
+ err = teamd_config_bool_get(ctx, &kidnap, "$.kidnap");
+ if (err || !kidnap ||
+ ctx->hwaddr_len != team_get_ifinfo_hwaddr_len(ifinfo) ||
+ memcmp(team_get_ifinfo_hwaddr(ifinfo),
+ ctx->hwaddr, ctx->hwaddr_len))
+ return 0;
+ return teamd_port_add(ctx, team_get_ifinfo_ifindex(ifinfo));
+}
+
static const struct teamd_event_watch_ops teamd_port_watch_ops = {
.port_added = teamd_event_watch_port_added,
+ .unlinked_hwaddr_changed = teamd_event_watch_unlinked_hwaddr_changed,
};
static int teamd_port_watch_init(struct teamd_context *ctx)
di...
2018 Feb 21
2
[RFC PATCH v3 0/3] Enable virtio_net to act as a backup for a passthru device
...ot;$.kidnap");
> + if (err || !kidnap ||
> + ctx->hwaddr_len != team_get_ifinfo_hwaddr_len(ifinfo) ||
> + memcmp(team_get_ifinfo_hwaddr(ifinfo),
> + ctx->hwaddr, ctx->hwaddr_len))
> + return 0;
> + return teamd_port_add(ctx, team_get_ifinfo_ifindex(ifinfo));
> +}
> +
So I am not sure about the name of this function. It seems to imply
that we want to capture a device if it changed its MAC address to
match the one we are using. I suppose that works if we are making this
a genreric thing that can run on any ne...
2018 Feb 21
2
[RFC PATCH v3 0/3] Enable virtio_net to act as a backup for a passthru device
...ot;$.kidnap");
> + if (err || !kidnap ||
> + ctx->hwaddr_len != team_get_ifinfo_hwaddr_len(ifinfo) ||
> + memcmp(team_get_ifinfo_hwaddr(ifinfo),
> + ctx->hwaddr, ctx->hwaddr_len))
> + return 0;
> + return teamd_port_add(ctx, team_get_ifinfo_ifindex(ifinfo));
> +}
> +
So I am not sure about the name of this function. It seems to imply
that we want to capture a device if it changed its MAC address to
match the one we are using. I suppose that works if we are making this
a genreric thing that can run on any ne...
2018 Feb 21
0
[RFC PATCH v3 0/3] Enable virtio_net to act as a backup for a passthru device
...> + if (err || !kidnap ||
>> + ctx->hwaddr_len != team_get_ifinfo_hwaddr_len(ifinfo) ||
>> + memcmp(team_get_ifinfo_hwaddr(ifinfo),
>> + ctx->hwaddr, ctx->hwaddr_len))
>> + return 0;
>> + return teamd_port_add(ctx, team_get_ifinfo_ifindex(ifinfo));
>> +}
>> +
>
>So I am not sure about the name of this function. It seems to imply
>that we want to capture a device if it changed its MAC address to
>match the one we are using. I suppose that works if we are making this
>a genreric...