Displaying 3 results from an estimated 3 matches for "takes_ownership".
2009 Dec 19
0
[LLVMdev] [PATCH] Circular Buffered Debug Stream
...REAM = true;
> +
> + /// PRESERVE_STREAM - Tell the destructor to not delete the held
> + /// stream.
> + ///
> + static const bool PRESERVE_STREAM = false;
I don't find these to be very clear names. How about giving them a
name involving 'ownership' like TAKES_OWNERSHIP? "preservation" isn't
really the same as "not deleting when the stream is destroyed" to me.
> + /// TheStream - The real stream we output to. We set it to be
> + /// unbuffered, since we're already doing our own buffering.
> + ///
> + raw_ost...
2009 Dec 18
2
[LLVMdev] [PATCH] Circular Buffered Debug Stream
On Friday 18 December 2009 17:27, David Greene wrote:
> > Here's the updated patch.
>
> Well, that didn't go through right. Here it is again.
Argh! Stupid bug fixed. :)
Index: include/llvm/Support/circular_raw_ostream.h
===================================================================
--- include/llvm/Support/circular_raw_ostream.h (revision 0)
+++
2009 Dec 19
2
[LLVMdev] [PATCH] Circular Buffered Debug Stream
.../// PRESERVE_STREAM - Tell the destructor to not delete the held
> > + /// stream.
> > + ///
> > + static const bool PRESERVE_STREAM = false;
>
> I don't find these to be very clear names. How about giving them a
> name involving 'ownership' like TAKES_OWNERSHIP? "preservation" isn't
> really the same as "not deleting when the stream is destroyed" to me.
That's a good idea.
I just took these from what Dan (I think) did in formatted_raw_ostream.
I'll change them here and rename DeleteStream to OwnsStream as well.
>...