Displaying 5 results from an estimated 5 matches for "sc_prohibit_magic_number_exit".
2009 Nov 20
1
fix new failures from latest-from-gnulib syntax-check
...ith the exemptions (see the .x-sc file below).
Then I converted the vast majority automatically, with this:
maint: use EXIT_SUCCESS and EXIT_FAILURE, not 0 and 1 to exit
Convert all uses automatically, via these two commands:
git grep -l '\<exit *(1)' \
| grep -vEf .x-sc_prohibit_magic_number_exit \
| xargs --no-run-if-empty \
perl -pi -e 's/\b(exit ?)\(1\)/$1(EXIT_FAILURE)/'
git grep -l '\<exit *(0)' \
| grep -vEf .x-sc_prohibit_magic_number_exit \
| xargs --no-run-if-empty \
perl -pi -e 's/\b(exit ?)\(0\)/$1(EXIT_SUCCESS)/'...
2010 Sep 11
1
Remaining syntax-check errors
...use unexpected "
po-docs/libguestfs-docs.pot:2396:"might be called indirectly from L<exit(3)>, which can cause unexpected "
src/guestfs.pod:1193:L<exit(3)>, which can cause unexpected problems in higher-level
maint.mk: use EXIT_* values rather than magic number
make: *** [sc_prohibit_magic_number_exit] Error 1
prohibit_openat_without_use
0.04 prohibit_openat_without_use
prohibit_root_dev_ino_without_use
0.04 prohibit_root_dev_ino_without_use
prohibit_safe_read_without_use
0.04 prohibit_safe_read_without_use
prohibit_signal_without_use
0.05 prohibit_signal_without_use
prohibit_strcmp
0.04 prohibi...
2012 Sep 16
3
Remaining syntax-check errors in libguestfs
...lt;exit(3)>, which can cause
> tests/mount-local/test-parallel-mount-local.c:104: exit (77);
> tests/mount-local/test-parallel-mount-local.c:110: exit (77);
> tests/regressions/rhbz790721.c:79: exit (77);
> maint.mk: use EXIT_* values rather than magic number
> make: *** [sc_prohibit_magic_number_exit] Error 1
I think exit (77) is acceptable. To automake, this means that the
test has been skipped, and there is no constant for it. However
writing a regexp that matches all numbers except "77" is quite hard.
> prohibit_path_max_allocation
> daemon/initrd.c:41: char filename[PAT...
2017 Jan 20
5
[PATCH 0/5] Rename src/ to lib/ and move common code to common/
This patch series moves some files and directories around but is only
code motion (or supposed to be).
A new directory, common/, is created for all of the common code which
is currently shared in random ways between parts of the project.
And src/ becomes lib/ (the largest change, but mostly mechanical).
In full this series makes the following changes:
src/libprotocol -> common/protocol
2017 Jan 25
10
[PATCH v2 0/7] Rename src/ to lib/ and move common code to common/
Previous patch series was posted here:
https://www.redhat.com/archives/libguestfs/2017-January/msg00059.html
v2 simply extends this patch series to cover the extra directories
common/edit, common/progress, common/windows and common/parallel.
The only remaining item is to consider whether we should rename mllib
to something else, mlcommon was my suggestion.
Rich.