Displaying 2 results from an estimated 2 matches for "sadd_open".
Did you mean:
uadd_open
2009 Feb 08
0
[LLVMdev] overflow + saturation stuff
...e AddInstruction::Wrapping:
// ...
case AddInstruction::UndefinedSigned:
// ...
case AddInstruction::UndefinedUnsigned:
// ...
}
}
}
with this:
switch (I->getOpcode()) {
case Instruction::Add:
// ...
case Instruction::SAdd_Open:
// ...
case Instruction::UAdd_Open:
// ...
break;
}
I'm not sure about the name "Open"; fixed-size integers are "closed"
under
wrapping and saturating add, so "open" sort of suggests an alternative,
and is concise. But regardless,...
2009 Feb 07
6
[LLVMdev] overflow + saturation stuff
Edwin was asking about how we should handle PR3328, how we should make
GEP respect -fwrapv etc. I wrote up some thoughts here if anyone is
interested:
http://nondot.org/sabre/LLVMNotes/IntegerOverflow.txt
-Chris