search for: run_script

Displaying 17 results from an estimated 17 matches for "run_script".

2011 Aug 02
6
[PATCH v2 0/4] Support drop directories directly from kinit
...it to execute scripts or executable files present in in the initramfs before switching over to the root filesystem. It is implemented by first implementing scandir() and alphasort() as present in POSIX.1-2008 in klibc itself, and then using that as the basis for iterating and executing files via a run_scripts() call. This patchset introduces two different drop directories, though this is of course subject to change and these are only presented in an effort to put an example forward. I currently only have a requirement to run stuff between the time we call do_mounts() and the time we call run_init()....
2013 May 08
5
Node definition from file (heterogeneous hostnames)
Hi, We would like to specify nodes in site.pp from a file. Is this possible? We have a script that should only be run by x nodes which can be different from time to time. Any suggestions? Thanks in advance Regard, Robin Jonsson -- You received this message because you are subscribed to the Google Groups "Puppet Users" group. To unsubscribe from this group and stop receiving
2011 Jul 29
3
[PATCH 1/3] klibc: Add scandir() and alphasort() support.
Add support for scandir() and alphasort() as defined in POSIX.1-2008. Signed-off-by: Mike Waychison <mikew at google.com> --- usr/include/dirent.h | 7 +++++ usr/klibc/Kbuild | 2 + usr/klibc/scandir.c | 76 ++++++++++++++++++++++++++++++++++++++++++++++++++ 3 files changed, 84 insertions(+), 1 deletions(-) create mode 100644 usr/klibc/scandir.c diff --git
2016 Aug 03
0
[PATCH] dib: rework run of extra-data.d hooks (RHBZ#1362354)
...rs ~log_file ~out_name ~rootfs_uuid ~arch ~network ~root_label ~install_type ~debug ~extra_packages @@ -392,26 +390,61 @@ let run_parts ~debug ~sysroot ~blockdev ~log_file ?(new_wd = "") flush_all (); Buffer.contents outbuf -let run_parts_host ~debug hooks_dir hook_name scripts run_script = +let run_parts_host ~debug (g : Guestfs.guestfs) hooks_dir hook_name base_mount_dir scripts run_script = let hook_dir = hooks_dir // hook_name in let scripts = List.sort digit_prefix_compare scripts in - let timings = Hashtbl.create 13 in - List.iter ( - fun x -> - message (f_&...
2016 Aug 03
3
[PATCH] mllib: move _exit from v2v as Exit module
Move the OCaml binding to C _exit to an own module. Just code motion, adapting v2v in the process. --- docs/C_SOURCE_FILES | 2 +- mllib/Makefile.am | 5 ++++- mllib/exit-c.c | 33 +++++++++++++++++++++++++++++++++ mllib/exit.ml | 19 +++++++++++++++++++ mllib/exit.mli | 20 ++++++++++++++++++++ v2v/Makefile.am | 1 - v2v/changeuid-c.c | 33
2009 Apr 24
1
use of "input" in system()
...do this (on a GNU/Linux system): > system( "cat -", input=sprintf("%04d", i) ) 0005 I am running bash, but system calls go to sh. I want to be able to put that input string ("0005") into a variable and do something like this: system( "i=`cat /dev/stdin` ; run_script > file${i}.out" , input=sprintf("%04d", i) ) I think my problem is more with sh than with R, but someone here must have tried this, so I'm hoping I can get an answer here. Thanks in advance. Best, Mike -- Michael B. Miller, Ph.D. Minnesota Center for Twin and Family Rese...
2016 May 23
0
[PATCH 5/5] mllib: add a new run_command helper
...unlink_on_exit out_file; let args = sprintf "--yes --output %s %s" (quote out_file) (quote filename) in diff --git a/dib/dib.ml b/dib/dib.ml index a76eb5e..4073d47 100644 --- a/dib/dib.ml +++ b/dib/dib.ml @@ -392,7 +392,7 @@ let run_parts_host ~debug hooks_dir hook_name scripts run_script = List.iter ( fun x -> message (f_"Running: %s/%s") hook_name x; - let cmd = sprintf "%s %s %s" (quote run_script) (quote hook_dir) (quote x) in + let cmd = [| run_script; hook_dir; x |] in let run () = run_command cmd in let de...
2017 Feb 14
14
[PATCH 00/10] dib/API: improvements and fixes
Hi, this patch series does changes mostly in virt-dib, few bug fixes and a couple of new features (mostly implemented upstream already). In addition, one new API is added, and a new optional argument for an existing API is added (the latter is not needed, but could be useful anyway). Thanks, Pino Toscano (10): dib: fix listing envvars in fake-sudo dib: source dib "die" script in
2011 Aug 03
2
[PATCH v3 0/2] Support drop directories directly from kinit
...#39;d like to do customization of the early-bootup sequence without having to hack kinit too much), and the use case for initramfs-tools, opening the door to replace all the "core" shell there with kinit as a C implementation. Thanks, Mike Waychison Changelog ========= v3 - Renamed run_scripts() to run_parts(). - Introduced the build of a standalone run-parts binary. - Dropped the alphasort and scandir parts of the series as they are now merged. v2 - Added __extern to alphasort declaration. - Split alphasort() out into alphasort.c and its own patch. Related discus...
2016 May 23
7
[PATCH 1/5] mllib: make external_command echo the command executed
Add an optional parameter to disable this behaviour, so the Curl module in v2v won't print user-sensible data (like passwords). --- builder/checksums.ml | 1 - builder/downloader.ml | 1 - builder/sigchecker.ml | 1 - mllib/common_utils.ml | 4 +++- mllib/common_utils.mli | 7 +++++-- v2v/curl.ml | 2 +- 6 files changed, 9 insertions(+), 7 deletions(-) diff --git
2015 Mar 31
0
[PATCH] WIP: New virt-dib tool
...hen ( + printf "%s completed\n" x + ); + Hashtbl.add timings x delta_t; + ) entries; + g#write_append log_file (timing_output ~target_name:hook_name entries timings) + ); + flush_all (); + Buffer.contents outbuf + +let run_parts_host ~dryrun ~debug hook_dir run_script = + let msg fs = make_message_function ~quiet:false fs in (* XXX *) + let hook_name = Filename.basename hook_dir in + let entries = Array.to_list (Sys.readdir hook_dir) in + let entries = List.filter (fun x -> is_string_valid x) entries in + let entries = List.filter ( + fun x -> +...
2013 Mar 04
1
[PATCH] fuse: Add guestmount-cleanup program to handle unmounting (RHBZ#916780).
* PATCH FOR DISCUSSION ONLY - NOT TO BE APPLIED * Colin suggested something which seems eminently sensible: https://bugzilla.redhat.com/show_bug.cgi?id=916780 I've been through a couple of rounds of trying to implement this. I started with adding the option as suggested to the guestmount program, but it tended to make the guestmount program more complex. More importantly, adding the option
2011 Dec 02
0
Wine release 1.3.34
...y key handle (Coverity). msvfw32: Fix a displayed label. Gerald Pfeifer (1): winex11.drv: Move a conditionally used label into the condition in X11DRV_XRender_Init. Hans Leidekker (11): winhttp: Reverse the order of arguments passed to Invoke. winhttp: Fix a memory leak in run_script. winhttp: Make the standard utilities available to PAC scripts. msi: Perform a case insensitive match on the volume label. ws2_32: Pass NULL nodename on to native getaddrinfo. winhttp: Resolve the server name only on the first request. winhttp: Consistently use the all...
2015 May 29
0
[PATCH v3] RFC: New virt-dib tool
...intf "%s completed after %.3f s\n" x delta_t + ); + Hashtbl.add timings x delta_t; + ) scripts; + g#write_append log_file (timing_output ~target_name:hook_name scripts timings); + flush_all (); + Buffer.contents outbuf + +let run_parts_host ~debug hooks_dir hook_name scripts run_script = + let hook_dir = hooks_dir // hook_name in + let scripts = List.sort digit_prefix_compare scripts in + let timings = Hashtbl.create 13 in + List.iter ( + fun x -> + message (f_"Running: %s/%s") hook_name x; + let cmd = sprintf "%s %s %s" (quote run_script)...
2015 Jul 03
1
[PATCH v5] New tool: virt-dib
...intf "%s completed after %.3f s\n" x delta_t + ); + Hashtbl.add timings x delta_t; + ) scripts; + g#write_append log_file (timing_output ~target_name:hook_name scripts timings); + flush_all (); + Buffer.contents outbuf + +let run_parts_host ~debug hooks_dir hook_name scripts run_script = + let hook_dir = hooks_dir // hook_name in + let scripts = List.sort digit_prefix_compare scripts in + let timings = Hashtbl.create 13 in + List.iter ( + fun x -> + message (f_"Running: %s/%s") hook_name x; + let cmd = sprintf "%s %s %s" (quote run_script)...
2013 Mar 05
1
[PATCH v2] fuse: Add guestunmount program to handle unmounting (RHBZ#916780)
Since the first patch: - The program is now called 'guestunmount'. - I tested the --fd option and it appears to work. - You can now control retries / quiet. - Revised man pages. - Includes tests. I'm just running through the automated tests now. Rich.
2015 Jun 16
2
[PATCH v4] RFC: New tool: virt-dib
...intf "%s completed after %.3f s\n" x delta_t + ); + Hashtbl.add timings x delta_t; + ) scripts; + g#write_append log_file (timing_output ~target_name:hook_name scripts timings); + flush_all (); + Buffer.contents outbuf + +let run_parts_host ~debug hooks_dir hook_name scripts run_script = + let hook_dir = hooks_dir // hook_name in + let scripts = List.sort digit_prefix_compare scripts in + let timings = Hashtbl.create 13 in + List.iter ( + fun x -> + message (f_"Running: %s/%s") hook_name x; + let cmd = sprintf "%s %s %s" (quote run_script)...