Displaying 4 results from an estimated 4 matches for "ptrbit".
Did you mean:
ptrbits
2012 Aug 27
2
[LLVMdev] FW: RFC: Supporting different sized address space arithmetic
...ev] FW: RFC: Supporting different sized address
> space arithmetic
>
> Micah,
>
> There are a number of variable names in this patch that don't follow
> the naming convention (which specifies that they should start with an
> uppercase letter).
>
> > if (PtrBits < 64)
> > - OffsVal = DAG.getNode(ISD::TRUNCATE, getCurDebugLoc(),
> > - TLI.getPointerTy(),
> > + OffsVal = DAG.getNode(ISD::TRUNCATE, getCurDebugLoc(),
> > PtrTy, DAG.getConstant(Offs, MVT::i64));
>
> This is not...
2012 Aug 24
0
[LLVMdev] FW: RFC: Supporting different sized address space arithmetic
Micah,
There are a number of variable names in this patch that don't follow
the naming convention (which specifies that they should start with an
uppercase letter).
> if (PtrBits < 64)
> - OffsVal = DAG.getNode(ISD::TRUNCATE, getCurDebugLoc(),
> - TLI.getPointerTy(),
> + OffsVal = DAG.getNode(ISD::TRUNCATE, getCurDebugLoc(),
> PtrTy, DAG.getConstant(Offs, MVT::i64));
This is not necessarily specific to your p...
2012 Aug 27
0
[LLVMdev] FW: RFC: Supporting different sized address space arithmetic
...ss
> > space arithmetic
> >
> > Micah,
> >
> > There are a number of variable names in this patch that don't follow
> > the naming convention (which specifies that they should start with
> > an uppercase letter).
> >
> > > if (PtrBits < 64)
> > > - OffsVal = DAG.getNode(ISD::TRUNCATE, getCurDebugLoc(),
> > > - TLI.getPointerTy(),
> > > + OffsVal = DAG.getNode(ISD::TRUNCATE, getCurDebugLoc(),
> > > PtrTy, DAG.getConstant(Offs, MVT::i64));
>...
2012 Aug 24
5
[LLVMdev] FW: RFC: Supporting different sized address space arithmetic
> -----Original Message-----
> From: Villmow, Micah
> Sent: Friday, August 24, 2012 2:56 PM
> To: 'Eli Friedman'
> Cc: LLVM Developers Mailing List
> Subject: RE: [LLVMdev] RFC: Supporting different sized address space
> arithmetic
>
> Eli,
> There is a patch that implements the beginning what I think is the
> correct approach to support the backend