Displaying 4 results from an estimated 4 matches for "performcoalesc".
2007 Aug 27
0
[LLVMdev] [patch] Pluggable Coalescers
...s.
+ virtual bool coalesceFunction(MachineFunction &mf,
InterferenceData &ifd) = 0;
80 col violation.
6.
+ /// doWork - The main coalescing algorithm. Return whether any
+ /// copies were coalesced.
+ bool doWork(MachineFunction &mf);
Please rename it to something like performCoalescing. Also, is this
defined anywhere?
7. About class LinearScanInterferenceData. Since it's just an
example, perhaps it should go into comments or a README file instead.
Evan
On Aug 20, 2007, at 1:58 PM, David A. Greene wrote:
> <pluggable_coalescer.patch>
2007 Aug 27
2
[LLVMdev] [patch] Pluggable Coalescers
...unction &mf,
> InterferenceData &ifd) = 0;
>
> 80 col violation.
Ok.
> 6.
> + /// doWork - The main coalescing algorithm. Return whether any
> + /// copies were coalesced.
> + bool doWork(MachineFunction &mf);
>
> Please rename it to something like performCoalescing. Also, is this
> defined anywhere?
It's just what runOnMachineFunction used to be. I split it out into doWork
so that it could be called from coalesceFunction and this is what used to
happen before I realized that didn't make sense at all. So really, doWork
can go away. I'll c...
2007 Aug 20
4
[LLVMdev] [patch] Pluggable Coalescers
Here's a proposed patch for reworking register coalescing to allow pluggable
coalescers. I think I've got the interfaces where I want them and am
reasonably sure I've squashed most of the bugs. I'm still doing some testing
and want to get through a whole regimen before committing.
As a reminder, this patch has several goals:
- Allow user-specified register coalescers, similar
2007 Aug 28
0
[LLVMdev] [patch] Pluggable Coalescers
...fd) = 0;
>>
>> 80 col violation.
>
> Ok.
>
>> 6.
>> + /// doWork - The main coalescing algorithm. Return whether any
>> + /// copies were coalesced.
>> + bool doWork(MachineFunction &mf);
>>
>> Please rename it to something like performCoalescing. Also, is this
>> defined anywhere?
>
> It's just what runOnMachineFunction used to be. I split it out into
> doWork
> so that it could be called from coalesceFunction and this is what
> used to
> happen before I realized that didn't make sense at all. So re...