Displaying 2 results from an estimated 2 matches for "nv50_wait_dpms_ctrl".
2014 Aug 12
0
[PATCH 3/4] drm/nouveau: Replaced copy-pasted nv_wait with nv50_wait_dpms_ctrl helper
....c b/drivers/gpu/drm/nouveau/core/engine/disp/dacnv50.c
index 61e29d6..98bded6 100644
--- a/drivers/gpu/drm/nouveau/core/engine/disp/dacnv50.c
+++ b/drivers/gpu/drm/nouveau/core/engine/disp/dacnv50.c
@@ -33,6 +33,12 @@
#include "nv50.h"
#include "nouveau_reg.h"
+static void
+nv50_wait_dpms_ctrl(struct nv50_disp_priv *priv, const u32 dpms_ctrl)
+{
+ nv_wait(priv, dpms_ctrl, NV50_PDISPLAY_DAC_DPMS_CTRL_PENDING, 0);
+}
+
int
nv50_dac_power(NV50_DISP_MTHD_V1)
{
@@ -56,10 +62,10 @@ nv50_dac_power(NV50_DISP_MTHD_V1)
} else
return ret;
- nv_wait(priv, dpms_ctrl, NV50_PDISPLAY_DAC_DPMS_...
2014 Aug 12
6
[PATCH 0/4] Some initial tidy-ups and refactoring
...p work, and refactoring that has arisen
as a by-product of my initial work on adding TV support to nv50.
Joel Holdsworth (4):
drm/nouveau: Removed unneeded include in nvc0_fence.c
drm/nouveau: Replaced magic numbers with defines from nouveau_reg
drm/nouveau: Replaced copy-pasted nv_wait with nv50_wait_dpms_ctrl
helper
drm/nouveau: Refactored encoder create functions into common
nv50_encoder_create helper
drivers/gpu/drm/nouveau/core/engine/disp/dacnv50.c | 33 ++--
drivers/gpu/drm/nouveau/nv50_display.c | 178 ++++++++-------------
drivers/gpu/drm/nouveau/nvc0_fence.c...