search for: mergability

Displaying 20 results from an estimated 74 matches for "mergability".

Did you mean: mergeability
2020 Aug 13
3
Deterministic function return attribute
...erested in what attributes in LLVM mean, specifically how to say that the result is always the same for the given input parameters. The main thing would be to merge two calls with the same parameters when the function is declared but not defined. (just like two stores). I'll call this property mergability. %1 := call @test(%0) %2 := call @test(%0) and the optimization would be something like (%2).replaceUsesWith((%1)). I think it's related to speculatable & readnone in LLVM, (if I understood well, it's the same as GCC's __attribute__((pure)), but I'm not sure whether there are...
2013 May 30
1
updated: kvm networking todo wiki
"Michael S. Tsirkin" <mst at redhat.com> writes: > On Thu, May 30, 2013 at 08:40:47AM -0500, Anthony Liguori wrote: >> Stefan Hajnoczi <stefanha at gmail.com> writes: >> >> > On Thu, May 30, 2013 at 7:23 AM, Rusty Russell <rusty at rustcorp.com.au> wrote: >> >> Anthony Liguori <anthony at codemonkey.ws> writes: >>
2013 May 30
1
updated: kvm networking todo wiki
"Michael S. Tsirkin" <mst at redhat.com> writes: > On Thu, May 30, 2013 at 08:40:47AM -0500, Anthony Liguori wrote: >> Stefan Hajnoczi <stefanha at gmail.com> writes: >> >> > On Thu, May 30, 2013 at 7:23 AM, Rusty Russell <rusty at rustcorp.com.au> wrote: >> >> Anthony Liguori <anthony at codemonkey.ws> writes: >>
2013 May 30
2
updated: kvm networking todo wiki
Stefan Hajnoczi <stefanha at gmail.com> writes: > On Thu, May 30, 2013 at 7:23 AM, Rusty Russell <rusty at rustcorp.com.au> wrote: >> Anthony Liguori <anthony at codemonkey.ws> writes: >>> Rusty Russell <rusty at rustcorp.com.au> writes: >>>> On Fri, May 24, 2013 at 08:47:58AM -0500, Anthony Liguori wrote: >>>>> FWIW, I think
2013 May 30
2
updated: kvm networking todo wiki
Stefan Hajnoczi <stefanha at gmail.com> writes: > On Thu, May 30, 2013 at 7:23 AM, Rusty Russell <rusty at rustcorp.com.au> wrote: >> Anthony Liguori <anthony at codemonkey.ws> writes: >>> Rusty Russell <rusty at rustcorp.com.au> writes: >>>> On Fri, May 24, 2013 at 08:47:58AM -0500, Anthony Liguori wrote: >>>>> FWIW, I think
2009 Jul 20
6
[patch 00/54] [Announce] Microsoft Hyper-V drivers for Linux
Hi all, I'm happy to announce, that after many months of discussions, Microsoft has released their Hyper-V Linux drivers under the GPLv2. Following this message, will be the patches that add the drivers to the drivers/staging/ tree, and a whole bunch of cleanups. It's taken a long road to get here, and I'd like to thank the following people who made this possible: - Steve
2009 Jul 20
6
[patch 00/54] [Announce] Microsoft Hyper-V drivers for Linux
Hi all, I'm happy to announce, that after many months of discussions, Microsoft has released their Hyper-V Linux drivers under the GPLv2. Following this message, will be the patches that add the drivers to the drivers/staging/ tree, and a whole bunch of cleanups. It's taken a long road to get here, and I'd like to thank the following people who made this possible: - Steve
2008 Oct 17
3
[LLVMdev] merging globals
Hello, Tatu > Is that correct? I think it's just something to be aware of. Currently we're aggressively merging globals by default. Do you think it will be better to provide special flag to control this behavior? -- WBR, Anton Korobeynikov
2008 Oct 17
0
[LLVMdev] merging globals
On Oct 17, 2008, at 7:30 AM, Anton Korobeynikov wrote: > Hello, Tatu > >> Is that correct? I think it's just something to be aware of. > Currently we're aggressively merging globals by default. Do you > think it > will be better to provide special flag to control this behavior? Please no flag. If we want to fix this problem, lets do it right. To me this
2020 Aug 14
2
Fwd: Deterministic function return attribute
...that the result is always the same for the given input parameters. >>  > >>  > The main thing would be to merge two calls with the same parameters >>  > when the function is declared but not defined. (just like two stores). >>  > I'll call this property mergability. >>  > >>  > %1 := call @test(%0) >>  > %2 := call @test(%0) >>  > >>  > and the optimization would be something like (%2).replaceUsesWith((%1)). >>  > >>  > I think it's related to speculatable & readnone in LLVM, (if I...
2008 Oct 16
2
[LLVMdev] merging globals
On Thu, Oct 16, 2008 at 12:35 PM, Mike Stump <mrs at apple.com> wrote: >> It doesn't really change the issue, though; we want the merging to be >> a front-end option, and we still need a solution which handles >> variables that gets marked by the optimizer. > > I think so. If we could get C/C++ to just bless merging and then just > support that and ignore
2008 Oct 17
2
[LLVMdev] merging globals
On 17/10/2008, Chris Lattner <clattner at apple.com> wrote: > Please no flag. If we want to fix this problem, lets do it right. To > me this consists of some flag on GlobalVariable that says that it is > 'mergable' or something like that. Wouldn't it be slightly cleaner to mark the distinct objects in the LLVM intermediate representation? This would make the default
2008 Oct 16
0
[LLVMdev] merging globals
On Oct 16, 2008, at 1:57 PM, Eli Friedman wrote: > I strongly doubt we can get away with that. Yeah, we agree on that one. I was just thinking about the const case. > Here's a more concrete version of the solution I'm proposing: we add a > new optional marking to constant globals, say "mergeable". There are > two reasonable semantics: one is that the result of
2020 Feb 13
1
[PATCH] nouveau: no need to check return value of debugfs_create functions
On Thu, Feb 13, 2020 at 11:39 PM Greg Kroah-Hartman <gregkh at linuxfoundation.org> wrote: > > On Thu, Feb 13, 2020 at 02:30:09PM -0800, John Hubbard wrote: > > On 2/9/20 2:55 AM, Greg Kroah-Hartman wrote: > > > When calling debugfs functions, there is no need to ever check the > > > return value. The function can work or not, but the code logic should >
2020 Feb 13
2
[PATCH] nouveau: no need to check return value of debugfs_create functions
On 2/9/20 2:55 AM, Greg Kroah-Hartman wrote: > When calling debugfs functions, there is no need to ever check the > return value. The function can work or not, but the code logic should > never do something different based on this. > Should we follow that line of reasoning further, and simply return void from the debugfs functions--rather than playing whack-a-mole with this
2017 Jul 31
5
[PATCH] mm: don't zero ballooned pages
On 07/31/2017 02:55 PM, Michal Hocko wrote: > On Mon 31-07-17 12:13:33, Wei Wang wrote: >> Ballooned pages will be marked as MADV_DONTNEED by the hypervisor and >> shouldn't be given to the host ksmd to scan. > Could you point me where this MADV_DONTNEED is done, please? Sure. It's done in the hypervisor when the balloon pages are received. Please see line 40 at
2017 Jul 31
5
[PATCH] mm: don't zero ballooned pages
On 07/31/2017 02:55 PM, Michal Hocko wrote: > On Mon 31-07-17 12:13:33, Wei Wang wrote: >> Ballooned pages will be marked as MADV_DONTNEED by the hypervisor and >> shouldn't be given to the host ksmd to scan. > Could you point me where this MADV_DONTNEED is done, please? Sure. It's done in the hypervisor when the balloon pages are received. Please see line 40 at
2017 Jan 04
2
NEAR non-leaf subqueries
Olly Betts writes: > On Thu, Dec 29, 2016 at 07:21:41PM +0100, Jean-Francois Dockes wrote: > > Xapian 1.2 supports a query like: > > > > (A OR B) NEAR (C OR D) > > > > and distributes the factors to create something like: > > > > (A NEAR 2 C) OR (B NEAR 2 C) OR (B NEAR 2 C) OR (A NEAR 2 C) > > > > Xapian 1.4 rejects such
2008 Oct 17
0
[LLVMdev] merging globals
On Oct 17, 2008, at 11:18 AM, danchr at gmail.com wrote: > On 17/10/2008, Chris Lattner <clattner at apple.com> wrote: >> Please no flag. If we want to fix this problem, lets do it right. >> To >> me this consists of some flag on GlobalVariable that says that it is >> 'mergable' or something like that. > > Wouldn't it be slightly cleaner to
2020 Feb 13
0
[PATCH] nouveau: no need to check return value of debugfs_create functions
On Thu, Feb 13, 2020 at 02:30:09PM -0800, John Hubbard wrote: > On 2/9/20 2:55 AM, Greg Kroah-Hartman wrote: > > When calling debugfs functions, there is no need to ever check the > > return value. The function can work or not, but the code logic should > > never do something different based on this. > > > > Should we follow that line of reasoning further, and