search for: llvm_asm_prefix

Displaying 3 results from an estimated 3 matches for "llvm_asm_prefix".

2009 Dec 07
1
[LLVMdev] #define LLVM_ASM_PREFIX_CHAR '\1' to make code more readable?
...r, how should I remove magic numbers from | } else if (Name == "\1stat64" || | Name == "\1lstat64" || | Name == "\1statvfs64" || | Name == "\1__isoc99_sscanf") { without using a macro? Something like | } else if (Name[0] == llvm_asm_prefix && Name.slice(1, 0) == "stat64" || | Name[0] == llvm_asm_prefix && Name.slice(1, 0) == "lstat64" || | Name[0] == llvm_asm_prefix && Name.slice(1, 0) == "statvfs64" || | Name[0] == llvm_asm_prefix && Name....
2009 Nov 26
0
[LLVMdev] #define LLVM_ASM_PREFIX_CHAR '\1' to make code more readable?
....cgi?id=5480 ) > > How about adding a #define for this prefix? The attached three patches > contain occurences of this prefix in llvm, clang and llvm-gcc that I > was able to identify but I don't know what would be a proper place for > the #define itself. Also should it maybe be LLVM_ASM_PREFIX or just > ASM_PREFIX? (I think both character and string versions are > needed. Afaik characters can not be concatenated to strings with > the preprocessor). Changing this from being a magic number to a 'static const char' is fine with me, please don't use a macro though. The...
2009 Nov 18
2
[LLVMdev] #define LLVM_ASM_PREFIX_CHAR '\1' to make code more readable?
...://llvm.org/bugs/show_bug.cgi?id=5480 ) How about adding a #define for this prefix? The attached three patches contain occurences of this prefix in llvm, clang and llvm-gcc that I was able to identify but I don't know what would be a proper place for the #define itself. Also should it maybe be LLVM_ASM_PREFIX or just ASM_PREFIX? (I think both character and string versions are needed. Afaik characters can not be concatenated to strings with the preprocessor). I am also not quite sure how the prefix should be documented. Does "\01foo" mean "foo is a name that can be given to assembler or d...