Displaying 5 results from an estimated 5 matches for "libprotocol_a_cflags".
Did you mean:
libprotocol_la_cflags
2011 Oct 20
4
[PATCH 1/3] out-of-tree build: daemon
...1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index e23ce86..af075d7 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -42,10 +42,10 @@ noinst_LIBRARIES = libprotocol.a
libprotocol_a_SOURCES = guestfs_protocol.c guestfs_protocol.h
libprotocol_a_CFLAGS = -Wall -Wno-unused -fno-strict-aliasing
-guestfs_protocol.c: $(libsrcdir)/guestfs_protocol.c
+guestfs_protocol.c: $(srcdir)/guestfs_protocol.c
rm -f $@
ln $< $@
-guestfs_protocol.h: $(libsrcdir)/guestfs_protocol.h
+guestfs_protocol.h: $(srcdir)/guestfs_protocol.h
rm -f $@
ln $< $@...
2013 Feb 18
4
Some fixes for building the Debian package for 1.20.2
I needed to add a few patches to be able to build libguestfs 1.20.2
out of tree. Mostly srcdir/builddir issues -- I think that I had
posted something for building the daemon before.
As mentioned on IRC, I found that compiling (Ruby bindings) caused
config.h file shipped with the Ruby headers to be included rather than
${builddir}/config.h. This can be fixed because the relevant checks
can be
2017 Jan 25
0
[PATCH v2 1/7] lib: Share common protocol and errnostring libraries with the library and daemon.
...ILT_SOURCES) \
guestfsd.pod
-$(shared_with_library): %: $(top_srcdir)/src/%
- rm -f $@
- ln $< $@
-
-noinst_LIBRARIES = libprotocol.a
-
-# This convenience library is solely to compile its generated sources with
-# custom flags.
-libprotocol_a_SOURCES = guestfs_protocol.c guestfs_protocol.h
-libprotocol_a_CFLAGS = -Wall -Wno-unused -fno-strict-aliasing
-
-$(top_builddir)/src/guestfs_protocol.c: force
- $(MAKE) -C $(top_builddir)/src guestfs_protocol.c
-$(top_builddir)/src/guestfs_protocol.h: force
- $(MAKE) -C $(top_builddir)/src guestfs_protocol.h
-
-# Build the errnostring perfect hash code. The generat...
2017 Jan 20
5
[PATCH 0/5] Rename src/ to lib/ and move common code to common/
This patch series moves some files and directories around but is only
code motion (or supposed to be).
A new directory, common/, is created for all of the common code which
is currently shared in random ways between parts of the project.
And src/ becomes lib/ (the largest change, but mostly mechanical).
In full this series makes the following changes:
src/libprotocol -> common/protocol
2017 Jan 25
10
[PATCH v2 0/7] Rename src/ to lib/ and move common code to common/
Previous patch series was posted here:
https://www.redhat.com/archives/libguestfs/2017-January/msg00059.html
v2 simply extends this patch series to cover the extra directories
common/edit, common/progress, common/windows and common/parallel.
The only remaining item is to consider whether we should rename mllib
to something else, mlcommon was my suggestion.
Rich.