search for: isa_nonnulll

Displaying 6 results from an estimated 6 matches for "isa_nonnulll".

Did you mean: isa_nonnull
2019 Apr 06
4
[RFC] Should we add isa_or_null<>?
...isa_and_nonnull<> is a bit of a weird name for me, but I could >> probably live with it. We could spell it nonnull_and_isa<> to reflect >> the order of the operations, but that sort of hides the important part >> of the API (the "isa" bit). >> > > isa_nonnulll works fine for me, isa_and_nonnull is a bit verbose but seems > OK as well. > > For nonnull_and_isa<T>(val) ; it starts to look strangely close to the > pattern !val && isa<T>(val) ; and I'm not sure it is really such a > readability improvement anymore? >...
2019 Apr 10
2
[RFC] Should we add isa_or_null<>?
...t; > > isa_and_nonnull<> is a bit of a weird name for me, but I could > probably live with it. We could spell it nonnull_and_isa<> to reflect > the order of the operations, but that sort of hides the important part > of the API (the "isa" bit). > > isa_nonnulll works fine for me, isa_and_nonnull is a bit verbose but seems OK as well. > > For nonnull_and_isa<T>(val) ; it starts to look strangely close to the pattern !val && isa<T>(val) ; and I'm not sure it is really such a readability > improvement anymore? > > --...
2019 Apr 07
2
[RFC] Should we add isa_or_null<>?
...for me, but I could >>>> probably live with it. We could spell it nonnull_and_isa<> to reflect >>>> the order of the operations, but that sort of hides the important part >>>> of the API (the "isa" bit). >>>> >>> >>> isa_nonnulll works fine for me, isa_and_nonnull is a bit verbose but >>> seems OK as well. >>> >>> For nonnull_and_isa<T>(val) ; it starts to look strangely close to the >>> pattern !val && isa<T>(val) ; and I'm not sure it is really such a >>&gt...
2019 Apr 04
4
[RFC] Should we add isa_or_null<>?
On Thu, Apr 4, 2019 at 12:58 PM Chris Lattner <clattner at nondot.org> wrote: > > > > > On Apr 4, 2019, at 5:37 AM, Don Hinton via llvm-dev <llvm-dev at lists.llvm.org> wrote: > > > > I'd like to propose adding `isa_or_null<>` to replace the following usage pattern that's relatively common in conditionals: > > > > var &&
2019 Apr 07
2
[RFC] Should we add isa_or_null<>?
...t does not translate with isa<> IMO. isa_and_nonnull<> is a bit of a weird name for me, but I could probably live with it. We could spell it nonnull_and_isa<> to reflect the order of the operations, but that sort of hides the important part of the API (the "isa" bit). isa_nonnulll works fine for me, isa_and_nonnull is a bit verbose but seems OK as well. For nonnull_and_isa<T>(val) ; it starts to look strangely close to the pattern !val && isa<T>(val) ; and I'm not sure it is really such a readability improvement anymore? -- Mehdi ~Aaron > &gt...
2019 Apr 22
3
[RFC] Should we add isa_or_null<>?
...bit of a weird name for me, but I could >> > probably live with it. We could spell it nonnull_and_isa<> to reflect >> > the order of the operations, but that sort of hides the important part >> > of the API (the "isa" bit). >> > >> > isa_nonnulll works fine for me, isa_and_nonnull is a bit verbose but >> seems OK as well. >> > >> > For nonnull_and_isa<T>(val) ; it starts to look strangely close to the >> pattern !val && isa<T>(val) ; and I'm not sure it is really such a >> readabi...