search for: isa_nonnul

Displaying 6 results from an estimated 6 matches for "isa_nonnul".

Did you mean: isa_nonnull
2019 Apr 05
2
[RFC] Should we add isa_or_null<>?
+1 for "isa_nonnull" --paulr From: llvm-dev [mailto:llvm-dev-bounces at lists.llvm.org] On Behalf Of Hubert Tong via llvm-dev Sent: Friday, April 05, 2019 12:10 AM To: Aaron Ballman Cc: LLVM Development List Subject: Re: [llvm-dev] [RFC] Should we add isa_or_null<>? On Thu, Apr 4, 2019 at 11:15 PM Aaron...
2019 Apr 22
3
[RFC] Should we add isa_or_null<>?
Hi All: Just wanted to wind this up and summarize the results. Although there were a few no votes, it looks like there's a consensus for adding a `isa_and_nonnull` type operator. While there were some who preferred `isa_nonnull`, it wasn't overwhelming, and since `isa_and_nonnull` is already committed, I'm going to leave it as `isa_and_nonnull` for the time being. Thanks for all the comments. don On Thu, Apr 11, 2019 at 7:49 PM Don Hinton <hintonda at gmail.com> wrote: > On Wed, Apr 10, 2019 at 11:3...
2019 May 05
3
[RFC] Should we add isa_or_null<>?
...> >> > >> On 22/04/2019 15:15, Don Hinton via llvm-dev wrote: > >> > Although there were a few no votes, it looks like there's a consensus > >> > for adding a `isa_and_nonnull` type operator. While there were some > who > >> > preferred `isa_nonnull`, it wasn't overwhelming, and since > >> > `isa_and_nonnull` is already committed, I'm going to leave it as > >> > `isa_and_nonnull` for the time being. > >> > >> Maybe I missed something, but it looked to me as if the consensus was > >> t...
2019 May 04
2
[RFC] Should we add isa_or_null<>?
...a llvm-dev < llvm-dev at lists.llvm.org> wrote: > On 22/04/2019 15:15, Don Hinton via llvm-dev wrote: > > Although there were a few no votes, it looks like there's a consensus > > for adding a `isa_and_nonnull` type operator. While there were some who > > preferred `isa_nonnull`, it wasn't overwhelming, and since > > `isa_and_nonnull` is already committed, I'm going to leave it as > > `isa_and_nonnull` for the time being. > > Maybe I missed something, but it looked to me as if the consensus was > that `isa_and_some_words<T>(foo)` impose...
2019 Apr 04
4
[RFC] Should we add isa_or_null<>?
On Thu, Apr 4, 2019 at 12:58 PM Chris Lattner <clattner at nondot.org> wrote: > > > > > On Apr 4, 2019, at 5:37 AM, Don Hinton via llvm-dev <llvm-dev at lists.llvm.org> wrote: > > > > I'd like to propose adding `isa_or_null<>` to replace the following usage pattern that's relatively common in conditionals: > > > > var &&
2019 Apr 10
2
[RFC] Should we add isa_or_null<>?
...t; > > isa_and_nonnull<> is a bit of a weird name for me, but I could > probably live with it. We could spell it nonnull_and_isa<> to reflect > the order of the operations, but that sort of hides the important part > of the API (the "isa" bit). > > isa_nonnulll works fine for me, isa_and_nonnull is a bit verbose but seems OK as well. > > For nonnull_and_isa<T>(val) ; it starts to look strangely close to the pattern !val && isa<T>(val) ; and I'm not sure it is really such a readability > improvement anymore? > >...