search for: isa_and_nonnull

Displaying 10 results from an estimated 10 matches for "isa_and_nonnull".

2019 Apr 22
3
[RFC] Should we add isa_or_null<>?
Hi All: Just wanted to wind this up and summarize the results. Although there were a few no votes, it looks like there's a consensus for adding a `isa_and_nonnull` type operator. While there were some who preferred `isa_nonnull`, it wasn't overwhelming, and since `isa_and_nonnull` is already committed, I'm going to leave it as `isa_and_nonnull` for the time being. Thanks for all the comments. don On Thu, Apr 11, 2019 at 7:49 PM Don Hinton <hi...
2019 May 04
2
[RFC] Should we add isa_or_null<>?
On Mon, Apr 29, 2019, 02:37 David Chisnall via llvm-dev < llvm-dev at lists.llvm.org> wrote: > On 22/04/2019 15:15, Don Hinton via llvm-dev wrote: > > Although there were a few no votes, it looks like there's a consensus > > for adding a `isa_and_nonnull` type operator. While there were some who > > preferred `isa_nonnull`, it wasn't overwhelming, and since > > `isa_and_nonnull` is already committed, I'm going to leave it as > > `isa_and_nonnull` for the time being. > > Maybe I missed something, but it looked to me...
2019 Apr 10
2
[RFC] Should we add isa_or_null<>?
...implementation could be a simple wrapper around isa<>, and while the IR produced is only slightly more efficient, the elimination of an extra > call could be worthwhile. > > > > I’d love to see this, I agree with downstream comments though that this name will be confusing. isa_and_nonnull<>. ? > > tbh, I don't think the proposed name will be all that confusing -- > > I am with David on this, this sounds like misleading naming to me, I would expect true on null value when reading : if (isa_or_null<T>(var)) > > we're used to _or_null() returnin...
2019 May 05
3
[RFC] Should we add isa_or_null<>?
...r 29, 2019, 02:37 David Chisnall via llvm-dev < > llvm-dev at lists.llvm.org> wrote: > >> > >> On 22/04/2019 15:15, Don Hinton via llvm-dev wrote: > >> > Although there were a few no votes, it looks like there's a consensus > >> > for adding a `isa_and_nonnull` type operator. While there were some > who > >> > preferred `isa_nonnull`, it wasn't overwhelming, and since > >> > `isa_and_nonnull` is already committed, I'm going to leave it as > >> > `isa_and_nonnull` for the time being. > >> > >&...
2019 Apr 04
4
[RFC] Should we add isa_or_null<>?
...> > > The implementation could be a simple wrapper around isa<>, and while the IR produced is only slightly more efficient, the elimination of an extra call could be worthwhile. > > I’d love to see this, I agree with downstream comments though that this name will be confusing. isa_and_nonnull<>. ? tbh, I don't think the proposed name will be all that confusing -- we're used to _or_null() returning "the right thing" when given null. isa_and_nonnull<> is a bit of a weird name for me, but I could probably live with it. We could spell it nonnull_and_isa<&gt...
2019 Apr 06
4
[RFC] Should we add isa_or_null<>?
...simple wrapper around isa<>, and while >> the IR produced is only slightly more efficient, the elimination of an >> extra call could be worthwhile. >> > >> > I’d love to see this, I agree with downstream comments though that this >> name will be confusing. isa_and_nonnull<>. ? >> >> tbh, I don't think the proposed name will be all that confusing -- >> > > I am with David on this, this sounds like misleading naming to me, I would > expect true on null value when reading : if (isa_or_null<T>(var)) > > we're used to...
2019 Apr 07
2
[RFC] Should we add isa_or_null<>?
...gt;>>> while the IR produced is only slightly more efficient, the elimination of >>>> an extra call could be worthwhile. >>>> > >>>> > I’d love to see this, I agree with downstream comments though that >>>> this name will be confusing. isa_and_nonnull<>. ? >>>> >>>> tbh, I don't think the proposed name will be all that confusing -- >>>> >>> >>> I am with David on this, this sounds like misleading naming to me, I >>> would expect true on null value when reading : if (isa_or_...
2019 Apr 07
2
[RFC] Should we add isa_or_null<>?
...> > > The implementation could be a simple wrapper around isa<>, and while the IR produced is only slightly more efficient, the elimination of an extra call could be worthwhile. > > I’d love to see this, I agree with downstream comments though that this name will be confusing. isa_and_nonnull<>. ? tbh, I don't think the proposed name will be all that confusing -- I am with David on this, this sounds like misleading naming to me, I would expect true on null value when reading : if (isa_or_null<T>(var)) we're used to _or_null() returning "the right thing"...
2019 Apr 04
4
[RFC] Should we add isa_or_null<>?
I'd like to propose adding `isa_or_null<>` to replace the following usage pattern that's relatively common in conditionals: var && isa<T>(var) =>> isa_or_null<T>(var) And in particular when `var` is a method call which might be expensive, e.g.: X->foo() && isa<T>(X->foo()) =>> isa_or_null<T>(X->foo()) The
2019 Apr 05
2
[RFC] Should we add isa_or_null<>?
...> > > The implementation could be a simple wrapper around isa<>, and while the IR produced is only slightly more efficient, the elimination of an extra call could be worthwhile. > > I’d love to see this, I agree with downstream comments though that this name will be confusing. isa_and_nonnull<>. ? tbh, I don't think the proposed name will be all that confusing -- we're used to _or_null() returning "the right thing" when given null. isa_and_nonnull<> is a bit of a weird name for me, but I could probably live with it. We could spell it nonnull_and_isa<&gt...