search for: hardref

Displaying 5 results from an estimated 5 matches for "hardref".

Did you mean: harder
2013 Jun 21
2
[LLVMdev] Proposal: type uniquing of debug info for LTO
On 21 June 2013 18:18, David Blaikie <dblaikie at gmail.com> wrote: > !llvm.hardref.foo.h.myClass = ...; > !llvm.hardref.bar.h.myClass = ...; > I like this idea! It's much easier to read than metadata fields, but will it need to have mangled names that today, are quoted? Do we still have the notion that named metadata cannot be deleted? cheers, --renato --------------...
2013 Jun 21
0
[LLVMdev] Proposal: type uniquing of debug info for LTO
On Fri, Jun 21, 2013 at 10:33 AM, Renato Golin <renato.golin at linaro.org> wrote: > On 21 June 2013 18:18, David Blaikie <dblaikie at gmail.com> wrote: >> >> !llvm.hardref.foo.h.myClass = ...; >> !llvm.hardref.bar.h.myClass = ...; > > > I like this idea! It's much easier to read than metadata fields, but will it > need to have mangled names that today, are quoted? Mangled in some form - using the actual language mangling's probably a good i...
2013 Jun 21
1
[LLVMdev] Proposal: type uniquing of debug info for LTO
...ren at apple.com> wrote: >> >> More details please :] >> What do you mean by "name the metadata"? Are you referring to the name field >> of the MDNode? > > Using named metadata rather than unnamed metadata. > > rather than having: > > !llvm.hardref = !{metadata !"foo.h::myClass", !3, metadata > !"bar.h:myEnum", !4} ... > !3 = ...; > !4 = ...; > > we could simply have: > > !llvm.hardref.foo.h.myClass = ...; > !llvm.hardref.bar.h.myClass = ...; > > or something like that. From the documentat...
2013 Jun 21
0
[LLVMdev] Proposal: type uniquing of debug info for LTO
...Fri, Jun 21, 2013 at 10:13 AM, Manman Ren <mren at apple.com> wrote: > > More details please :] > What do you mean by "name the metadata"? Are you referring to the name field > of the MDNode? Using named metadata rather than unnamed metadata. rather than having: !llvm.hardref = !{metadata !"foo.h::myClass", !3, metadata !"bar.h:myEnum", !4} ... !3 = ...; !4 = ...; we could simply have: !llvm.hardref.foo.h.myClass = ...; !llvm.hardref.bar.h.myClass = ...; or something like that. (assuming solution (b), in solution (a) it'd look more like &quot...
2013 Jun 21
3
[LLVMdev] Proposal: type uniquing of debug info for LTO
More details please :] What do you mean by "name the metadata"? Are you referring to the name field of the MDNode? Thanks, Manman On Jun 21, 2013, at 7:19 AM, David Blaikie wrote: > > On Jun 21, 2013 1:19 AM, "Jeremy Lakeman" <Jeremy.Lakeman at gmail.com> wrote: > > > > Wouldn't it be simpler to name the metadata based on the hash of the content?