Displaying 8 results from an estimated 8 matches for "hagerti".
Did you mean:
hagerty
2015 Jan 08
5
RFC: getifexists() {was [Bug 16065] "exists" ...}
In November, we had a "bug repository conversation"
with Peter Hagerty and myself:
https://bugs.r-project.org/bugzilla/show_bug.cgi?id=16065
where the bug report title started with
--->> "exists" is a bottleneck for dispatch and package loading, ...
Peter proposed an extra simplified and henc faster version of exists(),
and I commented
> --- Comment #2
2002 Feb 27
5
Machine trust account reqd in 2.2.3a?
Greetings,
I was reading over the documentation online for using SAMBA as a PDC, and
in the section about creating machine trust accounts is talks about having
to add machine accounts to the /etc/passwd file. The text also mentions
that future versions of SAMBA will remove this requirement:
"Because Samba requires machine accounts to possess a UNIX uid from which
an Windows NT SID can
2015 Jan 08
4
RFC: getifexists() {was [Bug 16065] "exists" ...}
If we do add an argument to get(), then it should be named consistently
with the ifnotfound argument of mget(). As mentioned, the possibility of a
NULL value is problematic. One solution is a sentinel value that indicates
an unbound value (like R_UnboundValue).
But another idea (and one pretty similar to John's) is to follow the SYMSXP
design at the C level, where there is a structure that
2015 Jan 08
0
RFC: getifexists() {was [Bug 16065] "exists" ...}
Adding an optional argument to get (and mget) like
val <- get(name, where, ..., value.if.not.found=NULL ) (*)
would be useful for many. HOWEVER, it is possible that there could be
some confusion here: (*) can give a NULL because either x exists and
has value NULL, or because x doesn't exist. If that matters, the user
would need to be careful about specifying a value.if.not.found
2015 Jan 08
1
RFC: getifexists() {was [Bug 16065] "exists" ...}
On 08/01/2015 9:03 AM, John Nolan wrote:
> Adding an optional argument to get (and mget) like
>
> val <- get(name, where, ..., value.if.not.found=NULL ) (*)
That would be a bad idea, as it would change behaviour of existing uses
of get(). What I suggested would not
give a default. If the arg was missing, we'd get the old behaviour, if
the arg was present, we'd use it.
2015 Jan 08
0
RFC: getifexists() {was [Bug 16065] "exists" ...}
On Thu, 8 Jan 2015, Michael Lawrence wrote:
> If we do add an argument to get(), then it should be named consistently
> with the ifnotfound argument of mget(). As mentioned, the possibility of a
> NULL value is problematic. One solution is a sentinel value that indicates
> an unbound value (like R_UnboundValue).
A null default is fine -- it's a default; if it isn't right for
2015 Jan 08
1
RFC: getifexists() {was [Bug 16065] "exists" ...}
> Adding an optional argument to get (and mget) like
> val <- get(name, where, ..., value.if.not.found=NULL ) (*)
> would be useful for many. HOWEVER, it is possible that there could be
> some confusion here: (*) can give a NULL because either x exists and
> has value NULL, or because x doesn't exist. If that matters, the user
> would need to be careful about
2015 Jan 08
2
RFC: getifexists() {was [Bug 16065] "exists" ...}
On Thu, Jan 8, 2015 at 11:57 AM, <luke-tierney at uiowa.edu> wrote:
> On Thu, 8 Jan 2015, Michael Lawrence wrote:
>
> If we do add an argument to get(), then it should be named consistently
>> with the ifnotfound argument of mget(). As mentioned, the possibility of a
>> NULL value is problematic. One solution is a sentinel value that indicates
>> an unbound value