Displaying 6 results from an estimated 6 matches for "getcurdebugloc".
2012 Aug 27
2
[LLVMdev] FW: RFC: Supporting different sized address space arithmetic
...> Micah,
>
> There are a number of variable names in this patch that don't follow
> the naming convention (which specifies that they should start with an
> uppercase letter).
>
> > if (PtrBits < 64)
> > - OffsVal = DAG.getNode(ISD::TRUNCATE, getCurDebugLoc(),
> > - TLI.getPointerTy(),
> > + OffsVal = DAG.getNode(ISD::TRUNCATE, getCurDebugLoc(),
> > PtrTy, DAG.getConstant(Offs, MVT::i64));
>
> This is not necessarily specific to your patch, but can you explain the
> special role of 64...
2012 Aug 24
0
[LLVMdev] FW: RFC: Supporting different sized address space arithmetic
Micah,
There are a number of variable names in this patch that don't follow
the naming convention (which specifies that they should start with an
uppercase letter).
> if (PtrBits < 64)
> - OffsVal = DAG.getNode(ISD::TRUNCATE, getCurDebugLoc(),
> - TLI.getPointerTy(),
> + OffsVal = DAG.getNode(ISD::TRUNCATE, getCurDebugLoc(),
> PtrTy, DAG.getConstant(Offs, MVT::i64));
This is not necessarily specific to your patch, but can you explain the
special role of 64-bits here?
Thanks again,
Hal...
2012 Aug 24
5
[LLVMdev] FW: RFC: Supporting different sized address space arithmetic
> -----Original Message-----
> From: Villmow, Micah
> Sent: Friday, August 24, 2012 2:56 PM
> To: 'Eli Friedman'
> Cc: LLVM Developers Mailing List
> Subject: RE: [LLVMdev] RFC: Supporting different sized address space
> arithmetic
>
> Eli,
> There is a patch that implements the beginning what I think is the
> correct approach to support the backend
2012 Aug 27
0
[LLVMdev] FW: RFC: Supporting different sized address space arithmetic
...here are a number of variable names in this patch that don't follow
> > the naming convention (which specifies that they should start with
> > an uppercase letter).
> >
> > > if (PtrBits < 64)
> > > - OffsVal = DAG.getNode(ISD::TRUNCATE, getCurDebugLoc(),
> > > - TLI.getPointerTy(),
> > > + OffsVal = DAG.getNode(ISD::TRUNCATE, getCurDebugLoc(),
> > > PtrTy, DAG.getConstant(Offs, MVT::i64));
> >
> > This is not necessarily specific to your patch, but can you explain
&g...
2012 Aug 25
0
[LLVMdev] FW: RFC: Supporting different sized address space arithmetic
....getPointerTy(dyn_cast<PointerType>(
+ SV->getType())->getAddressSpace());
+ if (PtrVT != NewPtrVT) {
+ // Check to see if we want to change the size of the pointer
+ // based on the address space and if so extend or truncate the pointer.
+ Ptr = DAG.getSExtOrTrunc(Ptr, getCurDebugLoc(), NewPtrVT);
+ PtrVT = NewPtrVT;
+ }
This situation should be impossible: you're checking whether a pointer
has the same type as itself. If you're hitting this, it's just a
symptom of a bug elsewhere. The same applies to other places you
perform this sort of check outside of &qu...
2012 Aug 30
2
[LLVMdev] FW: RFC: Supporting different sized address space arithmetic
...terType>(
> + SV->getType())->getAddressSpace());
> + if (PtrVT != NewPtrVT) {
> + // Check to see if we want to change the size of the pointer
> + // based on the address space and if so extend or truncate the
> pointer.
> + Ptr = DAG.getSExtOrTrunc(Ptr, getCurDebugLoc(), NewPtrVT);
> + PtrVT = NewPtrVT;
> + }
>
> This situation should be impossible: you're checking whether a pointer
> has the same type as itself. If you're hitting this, it's just a
> symptom of a bug elsewhere. The same applies to other places you
> perfor...