Displaying 7 results from an estimated 7 matches for "drm_underscan_state".
2018 Nov 22
0
[PATCH v3 1/3] drm/connector: Add generic underscan properties
...e (auto means apply underscan for HDMI
monitors only)
- Fix description of vborder/hborder:
right_border = left_border = hborder
top_border = bottom_border = vborder
not
right_border = left_border = hborder / 2
top_border = bottom_border = vborder / 2
- Rename drm_underscan into drm_underscan_state
---
drivers/gpu/drm/drm_atomic_uapi.c | 12 +++
drivers/gpu/drm/drm_connector.c | 127 ++++++++++++++++++++++++++++++
include/drm/drm_connector.h | 80 +++++++++++++++++++
3 files changed, 219 insertions(+)
diff --git a/drivers/gpu/drm/drm_atomic_uapi.c b/drivers/gpu/drm/drm_atomic_uapi...
2018 Nov 22
1
[PATCH v3 1/3] drm/connector: Add generic underscan properties
...r HDMI
> monitors only)
>- Fix description of vborder/hborder:
> right_border = left_border = hborder
> top_border = bottom_border = vborder
> not
> right_border = left_border = hborder / 2
> top_border = bottom_border = vborder / 2
>- Rename drm_underscan into drm_underscan_state
>---
> drivers/gpu/drm/drm_atomic_uapi.c | 12 +++
> drivers/gpu/drm/drm_connector.c | 127 ++++++++++++++++++++++++++++++
> include/drm/drm_connector.h | 80 +++++++++++++++++++
> 3 files changed, 219 insertions(+)
>
>diff --git a/drivers/gpu/drm/drm_atomic_uapi.c b/dri...
2018 Nov 22
5
[PATCH v3 0/3] drm/connector: Provide generic support for underscan
Hello,
This is an attempt at providing generic support for underscan connector
props. We already have 3 drivers defining the same underscan, underscan
vborder and underscan hborder properties (amd, radeon and nouveau) and
I am about to add a new one, hence my proposal to put the prop parsing
code in the core and add ->underscan fields to drm_connector_state.
This v3 was based on the "VC4
2018 May 11
5
[PATCH v2 0/4] drm/connector: Provide generic support for underscan
Hello,
This is an attempt at providing generic support for underscan connector
props. We already have 3 drivers defining the same underscan, underscan
vborder and underscan hborder properties (amd, radeon and nouveau) and
I am about to add a new one, hence my proposal to put the prop parsing
code in the core and add ->underscan fields to drm_connector_state.
In this v2, I also converted the
2018 May 07
2
[PATCH 1/3] drm/connector: Add generic underscan properties
...gt; + * order to cover fit in the display connected through this connector. Most of
> + * the time used to address situations where the display borders are hidden.
> + * Can also be used to compensate overscan done on the display side.
> + */
> +struct drm_underscan {
I'd call this drm_underscan_state, similar to how we have
drm_tv_connector_state.
> + /**
> + * @mode: Underscan mode.
> + */
> + enum drm_underscan_mode mode;
> +
> + /**
> + * @hborder: Horizontal border. This values encodes both the left and
> + * right borders: left_border = right_border = hborder /...
2018 May 07
0
[PATCH 1/3] drm/connector: Add generic underscan properties
...the display connected through this connector. Most of
> > + * the time used to address situations where the display borders are hidden.
> > + * Can also be used to compensate overscan done on the display side.
> > + */
> > +struct drm_underscan {
>
> I'd call this drm_underscan_state, similar to how we have
> drm_tv_connector_state.
>
> > + /**
> > + * @mode: Underscan mode.
> > + */
> > + enum drm_underscan_mode mode;
> > +
> > + /**
> > + * @hborder: Horizontal border. This values encodes both the left and
> > + * rig...
2018 May 07
8
[PATCH 0/3] drm/connector: Provide generic support for underscan
Hello,
This is an attempt at providing generic support for underscan connector
props. We already have 3 drivers defining the same underscan, underscan
vborder and underscan hborder properties (amd, radeon and nouveau) and
I am about to add a new one, hence my proposal to put the prop parsing
code in the core and add ->underscan fields to drm_connector_state.
Note that I use this new