search for: do_add_early_random

Displaying 5 results from an estimated 5 matches for "do_add_early_random".

2014 Jul 14
2
[RFC PATCH 1/3] hw_random: allow RNG devices to give early randomness after a delay
On Mon, Jul 14, 2014 at 10:05:19AM +0530, Amit Shah wrote: > Some RNG devices may not be ready to give early randomness at probe() > time, and hence lose out on the opportunity to contribute to system > randomness at boot- or device hotplug- time. > > This commit schedules a delayed work item for such devices, and fetches > early randomness after a delay. Currently the delay is
2014 Jul 14
2
[RFC PATCH 1/3] hw_random: allow RNG devices to give early randomness after a delay
On Mon, Jul 14, 2014 at 10:05:19AM +0530, Amit Shah wrote: > Some RNG devices may not be ready to give early randomness at probe() > time, and hence lose out on the opportunity to contribute to system > randomness at boot- or device hotplug- time. > > This commit schedules a delayed work item for such devices, and fetches > early randomness after a delay. Currently the delay is
2014 Jul 14
0
[RFC PATCH 1/3] hw_random: allow RNG devices to give early randomness after a delay
...wrng *rng = container_of(work, struct hwrng, dwork.work); > > + > > + get_early_randomness(rng); > > +} > > + > > +static void add_early_randomness(struct hwrng *rng) > > The add/get naming seems awkward in the above hunks. Yea; I felt that too. I thought of a do_add_early_randomness() instead, but that seemed awkward too. I forgot to mention I was planning on revisiting this naming for v1. > > +{ > > + if (!(rng->flags & HWRNG_DELAY_READ_AT_INIT)) > > + return get_early_randomness(rng); > > + > > + schedule_delayed_work(&rng->...
2014 Jul 18
2
[RFC PATCH 1/3] hw_random: allow RNG devices to give early randomness after a delay
...dwork.work); > > > + > > > + get_early_randomness(rng); > > > +} > > > + > > > +static void add_early_randomness(struct hwrng *rng) > > > > The add/get naming seems awkward in the above hunks. > > Yea; I felt that too. I thought of a do_add_early_randomness() > instead, but that seemed awkward too. I forgot to mention I was > planning on revisiting this naming for v1. > > > > +{ > > > + if (!(rng->flags & HWRNG_DELAY_READ_AT_INIT)) > > > + return get_early_randomness(rng); > > > + > > &g...
2014 Jul 18
2
[RFC PATCH 1/3] hw_random: allow RNG devices to give early randomness after a delay
...dwork.work); > > > + > > > + get_early_randomness(rng); > > > +} > > > + > > > +static void add_early_randomness(struct hwrng *rng) > > > > The add/get naming seems awkward in the above hunks. > > Yea; I felt that too. I thought of a do_add_early_randomness() > instead, but that seemed awkward too. I forgot to mention I was > planning on revisiting this naming for v1. > > > > +{ > > > + if (!(rng->flags & HWRNG_DELAY_READ_AT_INIT)) > > > + return get_early_randomness(rng); > > > + > > &g...