search for: devtools

Displaying 20 results from an estimated 179 matches for "devtools".

2013 Feb 26
2
[LLVMdev] make error building llvm/clang 3.2 on Linux
...7;include/i386-linux-gnu -L/usr/lib/i386-linux-gnu test.c Here's the output from that: *** $ gcc -v -isystem /usr/include/i386-linux-gnu -L/usr/lib/i386-linux-gnu test.c Using built-in specs. COLLECT_GCC=gcc COLLECT_LTO_WRAPPER=/home/youngmj/DevTools/Gnu_Compiler_Collection-gcc/Version_4.7.2/install/libexec/gcc/i686-pc-linux-gnu/4.7.2/lto-wrapper Target: i686-pc-linux-gnu Configured with: /home/youngmj/DevTools/Gnu_Compiler_Collection-gcc/Version_4.7.2/source/gcc-4.7.2/configure...
2013 Feb 24
0
[LLVMdev] make error building llvm/clang 3.2 on Linux
I'm continuing this here in llvm-dev since the thread was started here, but, in hindsight, it may have been better in cfe-dev, because the problem seems to be related to clang. I turned on "verbose" mode in make (VERBOSE=1 TOOL_VERBOSE=1) and found that it is clang, not gcc, that is being used at this point in the make. Based on the command issued (particularly with the --sysroot
2012 Mar 02
0
devtools 0.6
# devtools The aim of `devtools` is to make your life as a package developer easier by providing R functions that simplify many common tasks. Devtools is opinionated about how to do package development, and requires that you use `roxygen2` for documentation and `testthat` for testing. Future version will rel...
2012 Mar 02
0
devtools 0.6
# devtools The aim of `devtools` is to make your life as a package developer easier by providing R functions that simplify many common tasks. Devtools is opinionated about how to do package development, and requires that you use `roxygen2` for documentation and `testthat` for testing. Future version will rel...
2013 Feb 21
4
[LLVMdev] make error building llvm/clang 3.2 on Linux
...tribution tarballs, but I ran into this build error that's got me really puzzled. My platform is Linux - 32-bit Ubuntu (12.04) running on a PC. Here's the (abbreviated) output from make: *************************************** ... make[3]: Entering directory `/home/youngmj/DevTools/LLVM/Version_3.2/build/tools/clang/runtime' make[4]: Entering directory `/home/youngmj/DevTools/LLVM/Version_3.2/build/tools/clang/runtime/compiler-rt' make[5]: Entering directory `/home/youngmj/DevTools/LLVM...
2014 Apr 28
1
Will Devtools-1.1 or later become part of SCL?
I've already installed devtools-1.1 from Tru Huynh. http://people.centos.org/tru/devtools-1.1/ Thank You Tru. gcc 4.7.2 is so much newer than stock 4.4.7. (much better C++11 support) Why is devtools-1.1 not officially part of CentOS SCL? I know devtools-2.0 still has issues but 1.1 would bring us on par with...
2012 Jan 27
2
Unable to reload Rdoc
...D BUILD, R CMD INSTALL then in the same R session, reload the library & lookup a man page, I always get this error: Error in fetch(key) : internal error -3 in R_decompress1 I've tried all ways of reloading the package that i'm aware of: detach then library unloadNamespace then library devtools::install devtools::reload all lead to the error. I see from ?detach: ... So detaching and re-attaching a package may not refresh some or all components of the package, and is inadvisable. restarting the R session results in loading the updated man file, but do you have any ideas how to word arou...
2013 Dec 20
3
error con install_github() del paquete devtools
Hola a todos. Estoy intentando instalar el paquete likert utilizando devtools y obtengo el siguiente error library(devtools) install_github('likert','jbryer') Installing github repo(s) likert/master from jbryer Downloading likert.zip from https://github.com/jbryer/likert/archive/master.zip Error en function (type, msg, asError =...
2013 Dec 20
4
error con install_github() del paquete devtools
...or curro si funciona y tb tiene linux. Seguiré investigando has probado con: install_github('paquete",username='usuario')? 2013/12/20 Jose Luis Cañadas Reche <canadasreche@gmail.com>: > Hola a todos. > > Estoy intentando instalar el paquete likert utilizando devtools y obtengo el > siguiente error > > library(devtools) > install_github('likert','jbryer') > Installing github repo(s) likert/master from jbryer > Downloading likert.zip from > https://github.com/jbryer/likert/archive/master.zip > Er...
2013 Dec 20
0
error con install_github() del paquete devtools
Hola, Puedes hacerlo sin devtools. Descargas el ZIP del repositorio, lo descomprimes, instalas el paquete que hay en CRAN para tener todas las dependencias instaladas y finalmente instalas el paquete en la versión de GitHub. tmp <- paste0(tempdir(), '/likert.zip') download.file('https://github.com/jb...
2012 Mar 15
0
Make Asset Pipeline compatible with Chrome DevTools Autosave
https://github.com/NV/chrome-devtools-autosave doesn’t play nice with Asset Pipeline. https://github.com/NV/chrome-devtools-autosave/issues/27 The culprit of the problem is in the asset’s URLs. I cannot decipher a file path by its URL. For instance, /assets/main.css?body=1 could be either app/ass...
2014 Sep 14
1
default devtools enabled for users
Hi! I want to make the default environment for users the environment of devtoolset .. and i am thinking to do it this way: 1. make /bin/bash-devtools with the content scl enable devtoolset-2 bash "$@" 2. change for the prospective users the shell from /bin/bash to /bin/bash-devtoolset Is this the best way? Do anyone see or know of any pitfa...
2017 Jul 12
1
devtools::check "hangs"
Hi, checking my package with check from devtools leads to the output Functions with \usage entries need to have the appropriate \alias entries, and all their arguments documented. The \usage entries must correspond to syntactically valid R code. See chapter ?Writing R documentation files? in the ?Writing R Extensions? manual. * checking Rd conte...
2013 Dec 20
0
error con install_github() del paquete devtools
has probado con: install_github('paquete",username='usuario')? 2013/12/20 Jose Luis Cañadas Reche <canadasreche en gmail.com>: > Hola a todos. > > Estoy intentando instalar el paquete likert utilizando devtools y obtengo el > siguiente error > > library(devtools) > install_github('likert','jbryer') > Installing github repo(s) likert/master from jbryer > Downloading likert.zip from > https://github.com/jbryer/likert/archive/master.zip > Er...
2013 Dec 20
0
error con install_github() del paquete devtools
...nux. > Seguiré investigando > has probado con: install_github('paquete",username='usuario')? > > 2013/12/20 Jose Luis Cañadas Reche <canadasreche@gmail.com>: > > Hola a todos. > > > > Estoy intentando instalar el paquete likert utilizando devtools y obtengo > el > > siguiente error > > > > library(devtools) > > install_github('likert','jbryer') > > Installing github repo(s) likert/master from jbryer > > Downloading likert.zip from > > https://github.com/jbryer/l...
2017 Nov 07
2
Problem with r project in ubuntu xenial
For anyone who sees this conversation. There is a bug in installation of igraph in R language in Ubuntu. There is a solution in stackoverflow. We have to use the devtools. Write this code: install.packages("devtools") library(devtools) install_github("igraph/rigraph") If there are errors installing devtools just install any package that comments. On Nov 5, 2017 00:07, "George Balas" <gbalas07 at gmail.com> wrote: > -Well...
2013 Jul 19
2
rNVD3
Hola a todos ¿alguien sabe como instalar rNVD3 y ramnathv ?. Siguiendo estos pasos no soy en absoluto capaz. require(devtools) install_github('rNVD3', 'ramnathv') He intentado guardar el archivo zip, pero tampoco he podido. No sé que se me escapa. Saludos y buen verano!! pepeceb ________________________________ [[alternative HTML version deleted]]
2017 Aug 18
2
R Issues with packages
so I am trying to get my R setup to run this users package. Any help would be great THANKS devtools::install_github(repo = "dadrivr/ffanalytics") I get this devtools::install_github(repo = "dadrivr/ffanalytics") Downloading GitHub repo dadrivr/ffanalytics at master from URL https://api.github.com/repos/dadrivr/ffanalytics/zipball/maste...
2018 Feb 19
4
Include pre-existing PDF files as vignettes in an R package?
...to know if there's a way to include such PDF files as vignettes. We *do* have the source files for the PDF files in question, but it would be tedious to convert those source files to Rmd format. My first thought was simply to add the PDF files to the .../vignettes subdirectory and run the devtools::build_vignettes() function (mentioned in the Broman tutorial), but that doesn't work. I.e., the PDF files don't appear in the list of vignettes for the package. And after running devtools::build_vignettes I see that there's a lot of additional stuff in: ...lib/R/site-lib...
2013 Dec 22
0
error con install_github() del paquete devtools
A mi no me dio problemas. Intenta instalar nuevamente RCurl. > library(devtools) > install_github('likert','jbryer') Installing github repo likert/master from jbryer Downloading likert.zip from https://github.com/jbryer/likert/archive/master.zip Installing package from /tmp/RtmpJuHsLY/likert.zip arguments 'minimize...