Displaying 3 results from an estimated 3 matches for "c_supports_".
2020 Sep 22
2
Unifying CMake variable names used in checks across subprojects
...r most flags and library checks.
I think that this is really unnecessary and could be easily improved by
unifying CMake variable names used in checks across subprojects to benefit
from caching.
I've looked at naming conventions used across all subprojects and I'm
proposing the following:
C_SUPPORTS_${mangled_name}_FLAG for check_c_compiler_flag
CXX_SUPPORTS_${mangled_name}_FLAG for check_cxx_compiler_flag
HAVE_${mangled_name} for check_library_exists
Note: It'd be more consistent for check_library_exists to
use HAS_${mangled_name}_LIB but that's going to cause more churn in LLVM so
th...
2020 Sep 22
2
Unifying CMake variable names used in checks across subprojects
...s.
>
> I think that this is really unnecessary and could be easily improved by unifying CMake variable names used in checks across subprojects to benefit from caching.
>
> I've looked at naming conventions used across all subprojects and I'm proposing the following:
>
> C_SUPPORTS_${mangled_name}_FLAG for check_c_compiler_flag
> CXX_SUPPORTS_${mangled_name}_FLAG for check_cxx_compiler_flag
> HAVE_${mangled_name} for check_library_exists
IMO, these issues are a manifestation of the fact that we basically have (at least) 4 times the same overall logic, once for each runt...
2020 Sep 25
2
Unifying CMake variable names used in checks across subprojects
...think that this is really unnecessary and could be easily improved by unifying CMake variable names used in checks across subprojects to benefit from caching.
>>
>> I've looked at naming conventions used across all subprojects and I'm proposing the following:
>>
>> C_SUPPORTS_${mangled_name}_FLAG for check_c_compiler_flag
>> CXX_SUPPORTS_${mangled_name}_FLAG for check_cxx_compiler_flag
>> HAVE_${mangled_name} for check_library_exists
>
> IMO, these issues are a manifestation of the fact that we basically have (at least) 4 times the same overall logic,...