search for: _split_

Displaying 17 results from an estimated 17 matches for "_split_".

Did you mean: _split
2018 Dec 07
2
[RFC 3/3] virtio_ring: use new vring flags
On Fri, Dec 07, 2018 at 04:48:42PM +0800, Tiwei Bie wrote: > Switch to using the _SPLIT_ and _PACKED_ variants of vring flags > in split ring and packed ring respectively. > > Signed-off-by: Tiwei Bie <tiwei.bie at intel.com> > --- > @@ -502,7 +505,8 @@ static inline int virtqueue_add_split(struct virtqueue *_vq, > } > } > /* Last one doesn't c...
2018 Dec 07
2
[RFC 3/3] virtio_ring: use new vring flags
On Fri, Dec 07, 2018 at 04:48:42PM +0800, Tiwei Bie wrote: > Switch to using the _SPLIT_ and _PACKED_ variants of vring flags > in split ring and packed ring respectively. > > Signed-off-by: Tiwei Bie <tiwei.bie at intel.com> > --- > @@ -502,7 +505,8 @@ static inline int virtqueue_add_split(struct virtqueue *_vq, > } > } > /* Last one doesn't c...
2018 Dec 07
7
[RFC 0/3] virtio_ring: define flags as shifts consistently
This is a follow up of the discussion in this thread: https://patchwork.ozlabs.org/patch/1001015/#2042353 Tiwei Bie (3): virtio_ring: define flags as shifts consistently virtio_ring: add VIRTIO_RING_NO_LEGACY virtio_ring: use new vring flags drivers/virtio/virtio_ring.c | 100 ++++++++++++++++++------------- include/uapi/linux/virtio_ring.h | 61 +++++++++++++------ 2 files changed,
2018 Dec 07
7
[RFC 0/3] virtio_ring: define flags as shifts consistently
This is a follow up of the discussion in this thread: https://patchwork.ozlabs.org/patch/1001015/#2042353 Tiwei Bie (3): virtio_ring: define flags as shifts consistently virtio_ring: add VIRTIO_RING_NO_LEGACY virtio_ring: use new vring flags drivers/virtio/virtio_ring.c | 100 ++++++++++++++++++------------- include/uapi/linux/virtio_ring.h | 61 +++++++++++++------ 2 files changed,
2018 Dec 07
1
[RFC 2/3] virtio_ring: add VIRTIO_RING_NO_LEGACY
...ZE, VRING_USED_ALIGN_SIZE and VRING_DESC_ALIGN_SIZE > are not pre-virtio 1.0, but can also be disabled by VIRTIO_RING_NO_LEGACY > in this patch, because their names are not consistent with other names. > Not sure whether this is a good idea. If we want this, we may also want > to define _SPLIT_ version for them. I don't think it's a good idea to have alignment in there - the point of NO_LEGACY is to help catch bugs not to sanitize coding style IMHO. And spec calls "legacy" the 0.X interfaces, let's not muddy the waters. > > include/uapi/linux/virtio_ring.h...
2018 Nov 30
2
[PATCH net-next v3 01/13] virtio: add packed ring types and macros
...ifts? > > > > > > > > Yeah, it was suggested to use shifts, as _F_ should be a bit > > > > number, not a shifted value: > > > > > > > > https://patchwork.ozlabs.org/patch/942296/#1989390 > > > > > > But let's add a _SPLIT_ variant that uses shifts consistently. > > > > Maybe we could avoid adding SPLIT and PACKED, but define as follow: > > > > #define VRING_DESC_F_INDIRECT_SHIFT 2 > > #define VRING_DESC_F_INDIRECT (1ull << VRING_DESC_F_INDIRECT_SHIFT) > > > > #defin...
2018 Nov 30
2
[PATCH net-next v3 01/13] virtio: add packed ring types and macros
...ifts? > > > > > > > > Yeah, it was suggested to use shifts, as _F_ should be a bit > > > > number, not a shifted value: > > > > > > > > https://patchwork.ozlabs.org/patch/942296/#1989390 > > > > > > But let's add a _SPLIT_ variant that uses shifts consistently. > > > > Maybe we could avoid adding SPLIT and PACKED, but define as follow: > > > > #define VRING_DESC_F_INDIRECT_SHIFT 2 > > #define VRING_DESC_F_INDIRECT (1ull << VRING_DESC_F_INDIRECT_SHIFT) > > > > #defin...
2018 Nov 30
2
[PATCH net-next v3 01/13] virtio: add packed ring types and macros
...h, it was suggested to use shifts, as _F_ should be a bit > > > > > > number, not a shifted value: > > > > > > > > > > > > https://patchwork.ozlabs.org/patch/942296/#1989390 > > > > > > > > > > But let's add a _SPLIT_ variant that uses shifts consistently. > > > > > > > > Maybe we could avoid adding SPLIT and PACKED, but define as follow: > > > > > > > > #define VRING_DESC_F_INDIRECT_SHIFT 2 > > > > #define VRING_DESC_F_INDIRECT (1ull << VRING_...
2018 Nov 30
2
[PATCH net-next v3 01/13] virtio: add packed ring types and macros
...h, it was suggested to use shifts, as _F_ should be a bit > > > > > > number, not a shifted value: > > > > > > > > > > > > https://patchwork.ozlabs.org/patch/942296/#1989390 > > > > > > > > > > But let's add a _SPLIT_ variant that uses shifts consistently. > > > > > > > > Maybe we could avoid adding SPLIT and PACKED, but define as follow: > > > > > > > > #define VRING_DESC_F_INDIRECT_SHIFT 2 > > > > #define VRING_DESC_F_INDIRECT (1ull << VRING_...
2018 Nov 30
4
[PATCH net-next v3 01/13] virtio: add packed ring types and macros
On 2018/11/21 ??6:03, Tiwei Bie wrote: > Add types and macros for packed ring. > > Signed-off-by: Tiwei Bie <tiwei.bie at intel.com> > --- > include/uapi/linux/virtio_config.h | 3 +++ > include/uapi/linux/virtio_ring.h | 52 ++++++++++++++++++++++++++++++++++++++ > 2 files changed, 55 insertions(+) > > diff --git a/include/uapi/linux/virtio_config.h
2018 Nov 30
4
[PATCH net-next v3 01/13] virtio: add packed ring types and macros
On 2018/11/21 ??6:03, Tiwei Bie wrote: > Add types and macros for packed ring. > > Signed-off-by: Tiwei Bie <tiwei.bie at intel.com> > --- > include/uapi/linux/virtio_config.h | 3 +++ > include/uapi/linux/virtio_ring.h | 52 ++++++++++++++++++++++++++++++++++++++ > 2 files changed, 55 insertions(+) > > diff --git a/include/uapi/linux/virtio_config.h
2018 Dec 07
0
[RFC 2/3] virtio_ring: add VIRTIO_RING_NO_LEGACY
...VRING_AVAIL_ALIGN_SIZE, VRING_USED_ALIGN_SIZE and VRING_DESC_ALIGN_SIZE are not pre-virtio 1.0, but can also be disabled by VIRTIO_RING_NO_LEGACY in this patch, because their names are not consistent with other names. Not sure whether this is a good idea. If we want this, we may also want to define _SPLIT_ version for them. include/uapi/linux/virtio_ring.h | 4 ++++ 1 file changed, 4 insertions(+) diff --git a/include/uapi/linux/virtio_ring.h b/include/uapi/linux/virtio_ring.h index 9b0c0d92ab62..192573827850 100644 --- a/include/uapi/linux/virtio_ring.h +++ b/include/uapi/linux/virtio_ring.h @@ -...
2018 Dec 08
0
[RFC 3/3] virtio_ring: use new vring flags
On Fri, Dec 07, 2018 at 01:10:48PM -0500, Michael S. Tsirkin wrote: > On Fri, Dec 07, 2018 at 04:48:42PM +0800, Tiwei Bie wrote: > > Switch to using the _SPLIT_ and _PACKED_ variants of vring flags > > in split ring and packed ring respectively. > > > > Signed-off-by: Tiwei Bie <tiwei.bie at intel.com> > > --- > > @@ -502,7 +505,8 @@ static inline int virtqueue_add_split(struct virtqueue *_vq, > > } > >...
2018 Nov 30
0
[PATCH net-next v3 01/13] virtio: add packed ring types and macros
...ious flags, any reason for using shifts? > > > > > > Yeah, it was suggested to use shifts, as _F_ should be a bit > > > number, not a shifted value: > > > > > > https://patchwork.ozlabs.org/patch/942296/#1989390 > > > > But let's add a _SPLIT_ variant that uses shifts consistently. > > Maybe we could avoid adding SPLIT and PACKED, but define as follow: > > #define VRING_DESC_F_INDIRECT_SHIFT 2 > #define VRING_DESC_F_INDIRECT (1ull << VRING_DESC_F_INDIRECT_SHIFT) > > #define VRING_DESC_F_AVAIL_SHIFT 7 > #...
2018 Nov 30
0
[PATCH net-next v3 01/13] virtio: add packed ring types and macros
...; > > > > Yeah, it was suggested to use shifts, as _F_ should be a bit > > > > > number, not a shifted value: > > > > > > > > > > https://patchwork.ozlabs.org/patch/942296/#1989390 > > > > > > > > But let's add a _SPLIT_ variant that uses shifts consistently. > > > > > > Maybe we could avoid adding SPLIT and PACKED, but define as follow: > > > > > > #define VRING_DESC_F_INDIRECT_SHIFT 2 > > > #define VRING_DESC_F_INDIRECT (1ull << VRING_DESC_F_INDIRECT_SHIFT) &g...
2018 Nov 30
0
[PATCH net-next v3 01/13] virtio: add packed ring types and macros
...e shifts, as _F_ should be a bit > > > > > > > number, not a shifted value: > > > > > > > > > > > > > > https://patchwork.ozlabs.org/patch/942296/#1989390 > > > > > > > > > > > > But let's add a _SPLIT_ variant that uses shifts consistently. > > > > > > > > > > Maybe we could avoid adding SPLIT and PACKED, but define as follow: > > > > > > > > > > #define VRING_DESC_F_INDIRECT_SHIFT 2 > > > > > #define VRING_DESC_F_INDIRE...
2018 Dec 07
0
[RFC 3/3] virtio_ring: use new vring flags
Switch to using the _SPLIT_ and _PACKED_ variants of vring flags in split ring and packed ring respectively. Signed-off-by: Tiwei Bie <tiwei.bie at intel.com> --- drivers/virtio/virtio_ring.c | 100 +++++++++++++++++++++-------------- 1 file changed, 59 insertions(+), 41 deletions(-) diff --git a/drivers/virtio/virti...